source: projects/specs/trunk/lib/libk/libkgapi/libkgapi-vl.spec @ 8252

Revision 8252, 3.2 KB checked in by Takemikaduchi, 10 years ago (diff)

KDE-4.12.2

Line 
1Name:    libkgapi
2Summary: Google APIs for KDE
3Summary(ja): KDE 向け Google API 集
4Version: 2.0.2
5Release: 1%{?_dist_release}
6
7License: GPLv2+
8Group:   System Environment/Libraries
9URL:     https://projects.kde.org/projects/extragear/libs/libkgapi
10
11Source0: ftp://ftp.kde.org/pub/kde/stable/%{name}/%{version}/src/%{name}-%{version}.tar.xz
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: kdelibs-devel >= 4.7.0
15BuildRequires: kdepimlibs-devel >= 4.6
16BuildRequires: libkipi-devel
17BuildRequires: qjson-devel
18BuildRequires: soprano-devel
19BuildRequires: libboost-devel
20
21Requires: kdelibs >= 4.7.0
22
23Vendor: Project Vine
24Distribution: Vine Linux
25
26%description
27LibKGAPI (previously called LibKGoogle) is a C++ library that implements APIs for
28various Google services.
29
30Currently supported APIs:
31  - Calendar API v3 (https://developers.google.com/google-apps/calendar)
32  - Contacts API v3 (https://developers.google.com/google-apps/contacts/v3/)
33  - Tasks API v1 (https://developers.google.com/google-apps/tasks)
34
35
36%package devel
37Summary:  Development files for %{name}
38Summary(ja): %{name} の開発用ファイル
39Group: Development/Libraries
40Requires: %{name} = %{version}-%{release}
41Requires: kdelibs-devel
42
43%description devel
44%{summary}.
45
46
47%prep
48%setup -q
49
50%build
51mkdir -p %{_target_platform}
52pushd %{_target_platform}
53%cmake \
54    -DCMAKE_BUILD_TYPE=release \
55    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
56    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
57    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
58    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
59    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
60    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
61    ..
62popd
63
64make %{?_smp_mflags} -C %{_target_platform}
65
66
67%install
68rm -rf $RPM_BUILD_ROOT
69
70make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
71
72
73%check
74export PKG_CONFIG_PATH=$RPM_BUILD_ROOT%{_datadir}/pkgconfig:$RPM_BUILD_ROOT%{_libdir}/pkgconfig
75pkg-config --modversion libkipi
76
77
78%post
79/sbin/ldconfig
80touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
81
82%posttrans
83gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
84
85%postun
86/sbin/ldconfig
87if [ $1 -eq 0 ] ; then
88    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
89    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
90fi
91
92
93%files
94%defattr(-,root,root,-)
95%doc LICENSE README
96%{_libdir}/libkgapi.so.*
97%{_libdir}/libkgapi2.so.*
98
99%files devel
100%defattr(-,root,root,-)
101%{_includedir}/kde4/%{name}
102%{_includedir}/kde4/%{name}2
103%{_includedir}/kde4/LibKGAPI2
104%{_libdir}/libkgapi.so
105%{_libdir}/libkgapi2.so
106%{_libdir}/cmake/LibKGAPI
107%{_libdir}/cmake/LibKGAPI2
108%{_libdir}/pkgconfig/%{name}.pc
109%{_libdir}/pkgconfig/%{name}2.pc
110
111
112%changelog
113* Sun Feb 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.2-1
114- new upstream release
115
116* Sat Jul 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.1-1
117- new upstream release
118
119* Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.4-1
120- new upstream release
121
122* Sun Nov 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.3-1
123- new upstream release
124
125* Mon Sep 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.2-1
126- new upstream release
127
128* Sun Aug 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.1-1
129- initial build
Note: See TracBrowser for help on using the repository browser.