source: projects/specs/trunk/lib/libk/libkdcraw/libkdcraw-vl.spec @ 6797

Revision 6797, 4.1 KB checked in by Takemikaduchi, 12 years ago (diff)

KDE-4.9.1

Line 
1Name:    libkdcraw
2Summary: A C++ interface around LibRaw library
3Summary(ja): LibRaw ライブラリ向けの C++ インターフェース
4Version: 4.9.1
5Release: 1%{?_dist_release}
6
7# libkdcraw is GPLv2+,
8# LibRaw(bundled) is LGPLv2
9# demosaic-pack GPLv2+ GPLv3+ (addons to libraw)
10License: GPLv2+ and LGPLv2 and GPLv3+
11URL:     https://projects.kde.org/projects/kde/kdegraphics/libs/libkdcraw
12Group:   System Environment/Libraries
13
14Source0: ftp://ftp.kde.org/pub/kde/unstable/%{version}/src/%{name}-%{version}.tar.xz
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: kdelibs4-devel >= %{version}
18BuildRequires: lcms-devel
19BuildRequires: libjpeg-devel
20
21Requires: kdelibs4 >= %{version}
22
23# when split occurred
24Conflicts: kdegraphics-libs < 4.6.95-10
25
26# upstream plans to unbundle when libraw-1.0 is released
27# see also http://mail.kde.org/pipermail/digikam-devel/2010-March/041682.html
28Provides: bundled(LibRaw)
29# deomosaic-pack addons to libraw
30Provides: bundled(LibRaw-demosaic-pack-GPL2)
31Provides: bundled(LibRaw-demosaic-pack-GPL3)
32
33%description
34Libkdcraw is a C++ interface around LibRaw library used to decode RAW
35picture files. More information about LibRaw can be found at
36http://www.libraw.org.
37
38%package devel
39Summary:  Development files for %{name}
40Summary(ja): %{name} の開発用ファイル
41Group:   Development/Libraries
42Requires: %{name} = %{version}-%{release}
43Requires: kdelibs4-devel
44
45%description devel
46%{summary}.
47
48
49%prep
50%setup -q
51
52# copy/rename a few things for easier inclusion as %%doc
53cp -a libraw/README README.libraw
54cp -a libraw/COPYRIGHT COPYRIGHT.libraw
55
56
57%build
58mkdir -p %{_target_platform}
59pushd %{_target_platform}
60%cmake \
61    -DCMAKE_BUILD_TYPE=release \
62    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
63    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
64    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
65    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
66    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
67    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
68    ..
69popd
70
71make %{?_smp_mflags} -C %{_target_platform}
72
73
74%install
75rm -rf %{buildroot}
76
77make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
78
79
80%check
81export PKG_CONFIG_PATH=%{buildroot}%{_datadir}/pkgconfig:%{buildroot}%{_libdir}/pkgconfig
82pkg-config --modversion libkdcraw
83make -C %{_target_platform}/test
84
85%post
86/sbin/ldconfig
87touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
88
89%posttrans
90gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
91
92%postun
93/sbin/ldconfig
94if [ $1 -eq 0 ] ; then
95touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
96gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
97fi
98
99
100%files
101%doc AUTHORS ChangeLog COPYING NEWS README TODO
102%doc COPYRIGHT.libraw README.libraw libraw/README.demosaic-packs libraw/LICENSE.LGPL
103%{_libdir}/libkdcraw.so.*
104%{_datadir}/kde4/apps/libkdcraw/
105%{_datadir}/icons/hicolor/*/*/*
106
107%files devel
108%{_libdir}/libkdcraw.so
109%{_libdir}/pkgconfig/libkdcraw.pc
110%{_includedir}/kde4/libkdcraw/
111
112
113%changelog
114* Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
115- new upstream release
116
117* Sun Aug 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
118- new upstream release
119
120* Sun Dec 18 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
121- new upstream release
122
123* Sat Oct 15 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.2-1
124- new upstream release
125
126* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-2
127- Initial build for Vine Linux
128
129* Tue Jul 26 2011 Jaroslav Reznik <jreznik@redhat.com> 4.7.0-1
130- 4.7.0
131
132* Mon Jul 11 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.95-1
133- 4.6.95
134
135* Mon Jul 11 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.90-5
136- License: GPLv2+ and LGPLv2 and GPLv3+
137- Provides: bundled(LibRaw)
138
139* Sun Jul 10 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.90-4
140- fix URL
141- fix scriptlets
142
143* Sun Jul 10 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.90-3
144- License: GPLv2+
145- %%doc: +ChangeLog NEWS
146- add %%check section
147
148* Wed Jul 06 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.90-2
149- fix Source0 URL
150- Conflicts: kdegraphics < 7:4.6.90-10
151
152* Tue Jul 05 2011 Rex Dieter <rdieter@fedoraproject.org>  4.6.90-1
153- first try
154
155
Note: See TracBrowser for help on using the repository browser.