source: projects/specs/trunk/lib/libk/libkdcraw/libkdcraw-vl.spec @ 4664

Revision 4664, 3.7 KB checked in by inagaki, 13 years ago (diff)

NEW: libkdcraw, libkexiv2, libkipi, libksane and okular

Line 
1Name:    libkdcraw
2Summary: A C++ interface around LibRaw library
3Version: 4.7.0
4Release: 2%{?_dist_release}
5
6# libkdcraw is GPLv2+,
7# LibRaw(bundled) is LGPLv2
8# demosaic-pack GPLv2+ GPLv3+ (addons to libraw)
9License: GPLv2+ and LGPLv2 and GPLv3+
10URL:     https://projects.kde.org/projects/kde/kdegraphics/libs/libkdcraw
11Group:   System Environment/Libraries
12
13Source0: ftp://ftp.kde.org/pub/kde/unstable/%{version}/src/%{name}-%{version}.tar.bz2
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: kdelibs4-devel >= %{version}
17BuildRequires: lcms-devel
18BuildRequires: libjpeg-devel
19
20Requires: kdelibs4 >= 4.7
21
22# when split occurred
23Conflicts: kdegraphics-libs < 4.6.95-10
24
25# upstream plans to unbundle when libraw-1.0 is released
26# see also http://mail.kde.org/pipermail/digikam-devel/2010-March/041682.html
27Provides: bundled(LibRaw)
28# deomosaic-pack addons to libraw
29Provides: bundled(LibRaw-demosaic-pack-GPL2)
30Provides: bundled(LibRaw-demosaic-pack-GPL3)
31
32%description
33Libkdcraw is a C++ interface around LibRaw library used to decode RAW
34picture files. More information about LibRaw can be found at
35http://www.libraw.org.
36
37%package devel
38Summary:  Development files for %{name}
39Summary(ja): %{name} の開発用ファイル
40Group:   Development/Libraries
41Requires: %{name} = %{version}-%{release}
42Requires: kdelibs4-devel
43
44%description devel
45%{summary}.
46
47
48%prep
49%setup -q
50
51# copy/rename a few things for easier inclusion as %%doc
52cp -a libraw/README README.libraw
53cp -a libraw/COPYRIGHT COPYRIGHT.libraw
54
55
56%build
57mkdir -p %{_target_platform}
58pushd %{_target_platform}
59unset QTDIR || : ; . /etc/profile.d/qt4.sh
60%cmake \
61    -DCMAKE_BUILD_TYPE=release \
62    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
63    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
64    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
65    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
66    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
67    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
68    ..
69popd
70
71make %{?_smp_mflags} -C %{_target_platform}
72
73
74%install
75rm -rf %{buildroot}
76
77make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
78
79
80%check
81export PKG_CONFIG_PATH=%{buildroot}%{_datadir}/pkgconfig:%{buildroot}%{_libdir}/pkgconfig
82pkg-config --modversion libkdcraw
83make -C %{_target_platform}/test
84
85%post
86/sbin/ldconfig
87touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
88
89%posttrans
90gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
91
92%postun
93/sbin/ldconfig
94if [ $1 -eq 0 ] ; then
95touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
96gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
97fi
98
99
100%files
101%doc AUTHORS ChangeLog COPYING NEWS README TODO
102%doc COPYRIGHT.libraw README.libraw libraw/README.demosaic-packs libraw/LICENSE.LGPL
103%{_libdir}/libkdcraw.so.20*
104%{_datadir}/kde4/apps/libkdcraw/
105%{_datadir}/icons/hicolor/*/*/*
106
107%files devel
108%{_libdir}/libkdcraw.so
109%{_libdir}/pkgconfig/libkdcraw.pc
110%{_includedir}/kde4/libkdcraw/
111
112
113%changelog
114* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-2
115- Initial build for Vine Linux
116
117* Tue Jul 26 2011 Jaroslav Reznik <jreznik@redhat.com> 4.7.0-1
118- 4.7.0
119
120* Mon Jul 11 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.95-1
121- 4.6.95
122
123* Mon Jul 11 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.90-5
124- License: GPLv2+ and LGPLv2 and GPLv3+
125- Provides: bundled(LibRaw)
126
127* Sun Jul 10 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.90-4
128- fix URL
129- fix scriptlets
130
131* Sun Jul 10 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.90-3
132- License: GPLv2+
133- %%doc: +ChangeLog NEWS
134- add %%check section
135
136* Wed Jul 06 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.90-2
137- fix Source0 URL
138- Conflicts: kdegraphics < 7:4.6.90-10
139
140* Tue Jul 05 2011 Rex Dieter <rdieter@fedoraproject.org>  4.6.90-1
141- first try
142
143
Note: See TracBrowser for help on using the repository browser.