source: projects/specs/trunk/lib/libk/libkdcraw/libkdcraw-vl.spec @ 10442

Revision 10442, 4.5 KB checked in by tomop, 8 years ago (diff)

libkdcraw-4.14.3-2

Line 
1Name:    libkdcraw
2Summary: A C++ interface around LibRaw library
3Summary(ja): LibRaw ライブラリ向けの C++ インターフェース
4Version: 4.14.3
5Release: 2%{?_dist_release}
6
7# libkdcraw is GPLv2+,
8License: GPLv2+
9URL:     https://projects.kde.org/projects/kde/kdegraphics/libs/libkdcraw
10Group:   System Environment/Libraries
11
12Source0: ftp://ftp.kde.org/pub/kde/unstable/%{version}/src/%{name}-%{version}.tar.xz
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: kdelibs-devel >= %{version}
16BuildRequires: lcms-devel
17BuildRequires: libjpeg-devel
18BuildRequires: LibRaw-devel
19
20Requires: kdelibs >= %{version}
21
22# when split occurred
23Conflicts: kdegraphics-libs < 4.6.95-10
24
25Vendor: Project Vine
26Distribution: Vine Linux
27
28%description
29Libkdcraw is a C++ interface around LibRaw library used to decode RAW
30picture files. More information about LibRaw can be found at
31http://www.libraw.org.
32
33%package devel
34Summary:  Development files for %{name}
35Summary(ja): %{name} の開発用ファイル
36Group:   Development/Libraries
37Requires: %{name} = %{version}-%{release}
38Requires: kdelibs-devel
39
40%description devel
41%{summary}.
42
43
44%prep
45%setup -q
46
47%build
48mkdir -p %{_target_platform}
49pushd %{_target_platform}
50%cmake \
51    -DCMAKE_BUILD_TYPE=release \
52    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
53    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
54    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
55    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
56    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
57    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
58    ..
59popd
60
61make %{?_smp_mflags} -C %{_target_platform}
62
63
64%install
65rm -rf %{buildroot}
66
67make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
68
69
70%check
71export PKG_CONFIG_PATH=%{buildroot}%{_datadir}/pkgconfig:%{buildroot}%{_libdir}/pkgconfig
72pkg-config --modversion libkdcraw
73make -C %{_target_platform}/tests
74
75%post
76/sbin/ldconfig
77touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
78
79%posttrans
80gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
81
82%postun
83/sbin/ldconfig
84if [ $1 -eq 0 ] ; then
85touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
86gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
87fi
88
89
90%files
91%doc AUTHORS ChangeLog COPYING NEWS README TODO
92%{_libdir}/libkdcraw.so.*
93%{_datadir}/kde4/apps/libkdcraw/
94%{_datadir}/icons/hicolor/*/*/*
95
96%files devel
97%{_libdir}/libkdcraw.so
98%{_libdir}/pkgconfig/libkdcraw.pc
99%{_includedir}/kde4/libkdcraw/
100
101
102%changelog
103* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.14.3-2
104- rebuilt with LibRaw-0.17.2.
105
106* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-1
107- new upstream release
108
109* Tue May 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.5-1
110- new upstream release
111
112* Sun Feb 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.2-1
113- new upstream release
114- add BuildRequires: LibRaw-devel
115
116* Sun Dec 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.4-1
117- new upstream release
118
119* Sun Sep 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.1-1
120- new upstream release
121
122* Sat Jul 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.5-1
123- new upstream release
124
125* Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.5-1
126- new upstream release
127
128* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
129- new upstream release
130
131* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
132- new upstream release
133
134* Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
135- new upstream release
136
137* Sun Aug 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
138- new upstream release
139
140* Sun Dec 18 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
141- new upstream release
142
143* Sat Oct 15 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.2-1
144- new upstream release
145
146* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-2
147- Initial build for Vine Linux
148
149* Tue Jul 26 2011 Jaroslav Reznik <jreznik@redhat.com> 4.7.0-1
150- 4.7.0
151
152* Mon Jul 11 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.95-1
153- 4.6.95
154
155* Mon Jul 11 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.90-5
156- License: GPLv2+ and LGPLv2 and GPLv3+
157- Provides: bundled(LibRaw)
158
159* Sun Jul 10 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.90-4
160- fix URL
161- fix scriptlets
162
163* Sun Jul 10 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.90-3
164- License: GPLv2+
165- %%doc: +ChangeLog NEWS
166- add %%check section
167
168* Wed Jul 06 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.90-2
169- fix Source0 URL
170- Conflicts: kdegraphics < 7:4.6.90-10
171
172* Tue Jul 05 2011 Rex Dieter <rdieter@fedoraproject.org>  4.6.90-1
173- first try
174
175
Note: See TracBrowser for help on using the repository browser.