source: projects/specs/trunk/lib/libj/libjpeg/libjpeg-vl.spec @ 521

Revision 521, 10.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define LIBVER 62.0.0
3
4Summary: A library for manipulating JPEG image format files.
5Summary(ja): JPEG 形式画像ファイルを扱う為のライブラリ
6Name: libjpeg
7Version: 6b
8Release: 40%{?_dist_release}
9License: distributable
10Group: System Environment/Libraries
11Source0: ftp://ftp.uu.net/graphics/jpeg/jpegsrc.v6b.tar.bz2
12Patch0: libjpeg-6b-arm.patch
13Patch1: jpeg-c++.patch
14Patch2: libjpeg-shared.patch
15Patch3: libjpeg-rpath.patch
16Patch4: libjpeg-x86_64.patch
17URL: http://www.ijg.org/
18Buildroot: %{_tmppath}/%{name}-%{version}-root
19
20%package devel
21Summary: Development tools for programs which will use the libjpeg library.
22Summary(ja): libjpeg ライブラリを使うプログラム向け開発ツール
23Group: Development/Libraries
24Requires: libjpeg = %{version}-%{release}
25
26%package static
27Summary: Static library of libjpeg
28Summary(ja): libjpeg のスタティックライブラリ
29Group: Development/Libraries
30Requires: libjpeg-devel = %{version}-%{release}
31
32%description
33The libjpeg package contains a library of functions for manipulating
34JPEG images, as well as simple client programs for accessing the
35libjpeg functions.  Libjpeg client programs include cjpeg, djpeg,
36jpegtran, rdjpgcom and wrjpgcom.  Cjpeg compresses an image file into
37JPEG format.  Djpeg decompresses a JPEG file into a regular image
38file.  Jpegtran can perform various useful transformations on JPEG
39files.  Rdjpgcom displays any text comments included in a JPEG file.
40Wrjpgcom inserts text comments into a JPEG file.
41
42%description -l ja
43libjpeg パッケージには JPEG 画像を扱う為に必要なライブラリと,
44libjpeg 関数にアクセスする為の簡単なクライアントプログラムが
45収められています.libjpeg クライアントプログラムには cjpeg, djpeg,
46jpegtran, rdjpgcom, wrjpgcom があります.cjpeg は画像ファイルを
47JPEG 形式に圧縮します.djpeg は JPEG ファイルを通常の画像ファイルに
48展開します.jpegtran は JPEG ファイルに様々な変換を施すことが出来ます.
49rdjpgcom は JPEG ファイルに含まれているテキスト形式のコメントを表示し,
50wrjpgcom は JPEG ファイルにテキスト形式のコメントを追加します.
51
52%description devel
53The libjpeg-devel package includes the header files and static libraries
54necessary for developing programs which will manipulate JPEG files using
55the libjpeg library.
56
57If you are going to develop programs which will manipulate JPEG images,
58you should install libjpeg-devel.  You'll also need to have the libjpeg
59package installed.
60
61%description devel -l ja
62libjpeg-devel パッケージには,libjpeg ライブラリを使って JPEG ファイルを
63扱うプログラムを開発するのに必要なヘッダファイルとスタティックライブラリが
64収められています.
65
66JPEG 画像を扱うプログラムを開発する際には,libjpeg-devel を
67インストールして下さい.同時に libjpeg パッケージもインストールする
68必要があります.
69
70%description static
71The libjpeg-static package contains the statically linkable version of libjpeg.
72Linking to static libraries is discouraged for most applications, but it is
73necessary for some boot packages.
74
75
76## to build compat32 for x86_64 architecture support
77%package -n compat32-%{name}
78Summary: A library for manipulating JPEG image format files.
79Summary(ja): JPEG 形式画像ファイルを扱う為のライブラリ
80Group: Development/Libraries
81Requires: libjpeg = %{version}-%{release}
82%description -n compat32-%{name}
83The libjpeg package contains a library of functions for manipulating
84JPEG images, as well as simple client programs for accessing the
85libjpeg functions.  Libjpeg client programs include cjpeg, djpeg,
86jpegtran, rdjpgcom and wrjpgcom.  Cjpeg compresses an image file into
87JPEG format.  Djpeg decompresses a JPEG file into a regular image
88file.  Jpegtran can perform various useful transformations on JPEG
89files.  Rdjpgcom displays any text comments included in a JPEG file.
90Wrjpgcom inserts text comments into a JPEG file.
91
92%package -n compat32-%{name}-devel
93Summary: Development tools for programs which will use the libjpeg library.
94Summary(ja): libjpeg ライブラリを使うプログラム向け開発ツール
95Group: Development/Libraries
96Requires: compat32-libjpeg = %{version}-%{release}
97Requires: libjpeg-devel = %{version}-%{release}
98
99%description -n compat32-%{name}-devel
100The libjpeg-devel package includes the header files and static libraries
101necessary for developing programs which will manipulate JPEG files using
102the libjpeg library.
103
104If you are going to develop programs which will manipulate JPEG images,
105you should install libjpeg-devel.  You'll also need to have the libjpeg
106package installed.
107
108%prep
109%setup -q -n jpeg-6b
110%patch0 -p1 -b .arm
111%patch1 -p1 -b .c++
112%patch2 -p1 -b .ppcshared
113%patch3 -p1
114%patch4 -p1
115
116%build
117%configure --enable-shared --enable-static
118make libdir=%{_libdir} %{?_smp_mflags}
119LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$PWD make test
120
121%install
122rm -rf $RPM_BUILD_ROOT
123mkdir -p $RPM_BUILD_ROOT%{_bindir}
124mkdir -p $RPM_BUILD_ROOT%{_libdir}
125mkdir -p $RPM_BUILD_ROOT%{_includedir}
126mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
127%makeinstall
128# Work around the broken makefiles...
129mv $RPM_BUILD_ROOT%{_mandir}/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
130strip -R .comment $RPM_BUILD_ROOT%{_bindir}/* || :
131
132rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
133
134%post -p /sbin/ldconfig
135
136%postun -p /sbin/ldconfig
137
138%post -n compat32-%{name} -p /sbin/ldconfig
139
140%postun -n compat32-%{name} -p /sbin/ldconfig
141
142
143%clean
144rm -rf $RPM_BUILD_ROOT
145
146%files
147%defattr(-,root,root)
148%doc usage.doc README
149%{_bindir}/*
150%{_libdir}/libjpeg.so.*
151%{_mandir}/*/*
152
153%files devel
154%defattr(-,root,root)
155%doc libjpeg.doc coderules.doc structure.doc wizard.doc example.c
156%{_libdir}/*.so
157%{_includedir}/*
158
159%files static
160%defattr(-,root,root)
161%{_libdir}/*.a
162%{_includedir}/*
163
164## to build compat32 for x86_64 architecture support
165%if %{build_compat32}
166%files -n compat32-%{name}
167%defattr(-,root,root)
168%{_libdir}/libjpeg.so.*
169
170%files -n compat32-%{name}-devel
171%defattr(-,root,root)
172%{_libdir}/*.so
173%endif
174
175%changelog
176* Sat Feb 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 6b-40
177- rebuild with new environment
178
179* Mon May 04 2009 NAKAMURA Kenta <kenta@vinelinux.org> 6b-39
180- do not remove libjpeg.a even if %%{build_compat32} is defined
181
182* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 6b-38
183- split static library to -static subpackge
184  - libjpeg-static is needed by tuxonice-userui
185
186* Mon Dec 29 2008 Shu KONNO <owa@bg.wakwak.com> 6b-37
187- spec in utf-8
188
189* Thu May 01 2008 NAKAMURA Kenta <kenta@vinelinux.org> 6b-36
190- updated %%if %%{build_compat32} case related statements
191
192* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6b-35
193- applied new versioning policy
194- removed *.la files from devel package
195
196* Sat Aug 26 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 6b-34vl4
197- add Requires: compat32-libjpeg instead of libjpeg (compat32)
198- fix typo in changelog
199
200* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 6b-34vl3
201- fixed %postun (missing to build as scriptlet by invalid comment)
202
203* Sun Feb 05 2006 Shu KONNO <owa@bg.wakwak.com> 6b-34vl2
204- added compat32-* packages for x86_64 architecture support
205- added libjpeg-x86_64.patch by nakamura
206- added script for compat32-* before configuring
207
208* Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6b-34vl1
209- added Pacth2 and 3 from Fedora
210  * Tue Sep 23 2003 Florian La Roche <Florian.LaRoche@redhat.de>
211  - do not set rpath
212  * Thu Feb 13 2003 Elliot Lee <sopwith@redhat.com> 6b-27
213  - Add libjpeg-shared.patch to fix shlibs on powerpc
214- added URL
215
216* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 6b-21vl2
217- rebuild
218
219* Fri Dec 06 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6b-20vl1
220- based on 6b-20 from Rawhide and built for Vine Linux
221- added Japanese summary and description
222
223* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
224- automated rebuild
225
226* Thu May 23 2002 Tim Powers <timp@redhat.com>
227- automated rebuild
228
229* Thu Jan 31 2002 Bernhard Rosenkraenzer <bero@redhat.com> 6b-19
230- Fix bug #59011
231
232* Mon Jan 28 2002 Bernhard Rosenkraenzer <bero@redhat.com> 6b-18
233- Fix bug #58982
234
235* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
236- automated rebuild
237
238* Tue Jul 24 2001 Bill Nottingham <notting@redhat.com>
239- require libjpeg = %%{version}
240
241* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
242- Bump release + rebuild.
243
244* Mon Dec 11 2000 Than Ngo <than@redhat.com>
245- rebuilt with the fixed fileutils
246- use %%{_tmppath}
247
248* Wed Nov  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
249- fix a typo (strip -R .comment, not .comments)
250
251* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
252- automatic rebuild
253
254* Sat Jun 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
255- FHSify
256- add some C++ tweaks to the headers as suggested by bug #9822)
257
258* Wed May  5 2000 Bill Nottingham <notting@redhat.com>
259- configure tweaks for ia64; remove alpha patch (it's pointless)
260
261* Sat Feb  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
262- rebuild to get compressed man pages
263- fix description
264- some minor tweaks to the spec file
265- add docs
266- fix build on alpha (alphaev6 stuff)
267
268* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
269- auto rebuild in the new build environment (release 9)
270
271* Wed Jan 13 1999 Cristian Gafton <gafton@redhat.com>
272- patch to build on arm
273- build for glibc 2.1
274
275* Mon Oct 12 1998 Cristian Gafton <gafton@redhat.com>
276- strip binaries
277
278* Mon Aug  3 1998 Jeff Johnson <jbj@redhat.com>
279- fix buildroot problem.
280
281* Tue Jun 09 1998 Prospector System <bugs@redhat.com>
282- translations modified for de
283
284* Thu Jun 04 1998 Marc Ewing <marc@redhat.com>
285- up to release 4
286- remove patch that set (improper) soname - libjpeg now does it itself
287
288* Thu May 07 1998 Prospector System <bugs@redhat.com>
289- translations modified for de, fr, tr
290
291* Fri May 01 1998 Cristian Gafton <gafton@redhat.com>
292- fixed build on manhattan
293
294* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
295- upgraded to version 6b
296
297* Wed Oct 08 1997 Donnie Barnes <djb@redhat.com>
298- new package to remove jpeg stuff from libgr and put in it's own package
Note: See TracBrowser for help on using the repository browser.