source: projects/specs/trunk/lib/libj/libjpeg-turbo/libjpeg-turbo-vl.spec @ 8944

Revision 8944, 6.7 KB checked in by daisuke, 10 years ago (diff)

libjpeg-turbo:

  • update to 1.3.1
  • ship turbojpeg library and headers
Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        A MMX/SSE2 accelerated library for manipulating JPEG image files
4Summary(ja):    MMX/SSE2 でアクセラレーションされた libjpeg ライブラリ
5
6Name:           libjpeg-turbo
7Version:        1.3.1
8Release:        1%{?_dist_release}
9
10Group:          System Environment/Libraries
11License:        wxWidgets
12URL:            http://sourceforge.net/projects/libjpeg-turbo
13Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
14BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
15
16BuildRequires:  autoconf, automake, libtool
17%ifarch %{ix86} x86_64
18BuildRequires:  nasm
19%endif
20
21Obsoletes:      libjpeg < 6b-50vl6
22Provides:       libjpeg = 6b-50vl6
23
24Patch0:         libjpeg-turbo12-noinst.patch
25Patch1:         libjpeg-turbo-header-files.patch
26
27%description
28The libjpeg-turbo package contains a library of functions for manipulating
29JPEG images
30
31%package devel
32Summary:        Headers for the libjpeg-turbo library
33Summary(ja):    libjpeg-turbo ライブラリのヘッダファイル
34Group:          Development/Libraries
35Obsoletes:      libjpeg-devel < 6b-50vl6
36Obsoletes:      libjpeg-static < 6b-50vl6
37Provides:       libjpeg-devel = 6b-50vl6
38Requires:       libjpeg-turbo = %{version}-%{release}
39
40%description devel
41This package contains header files necessary for developing programs which
42will manipulate JPEG files using the libjpeg-turbo library
43
44%package utils
45Summary:        Utilities for manipulating JPEG images
46Summary(ja):    JPEG イメージを操作するためのユーティリティ
47Group:          Applications/Multimedia
48Requires:       libjpeg-turbo = %{version}-%{release}
49
50%description utils
51The libjpeg-turbo-utils package contains simple client programs for
52accessing the libjpeg functions. It contains cjpeg, djpeg, jpegtran,
53rdjpgcom and wrjpgcom. Cjpeg compresses an image file into JPEG format.
54Djpeg decompresses a JPEG file into a regular image file. Jpegtran
55can perform various useful transformations on JPEG files. Rdjpgcom
56displays any text comments included in a JPEG file. Wrjpgcom inserts
57text comments into a JPEG file.
58
59## to build compat32 for x86_64 architecture support
60%package -n compat32-%{name}
61Summary:        A MMX/SSE2 accelerated library for manipulating JPEG image files
62Summary(ja):    MMX/SSE2 でアクセラレーションされた libjpeg ライブラリ
63Group:          System Environment/Libraries
64Obsoletes:      compat32-libjpeg < 6b-50vl6
65Provides:       compat32-libjpeg = 6b-50vl6
66
67%description -n compat32-%{name}
68The libjpeg-turbo package contains a library of functions for manipulating
69JPEG images
70
71%package -n compat32-%{name}-devel
72Summary:        Headers for the libjpeg-turbo library
73Summary(ja):    libjpeg-turbo ライブラリのヘッダファイル
74Group:          Development/Libraries
75Obsoletes:      compat32-libjpeg-devel < 6b-50vl6
76Provides:       compat32-libjpeg-devel = 6b-50vl6
77Requires:       libjpeg-turbo = %{version}-%{release}
78
79%description -n compat32-%{name}-devel
80This package contains header files necessary for developing programs which
81will manipulate JPEG files using the libjpeg-turbo library
82
83%prep
84%setup -q
85
86%patch0 -p1 -b .noinst_jpgtest
87%patch1 -p1 -b .turbo_headers
88
89%build
90autoreconf -fiv
91
92%configure --disable-static
93
94make %{?_smp_mflags}
95
96%install
97rm -rf $RPM_BUILD_ROOT
98make install DESTDIR=$RPM_BUILD_ROOT
99
100# Fix perms
101chmod -x README-turbo.txt
102
103# Remove unwanted files
104rm -f $RPM_BUILD_ROOT/%{_libdir}/lib{,turbo}jpeg.la
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109%post -p /sbin/ldconfig
110%postun -p /sbin/ldconfig
111%post -n compat32-%{name} -p /sbin/ldconfig
112%postun -n compat32-%{name} -p /sbin/ldconfig
113
114%files
115%defattr(-,root,root,-)
116%doc README README-turbo.txt change.log ChangeLog.txt
117%{_libdir}/libjpeg.so.62*
118%{_libdir}/libturbojpeg.so.0*
119
120%files devel
121%defattr(-,root,root,-)
122%doc coderules.txt jconfig.txt libjpeg.txt structure.txt example.c
123%{_includedir}/jconfig.h
124%{_includedir}/jerror.h
125%{_includedir}/jmorecfg.h
126%{_includedir}/jpegint.h
127%{_includedir}/jpeglib.h
128%{_includedir}/turbojpeg.h
129%{_libdir}/libjpeg.so
130%{_libdir}/libturbojpeg.so
131
132%files utils
133%defattr(-,root,root,-)
134%doc usage.txt wizard.txt
135%{_bindir}/cjpeg
136%{_bindir}/djpeg
137%{_bindir}/jpegtran
138%{_bindir}/rdjpgcom
139%{_bindir}/wrjpgcom
140%{_mandir}/man1/cjpeg.1*
141%{_mandir}/man1/djpeg.1*
142%{_mandir}/man1/jpegtran.1*
143%{_mandir}/man1/rdjpgcom.1*
144%{_mandir}/man1/wrjpgcom.1*
145
146## to build compat32 for x86_64 architecture support
147%if %{build_compat32}
148%files -n compat32-%{name}
149%defattr(-,root,root)
150%{_libdir}/libjpeg.so.*
151%{_libdir}/libturbojpeg.so.*
152
153%files -n compat32-%{name}-devel
154%defattr(-,root,root)
155%{_libdir}/*.so
156%endif
157
158%changelog
159* Sun Sep 07 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.3.1-1
160- update to 1.3.1
161- ship turbojpeg library and headers
162
163* Sun Jul 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-2
164- rebuild with VineSeed environment
165
166* Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
167- new upstream release
168
169* Tue Mar 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
170- new upstream release
171
172* Tue Sep 14 2010 Daisuke SUZUKI <daisuke@linux.or.jp>  1.0.0-1
173- initial build for Vine Linux
174
175* Wed Aug 04 2010 Adam Tkac <atkac redhat com> 1.0.0-3
176- fix huffman decoder to handle broken JPEGs well (#617469)
177
178* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.0-2
179- add libjpeg-devel%%{_isa} provides to -devel subpkg to satisfy imlib-devel
180  deps
181
182* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.0-1
183- update to 1.0.0
184- patches merged
185  - libjpeg-turbo-programs.patch
186  - libjpeg-turbo-nosimd.patch
187- add libjpeg provides to the main package to workaround problems with broken
188  java-1.6.0-openjdk package
189
190* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 0.0.93-13
191- remove libjpeg provides from -utils subpkg
192
193* Wed Jun 30 2010 Rex Dieter <rdieter@fedoraproject.org> 0.0.93-12
194- move Obsoletes: libjpeg to main pkg
195
196* Wed Jun 30 2010 Rex Dieter <rdieter@fedoraproject.org> 0.0.93-11
197- -utils: Requires: %%name ...
198
199* Wed Jun 30 2010 Adam Tkac <atkac redhat com> 0.0.93-10
200- add Provides = libjpeg to -utils subpackage
201
202* Mon Jun 28 2010 Adam Tkac <atkac redhat com> 0.0.93-9
203- merge review related fixes (#600243)
204
205* Wed Jun 16 2010 Adam Tkac <atkac redhat com> 0.0.93-8
206- merge review related fixes (#600243)
207
208* Mon Jun 14 2010 Adam Tkac <atkac redhat com> 0.0.93-7
209- obsolete -static libjpeg subpackage (#600243)
210
211* Mon Jun 14 2010 Adam Tkac <atkac redhat com> 0.0.93-6
212- improve package description a little (#600243)
213- include example.c as %%doc in the -devel subpackage
214
215* Fri Jun 11 2010 Adam Tkac <atkac redhat com> 0.0.93-5
216- don't use "fc12" disttag in obsoletes/provides (#600243)
217
218* Thu Jun 10 2010 Adam Tkac <atkac redhat com> 0.0.93-4
219- fix compilation on platforms without MMX/SSE (#600243)
220
221* Thu Jun 10 2010 Adam Tkac <atkac redhat com> 0.0.93-3
222- package review related fixes (#600243)
223
224* Wed Jun 09 2010 Adam Tkac <atkac redhat com> 0.0.93-2
225- package review related fixes (#600243)
226
227* Fri Jun 04 2010 Adam Tkac <atkac redhat com> 0.0.93-1
228- initial package
Note: See TracBrowser for help on using the repository browser.