source: projects/specs/trunk/lib/libj/libjpeg-turbo/libjpeg-turbo-vl.spec @ 3192

Revision 3192, 6.5 KB checked in by daisuke, 13 years ago (diff)

libjpeg-turbo: update to 1.1.0

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        A MMX/SSE2 accelerated library for manipulating JPEG image files
4Summary(ja):    MMX/SSE2 でアクセラレーションされた libjpeg ライブラリ
5
6Name:           libjpeg-turbo
7Version:        1.1.0
8Release:        1%{?_dist_release}
9
10Group:          System Environment/Libraries
11License:        wxWidgets
12URL:            http://sourceforge.net/projects/libjpeg-turbo
13Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
14BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
15
16BuildRequires:  autoconf, automake, libtool
17%ifarch %{ix86} x86_64
18BuildRequires:  nasm
19%endif
20
21Obsoletes:      libjpeg < 6b-50vl6
22Provides:       libjpeg = 6b-50vl6
23
24Patch0:         libjpeg-turbo11-noinst_jpgtest.patch
25Patch1:         ljt11-rh688712.patch
26
27%description
28The libjpeg-turbo package contains a library of functions for manipulating
29JPEG images
30
31%package devel
32Summary:        Headers for the libjpeg-turbo library
33Summary(ja):    libjpeg-turbo ライブラリのヘッダファイル
34Group:          Development/Libraries
35Obsoletes:      libjpeg-devel < 6b-50vl6
36Obsoletes:      libjpeg-static < 6b-50vl6
37Provides:       libjpeg-devel = 6b-50vl6
38Requires:       libjpeg-turbo = %{version}-%{release}
39
40%description devel
41This package contains header files necessary for developing programs which
42will manipulate JPEG files using the libjpeg-turbo library
43
44%package utils
45Summary:        Utilities for manipulating JPEG images
46Summary(ja):    JPEG イメージを操作するためのユーティリティ
47Group:          Applications/Multimedia
48Requires:       libjpeg-turbo = %{version}-%{release}
49
50%description utils
51The libjpeg-turbo-utils package contains simple client programs for
52accessing the libjpeg functions. It contains cjpeg, djpeg, jpegtran,
53rdjpgcom and wrjpgcom. Cjpeg compresses an image file into JPEG format.
54Djpeg decompresses a JPEG file into a regular image file. Jpegtran
55can perform various useful transformations on JPEG files. Rdjpgcom
56displays any text comments included in a JPEG file. Wrjpgcom inserts
57text comments into a JPEG file.
58
59## to build compat32 for x86_64 architecture support
60%package -n compat32-%{name}
61Summary:        A MMX/SSE2 accelerated library for manipulating JPEG image files
62Summary(ja):    MMX/SSE2 でアクセラレーションされた libjpeg ライブラリ
63Group:          System Environment/Libraries
64Obsoletes:      compat32-libjpeg < 6b-50vl6
65Provides:       compat32-libjpeg = 6b-50vl6
66
67%description -n compat32-%{name}
68The libjpeg-turbo package contains a library of functions for manipulating
69JPEG images
70
71%package -n compat32-%{name}-devel
72Summary:        Headers for the libjpeg-turbo library
73Summary(ja):    libjpeg-turbo ライブラリのヘッダファイル
74Group:          Development/Libraries
75Obsoletes:      compat32-libjpeg-devel < 6b-50vl6
76Provides:       compat32-libjpeg-devel = 6b-50vl6
77Requires:       libjpeg-turbo = %{version}-%{release}
78
79%description -n compat32-%{name}-devel
80This package contains header files necessary for developing programs which
81will manipulate JPEG files using the libjpeg-turbo library
82
83%prep
84%setup -q
85
86%patch0 -p1 -b .noinst_jpgtest
87%patch1 -p0 -b .rh688712
88
89%build
90autoreconf -fiv
91
92%configure --disable-static
93
94make %{?_smp_mflags}
95
96%install
97rm -rf $RPM_BUILD_ROOT
98make install DESTDIR=$RPM_BUILD_ROOT
99
100# Fix perms
101chmod -x README-turbo.txt
102
103# Remove unwanted files
104rm -f $RPM_BUILD_ROOT/%{_libdir}/lib{,turbo}jpeg.la
105
106# Don't distribute libjpegturbo because it is unversioned
107rm -f $RPM_BUILD_ROOT/%{_includedir}/turbojpeg.h
108rm -f $RPM_BUILD_ROOT/%{_libdir}/libturbojpeg.so
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%post -p /sbin/ldconfig
114%postun -p /sbin/ldconfig
115%post -n compat32-%{name} -p /sbin/ldconfig
116%postun -n compat32-%{name} -p /sbin/ldconfig
117
118%files
119%defattr(-,root,root,-)
120%doc README README-turbo.txt change.log ChangeLog.txt LGPL.txt LICENSE.txt
121%{_libdir}/libjpeg.so.62.0.0
122%{_libdir}/libjpeg.so.62
123
124%files devel
125%defattr(-,root,root,-)
126%doc coderules.doc jconfig.doc libjpeg.doc structure.doc example.c
127%{_includedir}/jconfig.h
128%{_includedir}/jerror.h
129%{_includedir}/jmorecfg.h
130%{_includedir}/jpeglib.h
131%{_libdir}/libjpeg.so
132
133%files utils
134%defattr(-,root,root,-)
135%doc usage.doc wizard.doc
136%{_bindir}/cjpeg
137%{_bindir}/djpeg
138%{_bindir}/jpegtran
139%{_bindir}/rdjpgcom
140%{_bindir}/wrjpgcom
141%{_mandir}/man1/cjpeg.1*
142%{_mandir}/man1/djpeg.1*
143%{_mandir}/man1/jpegtran.1*
144%{_mandir}/man1/rdjpgcom.1*
145%{_mandir}/man1/wrjpgcom.1*
146
147## to build compat32 for x86_64 architecture support
148%if %{build_compat32}
149%files -n compat32-%{name}
150%defattr(-,root,root)
151%{_libdir}/libjpeg.so.*
152
153%files -n compat32-%{name}-devel
154%defattr(-,root,root)
155%{_libdir}/*.so
156%endif
157
158%changelog
159* Tue Mar 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
160- new upstream release
161
162* Tue Sep 14 2010 Daisuke SUZUKI <daisuke@linux.or.jp>  1.0.0-1
163- initial build for Vine Linux
164
165* Wed Aug 04 2010 Adam Tkac <atkac redhat com> 1.0.0-3
166- fix huffman decoder to handle broken JPEGs well (#617469)
167
168* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.0-2
169- add libjpeg-devel%%{_isa} provides to -devel subpkg to satisfy imlib-devel
170  deps
171
172* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.0-1
173- update to 1.0.0
174- patches merged
175  - libjpeg-turbo-programs.patch
176  - libjpeg-turbo-nosimd.patch
177- add libjpeg provides to the main package to workaround problems with broken
178  java-1.6.0-openjdk package
179
180* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 0.0.93-13
181- remove libjpeg provides from -utils subpkg
182
183* Wed Jun 30 2010 Rex Dieter <rdieter@fedoraproject.org> 0.0.93-12
184- move Obsoletes: libjpeg to main pkg
185
186* Wed Jun 30 2010 Rex Dieter <rdieter@fedoraproject.org> 0.0.93-11
187- -utils: Requires: %%name ...
188
189* Wed Jun 30 2010 Adam Tkac <atkac redhat com> 0.0.93-10
190- add Provides = libjpeg to -utils subpackage
191
192* Mon Jun 28 2010 Adam Tkac <atkac redhat com> 0.0.93-9
193- merge review related fixes (#600243)
194
195* Wed Jun 16 2010 Adam Tkac <atkac redhat com> 0.0.93-8
196- merge review related fixes (#600243)
197
198* Mon Jun 14 2010 Adam Tkac <atkac redhat com> 0.0.93-7
199- obsolete -static libjpeg subpackage (#600243)
200
201* Mon Jun 14 2010 Adam Tkac <atkac redhat com> 0.0.93-6
202- improve package description a little (#600243)
203- include example.c as %%doc in the -devel subpackage
204
205* Fri Jun 11 2010 Adam Tkac <atkac redhat com> 0.0.93-5
206- don't use "fc12" disttag in obsoletes/provides (#600243)
207
208* Thu Jun 10 2010 Adam Tkac <atkac redhat com> 0.0.93-4
209- fix compilation on platforms without MMX/SSE (#600243)
210
211* Thu Jun 10 2010 Adam Tkac <atkac redhat com> 0.0.93-3
212- package review related fixes (#600243)
213
214* Wed Jun 09 2010 Adam Tkac <atkac redhat com> 0.0.93-2
215- package review related fixes (#600243)
216
217* Fri Jun 04 2010 Adam Tkac <atkac redhat com> 0.0.93-1
218- initial package
Note: See TracBrowser for help on using the repository browser.