source: projects/specs/trunk/lib/libj/libjpeg-turbo/libjpeg-turbo-vl.spec @ 12519

Revision 12519, 8.5 KB checked in by tomop, 3 years ago (diff)

updated 7 packages

ghostscript-9.53.3-1

lua-5.4.2-1

libjpeg-turbo-2.0.6-1

libtiff-4.2.0-1

openjpeg2-2.4.0-1

proftpd-1.3.7a-1

wireshark-3.4.2-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        A MMX/SSE2/SIMD accelerated library for manipulating JPEG image files
4Summary(ja):    MMX/SSE2/SIMD でアクセラレーションされた libjpeg ライブラリ
5
6Name:           libjpeg-turbo
7Version:        2.0.6
8Release:        1%{?_dist_release}
9Group:          system
10Vendor:         Project Vine
11Distribution:   Vine Linux
12
13License:        IJG
14URL:            http://sourceforge.net/projects/libjpeg-turbo
15
16Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
17Patch0:         libjpeg-turbo-cmake.patch
18Patch1:         libjpeg-turbo-CET.patch
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
21
22BuildRequires:  cmake
23%ifarch %{ix86} x86_64
24BuildRequires:  nasm
25%endif
26
27Obsoletes:      libjpeg < 6b-50vl6
28Provides:       libjpeg = 6b-50vl6
29
30%description
31The libjpeg-turbo package contains a library of functions for manipulating
32JPEG images
33
34
35%package devel
36Summary:        Headers for the libjpeg-turbo library
37Summary(ja):    libjpeg-turbo ライブラリのヘッダファイル
38Group:          programming
39Obsoletes:      libjpeg-devel < 6b-50vl6
40Obsoletes:      libjpeg-static < 6b-50vl6
41Provides:       libjpeg-devel = 6b-50vl6
42Requires:       libjpeg-turbo = %{version}-%{release}
43
44%description devel
45This package contains header files necessary for developing programs which
46will manipulate JPEG files using the libjpeg-turbo library
47
48
49%package utils
50Summary:        Utilities for manipulating JPEG images
51Summary(ja):    JPEG イメージを操作するためのユーティリティ
52Group:          graphics
53Requires:       libjpeg-turbo = %{version}-%{release}
54
55%description utils
56The libjpeg-turbo-utils package contains simple client programs for
57accessing the libjpeg functions. It contains cjpeg, djpeg, jpegtran,
58rdjpgcom and wrjpgcom. Cjpeg compresses an image file into JPEG format.
59Djpeg decompresses a JPEG file into a regular image file. Jpegtran
60can perform various useful transformations on JPEG files. Rdjpgcom
61displays any text comments included in a JPEG file. Wrjpgcom inserts
62text comments into a JPEG file.
63
64
65## to build compat32 for x86_64 architecture support
66%package -n compat32-%{name}
67Summary:        A MMX/SSE2 accelerated library for manipulating JPEG image files
68Summary(ja):    MMX/SSE2 でアクセラレーションされた libjpeg ライブラリ
69Group:          system
70Obsoletes:      compat32-libjpeg < 6b-50vl6
71Provides:       compat32-libjpeg = 6b-50vl6
72
73%description -n compat32-%{name}
74The libjpeg-turbo package contains a library of functions for manipulating
75JPEG images
76
77
78%package -n compat32-%{name}-devel
79Summary:        Headers for the libjpeg-turbo library
80Summary(ja):    libjpeg-turbo ライブラリのヘッダファイル
81Group:          programming
82Obsoletes:      compat32-libjpeg-devel < 6b-50vl6
83Provides:       compat32-libjpeg-devel = 6b-50vl6
84Requires:       libjpeg-turbo = %{version}-%{release}
85
86%description -n compat32-%{name}-devel
87This package contains header files necessary for developing programs which
88will manipulate JPEG files using the libjpeg-turbo library
89
90
91%debug_package
92
93
94%prep
95%setup -q
96%patch0 -p1
97%patch1 -p1
98
99
100%build
101%ifarch %{ix86} x86_64
102export LDFLAGS="$RPM_LD_FLAGS -Wl,-z,ibt -Wl,-z,shstk"
103%endif
104
105mkdir jpeg6
106pushd jpeg6
107%{cmake} \
108         -DCMAKE_SKIP_RPATH:BOOL=YES \
109         -DCMAKE_SKIP_INSTALL_RPATH:BOOL=YES \
110         -DENABLE_STATIC:BOOL=NO \
111         ..
112
113make %{?_smp_mflags} V=1
114popd
115
116mkdir jpeg8
117pushd jpeg8
118%{cmake} \
119         -DWITH_JPEG8=YES \
120         -DCMAKE_SKIP_RPATH:BOOL=YES \
121         -DCMAKE_SKIP_INSTALL_RPATH:BOOL=YES \
122         -DENABLE_STATIC:BOOL=NO \
123         ..
124
125make %{?_smp_mflags} V=1
126popd
127
128
129# Fix perms
130chmod -x README.md
131
132
133
134%install
135rm -rf %{buildroot}
136pushd jpeg6
137make install DESTDIR=%{buildroot}
138popd
139
140rm -rf %{buildroot}%{_mandir}/*
141rm -f %{buildroot}%{_includedir}/*
142rm -f %{buildroot}%{_bindir}/*
143rm -f %{buildroot}%{_libdir}/pkgconfig/*
144rm -f %{buildroot}%{_libdir}/lib*.so
145
146pushd jpeg8
147make install DESTDIR=%{buildroot}
148popd
149
150# Remove unwanted files
151rm -f %{buildroot}/%{_libdir}/lib{,turbo}jpeg.la
152
153
154%check
155pushd jpeg6
156LD_LIBRARY_PATH=%{buildroot}%{_libdir} make test %{?_smp_mflags}
157popd
158
159pushd jpeg8
160LD_LIBRARY_PATH=%{buildroot}%{_libdir} make test %{?_smp_mflags}
161popd
162
163
164%clean
165rm -rf %{buildroot}
166
167
168%post -p /sbin/ldconfig
169%postun -p /sbin/ldconfig
170%post -n compat32-%{name} -p /sbin/ldconfig
171%postun -n compat32-%{name} -p /sbin/ldconfig
172
173%files
174%defattr(-,root,root,-)
175%license LICENSE.md
176%doc README.md README.ijg ChangeLog.md
177%{_libdir}/libjpeg.so.*
178%{_libdir}/libturbojpeg.so.*
179
180%files devel
181%defattr(-,root,root,-)
182%doc coderules.txt jconfig.txt libjpeg.txt structure.txt example.c
183%{_includedir}/jconfig.h
184%{_includedir}/jerror.h
185%{_includedir}/jmorecfg.h
186%{_includedir}/jpegint.h
187%{_includedir}/jpeglib.h
188%{_includedir}/turbojpeg.h
189%{_libdir}/libjpeg.so
190%{_libdir}/libturbojpeg.so
191%{_libdir}/pkgconfig/libjpeg.pc
192%{_libdir}/pkgconfig/libturbojpeg.pc
193
194%files utils
195%defattr(-,root,root,-)
196%doc usage.txt wizard.txt
197%{_bindir}/cjpeg
198%{_bindir}/djpeg
199%{_bindir}/jpegtran
200%{_bindir}/rdjpgcom
201%{_bindir}/wrjpgcom
202%{_mandir}/man1/cjpeg.1*
203%{_mandir}/man1/djpeg.1*
204%{_mandir}/man1/jpegtran.1*
205%{_mandir}/man1/rdjpgcom.1*
206%{_mandir}/man1/wrjpgcom.1*
207
208## to build compat32 for x86_64 architecture support
209%if %{build_compat32}
210%files -n compat32-%{name}
211%defattr(-,root,root)
212%{_libdir}/libjpeg.so.*
213%{_libdir}/libturbojpeg.so.*
214
215%files -n compat32-%{name}-devel
216%defattr(-,root,root)
217%{_libdir}/*.so
218%endif
219
220%changelog
221* Tue Dec 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.6-1
222- new upstream release.
223
224* Wed Sep 23 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.5-1
225- new upstream release.
226- dropped Patch1000: fixed in upstream.
227
228* Mon Jun 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.4-2
229- added Patch1000 to fix CVE-2020-13790.
230
231* Mon Feb 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.4-1
232- new upstream release.
233
234* Sat Oct 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.3-2
235- built both of libjpeg.so.62 and libjpeg.so.8.
236
237* Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.3-1
238- new upstream release.
239- dropped all patches.
240- imported Patch0 and 1 from rawhide.
241
242* Tue Dec 19 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.5.3-1
243- update to 1.5.3
244- update Patch0,doc
245
246* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
247- update to 1.4.2
248- update Patch0
249
250* Sun Sep 07 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.3.1-1
251- update to 1.3.1
252- ship turbojpeg library and headers
253
254* Sun Jul 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-2
255- rebuild with VineSeed environment
256
257* Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
258- new upstream release
259
260* Tue Mar 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
261- new upstream release
262
263* Tue Sep 14 2010 Daisuke SUZUKI <daisuke@linux.or.jp>  1.0.0-1
264- initial build for Vine Linux
265
266* Wed Aug 04 2010 Adam Tkac <atkac redhat com> 1.0.0-3
267- fix huffman decoder to handle broken JPEGs well (#617469)
268
269* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.0-2
270- add libjpeg-devel%%{_isa} provides to -devel subpkg to satisfy imlib-devel
271  deps
272
273* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.0-1
274- update to 1.0.0
275- patches merged
276  - libjpeg-turbo-programs.patch
277  - libjpeg-turbo-nosimd.patch
278- add libjpeg provides to the main package to workaround problems with broken
279  java-1.6.0-openjdk package
280
281* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 0.0.93-13
282- remove libjpeg provides from -utils subpkg
283
284* Wed Jun 30 2010 Rex Dieter <rdieter@fedoraproject.org> 0.0.93-12
285- move Obsoletes: libjpeg to main pkg
286
287* Wed Jun 30 2010 Rex Dieter <rdieter@fedoraproject.org> 0.0.93-11
288- -utils: Requires: %%name ...
289
290* Wed Jun 30 2010 Adam Tkac <atkac redhat com> 0.0.93-10
291- add Provides = libjpeg to -utils subpackage
292
293* Mon Jun 28 2010 Adam Tkac <atkac redhat com> 0.0.93-9
294- merge review related fixes (#600243)
295
296* Wed Jun 16 2010 Adam Tkac <atkac redhat com> 0.0.93-8
297- merge review related fixes (#600243)
298
299* Mon Jun 14 2010 Adam Tkac <atkac redhat com> 0.0.93-7
300- obsolete -static libjpeg subpackage (#600243)
301
302* Mon Jun 14 2010 Adam Tkac <atkac redhat com> 0.0.93-6
303- improve package description a little (#600243)
304- include example.c as %%doc in the -devel subpackage
305
306* Fri Jun 11 2010 Adam Tkac <atkac redhat com> 0.0.93-5
307- don't use "fc12" disttag in obsoletes/provides (#600243)
308
309* Thu Jun 10 2010 Adam Tkac <atkac redhat com> 0.0.93-4
310- fix compilation on platforms without MMX/SSE (#600243)
311
312* Thu Jun 10 2010 Adam Tkac <atkac redhat com> 0.0.93-3
313- package review related fixes (#600243)
314
315* Wed Jun 09 2010 Adam Tkac <atkac redhat com> 0.0.93-2
316- package review related fixes (#600243)
317
318* Fri Jun 04 2010 Adam Tkac <atkac redhat com> 0.0.93-1
319- initial package
Note: See TracBrowser for help on using the repository browser.