source: projects/specs/trunk/lib/libj/libjpeg-turbo/libjpeg-turbo-vl.spec @ 12415

Revision 12415, 8.3 KB checked in by tomop, 4 years ago (diff)

updated 6 packages

c-ares-1.16.1-1

curl-7.70.0-1

libjpeg-turbo-2.0.4-2

libtiff-4.1.0-1

nghttp2-1.41.0-1

sqlite3-3.32.2-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        A MMX/SSE2/SIMD accelerated library for manipulating JPEG image files
4Summary(ja):    MMX/SSE2/SIMD でアクセラレーションされた libjpeg ライブラリ
5
6Name:           libjpeg-turbo
7Version:        2.0.4
8Release:        2%{?_dist_release}
9
10Group:          System Environment/Libraries
11License:        IJG
12URL:            http://sourceforge.net/projects/libjpeg-turbo
13Vendor:         Project Vine
14Distribution:   Vine Linux
15
16Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
17Patch0:         libjpeg-turbo-cmake.patch
18Patch1:         libjpeg-turbo-CET.patch
19Patch1000:      CVE-2020-13790.patch
20BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
21
22BuildRequires:  cmake
23%ifarch %{ix86} x86_64
24BuildRequires:  nasm
25%endif
26
27Obsoletes:      libjpeg < 6b-50vl6
28Provides:       libjpeg = 6b-50vl6
29
30%description
31The libjpeg-turbo package contains a library of functions for manipulating
32JPEG images
33
34%package devel
35Summary:        Headers for the libjpeg-turbo library
36Summary(ja):    libjpeg-turbo ライブラリのヘッダファイル
37Group:          Development/Libraries
38Obsoletes:      libjpeg-devel < 6b-50vl6
39Obsoletes:      libjpeg-static < 6b-50vl6
40Provides:       libjpeg-devel = 6b-50vl6
41Requires:       libjpeg-turbo = %{version}-%{release}
42
43%description devel
44This package contains header files necessary for developing programs which
45will manipulate JPEG files using the libjpeg-turbo library
46
47%package utils
48Summary:        Utilities for manipulating JPEG images
49Summary(ja):    JPEG イメージを操作するためのユーティリティ
50Group:          Applications/Multimedia
51Requires:       libjpeg-turbo = %{version}-%{release}
52
53%description utils
54The libjpeg-turbo-utils package contains simple client programs for
55accessing the libjpeg functions. It contains cjpeg, djpeg, jpegtran,
56rdjpgcom and wrjpgcom. Cjpeg compresses an image file into JPEG format.
57Djpeg decompresses a JPEG file into a regular image file. Jpegtran
58can perform various useful transformations on JPEG files. Rdjpgcom
59displays any text comments included in a JPEG file. Wrjpgcom inserts
60text comments into a JPEG file.
61
62## to build compat32 for x86_64 architecture support
63%package -n compat32-%{name}
64Summary:        A MMX/SSE2 accelerated library for manipulating JPEG image files
65Summary(ja):    MMX/SSE2 でアクセラレーションされた libjpeg ライブラリ
66Group:          System Environment/Libraries
67Obsoletes:      compat32-libjpeg < 6b-50vl6
68Provides:       compat32-libjpeg = 6b-50vl6
69
70%description -n compat32-%{name}
71The libjpeg-turbo package contains a library of functions for manipulating
72JPEG images
73
74%package -n compat32-%{name}-devel
75Summary:        Headers for the libjpeg-turbo library
76Summary(ja):    libjpeg-turbo ライブラリのヘッダファイル
77Group:          Development/Libraries
78Obsoletes:      compat32-libjpeg-devel < 6b-50vl6
79Provides:       compat32-libjpeg-devel = 6b-50vl6
80Requires:       libjpeg-turbo = %{version}-%{release}
81
82%description -n compat32-%{name}-devel
83This package contains header files necessary for developing programs which
84will manipulate JPEG files using the libjpeg-turbo library
85
86
87%prep
88%setup -q
89%patch0 -p1
90%patch1 -p1
91%patch1000 -p1
92
93
94%build
95%ifarch %{ix86} x86_64
96export LDFLAGS="$RPM_LD_FLAGS -Wl,-z,ibt -Wl,-z,shstk"
97%endif
98
99mkdir jpeg6
100pushd jpeg6
101%{cmake} \
102         -DCMAKE_SKIP_RPATH:BOOL=YES \
103         -DCMAKE_SKIP_INSTALL_RPATH:BOOL=YES \
104         -DENABLE_STATIC:BOOL=NO \
105         ..
106
107make %{?_smp_mflags} V=1
108popd
109
110mkdir jpeg8
111pushd jpeg8
112%{cmake} \
113         -DWITH_JPEG8=YES \
114         -DCMAKE_SKIP_RPATH:BOOL=YES \
115         -DCMAKE_SKIP_INSTALL_RPATH:BOOL=YES \
116         -DENABLE_STATIC:BOOL=NO \
117         ..
118
119make %{?_smp_mflags} V=1
120popd
121
122
123# Fix perms
124chmod -x README.md
125
126
127
128%install
129rm -rf %{buildroot}
130pushd jpeg6
131make install DESTDIR=%{buildroot}
132popd
133
134rm -rf %{buildroot}%{_mandir}/*
135rm -f %{buildroot}%{_includedir}/*
136rm -f %{buildroot}%{_bindir}/*
137rm -f %{buildroot}%{_libdir}/pkgconfig/*
138rm -f %{buildroot}%{_libdir}/lib*.so
139
140pushd jpeg8
141make install DESTDIR=%{buildroot}
142popd
143
144# Remove unwanted files
145rm -f %{buildroot}/%{_libdir}/lib{,turbo}jpeg.la
146
147
148%check
149pushd jpeg6
150LD_LIBRARY_PATH=%{buildroot}%{_libdir} make test %{?_smp_mflags}
151popd
152
153pushd jpeg8
154LD_LIBRARY_PATH=%{buildroot}%{_libdir} make test %{?_smp_mflags}
155popd
156
157
158%clean
159rm -rf %{buildroot}
160
161
162%post -p /sbin/ldconfig
163%postun -p /sbin/ldconfig
164%post -n compat32-%{name} -p /sbin/ldconfig
165%postun -n compat32-%{name} -p /sbin/ldconfig
166
167%files
168%defattr(-,root,root,-)
169%license LICENSE.md
170%doc README.md README.ijg ChangeLog.md
171%{_libdir}/libjpeg.so.*
172%{_libdir}/libturbojpeg.so.*
173
174%files devel
175%defattr(-,root,root,-)
176%doc coderules.txt jconfig.txt libjpeg.txt structure.txt example.c
177%{_includedir}/jconfig.h
178%{_includedir}/jerror.h
179%{_includedir}/jmorecfg.h
180%{_includedir}/jpegint.h
181%{_includedir}/jpeglib.h
182%{_includedir}/turbojpeg.h
183%{_libdir}/libjpeg.so
184%{_libdir}/libturbojpeg.so
185%{_libdir}/pkgconfig/libjpeg.pc
186%{_libdir}/pkgconfig/libturbojpeg.pc
187
188%files utils
189%defattr(-,root,root,-)
190%doc usage.txt wizard.txt
191%{_bindir}/cjpeg
192%{_bindir}/djpeg
193%{_bindir}/jpegtran
194%{_bindir}/rdjpgcom
195%{_bindir}/wrjpgcom
196%{_mandir}/man1/cjpeg.1*
197%{_mandir}/man1/djpeg.1*
198%{_mandir}/man1/jpegtran.1*
199%{_mandir}/man1/rdjpgcom.1*
200%{_mandir}/man1/wrjpgcom.1*
201
202## to build compat32 for x86_64 architecture support
203%if %{build_compat32}
204%files -n compat32-%{name}
205%defattr(-,root,root)
206%{_libdir}/libjpeg.so.*
207%{_libdir}/libturbojpeg.so.*
208
209%files -n compat32-%{name}-devel
210%defattr(-,root,root)
211%{_libdir}/*.so
212%endif
213
214%changelog
215* Mon Jun 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.4-2
216- added Patch1000 to fix CVE-2020-13790.
217
218* Mon Feb 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.4-1
219- new upstream release.
220
221* Sat Oct 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.3-2
222- built both of libjpeg.so.62 and libjpeg.so.8.
223
224* Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.3-1
225- new upstream release.
226- dropped all patches.
227- imported Patch0 and 1 from rawhide.
228
229* Tue Dec 19 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.5.3-1
230- update to 1.5.3
231- update Patch0,doc
232
233* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
234- update to 1.4.2
235- update Patch0
236
237* Sun Sep 07 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.3.1-1
238- update to 1.3.1
239- ship turbojpeg library and headers
240
241* Sun Jul 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-2
242- rebuild with VineSeed environment
243
244* Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
245- new upstream release
246
247* Tue Mar 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
248- new upstream release
249
250* Tue Sep 14 2010 Daisuke SUZUKI <daisuke@linux.or.jp>  1.0.0-1
251- initial build for Vine Linux
252
253* Wed Aug 04 2010 Adam Tkac <atkac redhat com> 1.0.0-3
254- fix huffman decoder to handle broken JPEGs well (#617469)
255
256* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.0-2
257- add libjpeg-devel%%{_isa} provides to -devel subpkg to satisfy imlib-devel
258  deps
259
260* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.0-1
261- update to 1.0.0
262- patches merged
263  - libjpeg-turbo-programs.patch
264  - libjpeg-turbo-nosimd.patch
265- add libjpeg provides to the main package to workaround problems with broken
266  java-1.6.0-openjdk package
267
268* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 0.0.93-13
269- remove libjpeg provides from -utils subpkg
270
271* Wed Jun 30 2010 Rex Dieter <rdieter@fedoraproject.org> 0.0.93-12
272- move Obsoletes: libjpeg to main pkg
273
274* Wed Jun 30 2010 Rex Dieter <rdieter@fedoraproject.org> 0.0.93-11
275- -utils: Requires: %%name ...
276
277* Wed Jun 30 2010 Adam Tkac <atkac redhat com> 0.0.93-10
278- add Provides = libjpeg to -utils subpackage
279
280* Mon Jun 28 2010 Adam Tkac <atkac redhat com> 0.0.93-9
281- merge review related fixes (#600243)
282
283* Wed Jun 16 2010 Adam Tkac <atkac redhat com> 0.0.93-8
284- merge review related fixes (#600243)
285
286* Mon Jun 14 2010 Adam Tkac <atkac redhat com> 0.0.93-7
287- obsolete -static libjpeg subpackage (#600243)
288
289* Mon Jun 14 2010 Adam Tkac <atkac redhat com> 0.0.93-6
290- improve package description a little (#600243)
291- include example.c as %%doc in the -devel subpackage
292
293* Fri Jun 11 2010 Adam Tkac <atkac redhat com> 0.0.93-5
294- don't use "fc12" disttag in obsoletes/provides (#600243)
295
296* Thu Jun 10 2010 Adam Tkac <atkac redhat com> 0.0.93-4
297- fix compilation on platforms without MMX/SSE (#600243)
298
299* Thu Jun 10 2010 Adam Tkac <atkac redhat com> 0.0.93-3
300- package review related fixes (#600243)
301
302* Wed Jun 09 2010 Adam Tkac <atkac redhat com> 0.0.93-2
303- package review related fixes (#600243)
304
305* Fri Jun 04 2010 Adam Tkac <atkac redhat com> 0.0.93-1
306- initial package
Note: See TracBrowser for help on using the repository browser.