source: projects/specs/trunk/lib/libj/libjpeg-turbo/libjpeg-turbo-vl.spec @ 12320

Revision 12320, 8.2 KB checked in by tomop, 4 years ago (diff)

updated 18 packages

clamav-0.102.2-1

dhcpcd-8.1.1-1

dovecot-2.3.9.3-1

golang-1.13.5-1

llvm-9.0.1-1

libjpeg-turbo-2.0.4-1

libserf-1.3.9-2

libxml2-2.9.10-2

mariadb-10.4.12-1

nodejs-12.16.0-1

php-ext-clearsilver-0.4-15

php73-7.3.14-1

python-pillow-6.2.2-1

rust-1.40.0-1

spamassassin-3.4.4-1

sqlite3-3.31.1-1

squid-4.10-1

sudo-1.8.31-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        A MMX/SSE2/SIMD accelerated library for manipulating JPEG image files
4Summary(ja):    MMX/SSE2/SIMD でアクセラレーションされた libjpeg ライブラリ
5
6Name:           libjpeg-turbo
7Version:        2.0.4
8Release:        1%{?_dist_release}
9
10Group:          System Environment/Libraries
11License:        IJG
12URL:            http://sourceforge.net/projects/libjpeg-turbo
13Vendor:         Project Vine
14Distribution:   Vine Linux
15
16Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
17Patch0:         libjpeg-turbo-cmake.patch
18Patch1:         libjpeg-turbo-CET.patch
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
21
22BuildRequires:  cmake
23%ifarch %{ix86} x86_64
24BuildRequires:  nasm
25%endif
26
27Obsoletes:      libjpeg < 6b-50vl6
28Provides:       libjpeg = 6b-50vl6
29
30%description
31The libjpeg-turbo package contains a library of functions for manipulating
32JPEG images
33
34%package devel
35Summary:        Headers for the libjpeg-turbo library
36Summary(ja):    libjpeg-turbo ライブラリのヘッダファイル
37Group:          Development/Libraries
38Obsoletes:      libjpeg-devel < 6b-50vl6
39Obsoletes:      libjpeg-static < 6b-50vl6
40Provides:       libjpeg-devel = 6b-50vl6
41Requires:       libjpeg-turbo = %{version}-%{release}
42
43%description devel
44This package contains header files necessary for developing programs which
45will manipulate JPEG files using the libjpeg-turbo library
46
47%package utils
48Summary:        Utilities for manipulating JPEG images
49Summary(ja):    JPEG イメージを操作するためのユーティリティ
50Group:          Applications/Multimedia
51Requires:       libjpeg-turbo = %{version}-%{release}
52
53%description utils
54The libjpeg-turbo-utils package contains simple client programs for
55accessing the libjpeg functions. It contains cjpeg, djpeg, jpegtran,
56rdjpgcom and wrjpgcom. Cjpeg compresses an image file into JPEG format.
57Djpeg decompresses a JPEG file into a regular image file. Jpegtran
58can perform various useful transformations on JPEG files. Rdjpgcom
59displays any text comments included in a JPEG file. Wrjpgcom inserts
60text comments into a JPEG file.
61
62## to build compat32 for x86_64 architecture support
63%package -n compat32-%{name}
64Summary:        A MMX/SSE2 accelerated library for manipulating JPEG image files
65Summary(ja):    MMX/SSE2 でアクセラレーションされた libjpeg ライブラリ
66Group:          System Environment/Libraries
67Obsoletes:      compat32-libjpeg < 6b-50vl6
68Provides:       compat32-libjpeg = 6b-50vl6
69
70%description -n compat32-%{name}
71The libjpeg-turbo package contains a library of functions for manipulating
72JPEG images
73
74%package -n compat32-%{name}-devel
75Summary:        Headers for the libjpeg-turbo library
76Summary(ja):    libjpeg-turbo ライブラリのヘッダファイル
77Group:          Development/Libraries
78Obsoletes:      compat32-libjpeg-devel < 6b-50vl6
79Provides:       compat32-libjpeg-devel = 6b-50vl6
80Requires:       libjpeg-turbo = %{version}-%{release}
81
82%description -n compat32-%{name}-devel
83This package contains header files necessary for developing programs which
84will manipulate JPEG files using the libjpeg-turbo library
85
86
87%prep
88%setup -q
89%patch0 -p1
90%patch1 -p1
91
92
93%build
94%ifarch %{ix86} x86_64
95export LDFLAGS="$RPM_LD_FLAGS -Wl,-z,ibt -Wl,-z,shstk"
96%endif
97
98mkdir jpeg6
99pushd jpeg6
100%{cmake} \
101         -DCMAKE_SKIP_RPATH:BOOL=YES \
102         -DCMAKE_SKIP_INSTALL_RPATH:BOOL=YES \
103         -DENABLE_STATIC:BOOL=NO \
104         ..
105
106make %{?_smp_mflags} V=1
107popd
108
109mkdir jpeg8
110pushd jpeg8
111%{cmake} \
112         -DWITH_JPEG8=YES \
113         -DCMAKE_SKIP_RPATH:BOOL=YES \
114         -DCMAKE_SKIP_INSTALL_RPATH:BOOL=YES \
115         -DENABLE_STATIC:BOOL=NO \
116         ..
117
118make %{?_smp_mflags} V=1
119popd
120
121
122# Fix perms
123chmod -x README.md
124
125
126
127%install
128rm -rf %{buildroot}
129pushd jpeg6
130make install DESTDIR=%{buildroot}
131popd
132
133rm -rf %{buildroot}%{_mandir}/*
134rm -f %{buildroot}%{_includedir}/*
135rm -f %{buildroot}%{_bindir}/*
136rm -f %{buildroot}%{_libdir}/pkgconfig/*
137rm -f %{buildroot}%{_libdir}/lib*.so
138
139pushd jpeg8
140make install DESTDIR=%{buildroot}
141popd
142
143# Remove unwanted files
144rm -f %{buildroot}/%{_libdir}/lib{,turbo}jpeg.la
145
146
147%check
148pushd jpeg6
149LD_LIBRARY_PATH=%{buildroot}%{_libdir} make test %{?_smp_mflags}
150popd
151
152pushd jpeg8
153LD_LIBRARY_PATH=%{buildroot}%{_libdir} make test %{?_smp_mflags}
154popd
155
156
157%clean
158rm -rf %{buildroot}
159
160
161%post -p /sbin/ldconfig
162%postun -p /sbin/ldconfig
163%post -n compat32-%{name} -p /sbin/ldconfig
164%postun -n compat32-%{name} -p /sbin/ldconfig
165
166%files
167%defattr(-,root,root,-)
168%license LICENSE.md
169%doc README.md README.ijg ChangeLog.md
170%{_libdir}/libjpeg.so.*
171%{_libdir}/libturbojpeg.so.*
172
173%files devel
174%defattr(-,root,root,-)
175%doc coderules.txt jconfig.txt libjpeg.txt structure.txt example.c
176%{_includedir}/jconfig.h
177%{_includedir}/jerror.h
178%{_includedir}/jmorecfg.h
179%{_includedir}/jpegint.h
180%{_includedir}/jpeglib.h
181%{_includedir}/turbojpeg.h
182%{_libdir}/libjpeg.so
183%{_libdir}/libturbojpeg.so
184%{_libdir}/pkgconfig/libjpeg.pc
185%{_libdir}/pkgconfig/libturbojpeg.pc
186
187%files utils
188%defattr(-,root,root,-)
189%doc usage.txt wizard.txt
190%{_bindir}/cjpeg
191%{_bindir}/djpeg
192%{_bindir}/jpegtran
193%{_bindir}/rdjpgcom
194%{_bindir}/wrjpgcom
195%{_mandir}/man1/cjpeg.1*
196%{_mandir}/man1/djpeg.1*
197%{_mandir}/man1/jpegtran.1*
198%{_mandir}/man1/rdjpgcom.1*
199%{_mandir}/man1/wrjpgcom.1*
200
201## to build compat32 for x86_64 architecture support
202%if %{build_compat32}
203%files -n compat32-%{name}
204%defattr(-,root,root)
205%{_libdir}/libjpeg.so.*
206%{_libdir}/libturbojpeg.so.*
207
208%files -n compat32-%{name}-devel
209%defattr(-,root,root)
210%{_libdir}/*.so
211%endif
212
213%changelog
214* Mon Feb 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.4-1
215- new upstream release.
216
217* Sat Oct 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.3-2
218- built both of libjpeg.so.62 and libjpeg.so.8.
219
220* Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.3-1
221- new upstream release.
222- dropped all patches.
223- imported Patch0 and 1 from rawhide.
224
225* Tue Dec 19 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.5.3-1
226- update to 1.5.3
227- update Patch0,doc
228
229* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
230- update to 1.4.2
231- update Patch0
232
233* Sun Sep 07 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.3.1-1
234- update to 1.3.1
235- ship turbojpeg library and headers
236
237* Sun Jul 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-2
238- rebuild with VineSeed environment
239
240* Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
241- new upstream release
242
243* Tue Mar 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
244- new upstream release
245
246* Tue Sep 14 2010 Daisuke SUZUKI <daisuke@linux.or.jp>  1.0.0-1
247- initial build for Vine Linux
248
249* Wed Aug 04 2010 Adam Tkac <atkac redhat com> 1.0.0-3
250- fix huffman decoder to handle broken JPEGs well (#617469)
251
252* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.0-2
253- add libjpeg-devel%%{_isa} provides to -devel subpkg to satisfy imlib-devel
254  deps
255
256* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.0-1
257- update to 1.0.0
258- patches merged
259  - libjpeg-turbo-programs.patch
260  - libjpeg-turbo-nosimd.patch
261- add libjpeg provides to the main package to workaround problems with broken
262  java-1.6.0-openjdk package
263
264* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 0.0.93-13
265- remove libjpeg provides from -utils subpkg
266
267* Wed Jun 30 2010 Rex Dieter <rdieter@fedoraproject.org> 0.0.93-12
268- move Obsoletes: libjpeg to main pkg
269
270* Wed Jun 30 2010 Rex Dieter <rdieter@fedoraproject.org> 0.0.93-11
271- -utils: Requires: %%name ...
272
273* Wed Jun 30 2010 Adam Tkac <atkac redhat com> 0.0.93-10
274- add Provides = libjpeg to -utils subpackage
275
276* Mon Jun 28 2010 Adam Tkac <atkac redhat com> 0.0.93-9
277- merge review related fixes (#600243)
278
279* Wed Jun 16 2010 Adam Tkac <atkac redhat com> 0.0.93-8
280- merge review related fixes (#600243)
281
282* Mon Jun 14 2010 Adam Tkac <atkac redhat com> 0.0.93-7
283- obsolete -static libjpeg subpackage (#600243)
284
285* Mon Jun 14 2010 Adam Tkac <atkac redhat com> 0.0.93-6
286- improve package description a little (#600243)
287- include example.c as %%doc in the -devel subpackage
288
289* Fri Jun 11 2010 Adam Tkac <atkac redhat com> 0.0.93-5
290- don't use "fc12" disttag in obsoletes/provides (#600243)
291
292* Thu Jun 10 2010 Adam Tkac <atkac redhat com> 0.0.93-4
293- fix compilation on platforms without MMX/SSE (#600243)
294
295* Thu Jun 10 2010 Adam Tkac <atkac redhat com> 0.0.93-3
296- package review related fixes (#600243)
297
298* Wed Jun 09 2010 Adam Tkac <atkac redhat com> 0.0.93-2
299- package review related fixes (#600243)
300
301* Fri Jun 04 2010 Adam Tkac <atkac redhat com> 0.0.93-1
302- initial package
Note: See TracBrowser for help on using the repository browser.