source: projects/specs/trunk/lib/libj/libjpeg-turbo/libjpeg-turbo-vl.spec @ 12242

Revision 12242, 8.1 KB checked in by tomop, 5 years ago (diff)

updated 7 packages

audacity-2.2.2-1

empathy-3.12.14-2

gthumb-3.8.1-1

liferea-1.12.7-1

libjpeg-turbo-2.0.3-2

libmspack-0.10.1-1

wxGTK3-3.0.4-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        A MMX/SSE2/SIMD accelerated library for manipulating JPEG image files
4Summary(ja):    MMX/SSE2/SIMD でアクセラレーションされた libjpeg ライブラリ
5
6Name:           libjpeg-turbo
7Version:        2.0.3
8Release:        2%{?_dist_release}
9
10Group:          System Environment/Libraries
11License:        IJG
12URL:            http://sourceforge.net/projects/libjpeg-turbo
13Vendor:         Project Vine
14Distribution:   Vine Linux
15
16Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
17Patch0:         libjpeg-turbo-cmake.patch
18Patch1:         libjpeg-turbo-CET.patch
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
21
22BuildRequires:  cmake
23%ifarch %{ix86} x86_64
24BuildRequires:  nasm
25%endif
26
27Obsoletes:      libjpeg < 6b-50vl6
28Provides:       libjpeg = 6b-50vl6
29
30%description
31The libjpeg-turbo package contains a library of functions for manipulating
32JPEG images
33
34%package devel
35Summary:        Headers for the libjpeg-turbo library
36Summary(ja):    libjpeg-turbo ライブラリのヘッダファイル
37Group:          Development/Libraries
38Obsoletes:      libjpeg-devel < 6b-50vl6
39Obsoletes:      libjpeg-static < 6b-50vl6
40Provides:       libjpeg-devel = 6b-50vl6
41Requires:       libjpeg-turbo = %{version}-%{release}
42
43%description devel
44This package contains header files necessary for developing programs which
45will manipulate JPEG files using the libjpeg-turbo library
46
47%package utils
48Summary:        Utilities for manipulating JPEG images
49Summary(ja):    JPEG イメージを操作するためのユーティリティ
50Group:          Applications/Multimedia
51Requires:       libjpeg-turbo = %{version}-%{release}
52
53%description utils
54The libjpeg-turbo-utils package contains simple client programs for
55accessing the libjpeg functions. It contains cjpeg, djpeg, jpegtran,
56rdjpgcom and wrjpgcom. Cjpeg compresses an image file into JPEG format.
57Djpeg decompresses a JPEG file into a regular image file. Jpegtran
58can perform various useful transformations on JPEG files. Rdjpgcom
59displays any text comments included in a JPEG file. Wrjpgcom inserts
60text comments into a JPEG file.
61
62## to build compat32 for x86_64 architecture support
63%package -n compat32-%{name}
64Summary:        A MMX/SSE2 accelerated library for manipulating JPEG image files
65Summary(ja):    MMX/SSE2 でアクセラレーションされた libjpeg ライブラリ
66Group:          System Environment/Libraries
67Obsoletes:      compat32-libjpeg < 6b-50vl6
68Provides:       compat32-libjpeg = 6b-50vl6
69
70%description -n compat32-%{name}
71The libjpeg-turbo package contains a library of functions for manipulating
72JPEG images
73
74%package -n compat32-%{name}-devel
75Summary:        Headers for the libjpeg-turbo library
76Summary(ja):    libjpeg-turbo ライブラリのヘッダファイル
77Group:          Development/Libraries
78Obsoletes:      compat32-libjpeg-devel < 6b-50vl6
79Provides:       compat32-libjpeg-devel = 6b-50vl6
80Requires:       libjpeg-turbo = %{version}-%{release}
81
82%description -n compat32-%{name}-devel
83This package contains header files necessary for developing programs which
84will manipulate JPEG files using the libjpeg-turbo library
85
86
87%prep
88%setup -q
89%patch0 -p1
90%patch1 -p1
91
92
93%build
94%ifarch %{ix86} x86_64
95export LDFLAGS="$RPM_LD_FLAGS -Wl,-z,ibt -Wl,-z,shstk"
96%endif
97
98mkdir jpeg6
99pushd jpeg6
100%{cmake} \
101         -DCMAKE_SKIP_RPATH:BOOL=YES \
102         -DCMAKE_SKIP_INSTALL_RPATH:BOOL=YES \
103         -DENABLE_STATIC:BOOL=NO \
104         ..
105
106make %{?_smp_mflags} V=1
107popd
108
109mkdir jpeg8
110pushd jpeg8
111%{cmake} \
112         -DWITH_JPEG8=YES \
113         -DCMAKE_SKIP_RPATH:BOOL=YES \
114         -DCMAKE_SKIP_INSTALL_RPATH:BOOL=YES \
115         -DENABLE_STATIC:BOOL=NO \
116         ..
117
118make %{?_smp_mflags} V=1
119popd
120
121
122# Fix perms
123chmod -x README.md
124
125
126
127%install
128rm -rf %{buildroot}
129pushd jpeg6
130make install DESTDIR=%{buildroot}
131popd
132
133rm -rf %{buildroot}%{_mandir}/*
134rm -f %{buildroot}%{_includedir}/*
135rm -f %{buildroot}%{_bindir}/*
136rm -f %{buildroot}%{_libdir}/pkgconfig/*
137rm -f %{buildroot}%{_libdir}/lib*.so
138
139pushd jpeg8
140make install DESTDIR=%{buildroot}
141popd
142
143# Remove unwanted files
144rm -f %{buildroot}/%{_libdir}/lib{,turbo}jpeg.la
145
146
147%check
148pushd jpeg6
149LD_LIBRARY_PATH=%{buildroot}%{_libdir} make test %{?_smp_mflags}
150popd
151
152pushd jpeg8
153LD_LIBRARY_PATH=%{buildroot}%{_libdir} make test %{?_smp_mflags}
154popd
155
156
157%clean
158rm -rf %{buildroot}
159
160
161%post -p /sbin/ldconfig
162%postun -p /sbin/ldconfig
163%post -n compat32-%{name} -p /sbin/ldconfig
164%postun -n compat32-%{name} -p /sbin/ldconfig
165
166%files
167%defattr(-,root,root,-)
168%license LICENSE.md
169%doc README.md README.ijg ChangeLog.md
170%{_libdir}/libjpeg.so.*
171%{_libdir}/libturbojpeg.so.*
172
173%files devel
174%defattr(-,root,root,-)
175%doc coderules.txt jconfig.txt libjpeg.txt structure.txt example.c
176%{_includedir}/jconfig.h
177%{_includedir}/jerror.h
178%{_includedir}/jmorecfg.h
179%{_includedir}/jpegint.h
180%{_includedir}/jpeglib.h
181%{_includedir}/turbojpeg.h
182%{_libdir}/libjpeg.so
183%{_libdir}/libturbojpeg.so
184%{_libdir}/pkgconfig/libjpeg.pc
185%{_libdir}/pkgconfig/libturbojpeg.pc
186
187%files utils
188%defattr(-,root,root,-)
189%doc usage.txt wizard.txt
190%{_bindir}/cjpeg
191%{_bindir}/djpeg
192%{_bindir}/jpegtran
193%{_bindir}/rdjpgcom
194%{_bindir}/wrjpgcom
195%{_mandir}/man1/cjpeg.1*
196%{_mandir}/man1/djpeg.1*
197%{_mandir}/man1/jpegtran.1*
198%{_mandir}/man1/rdjpgcom.1*
199%{_mandir}/man1/wrjpgcom.1*
200
201## to build compat32 for x86_64 architecture support
202%if %{build_compat32}
203%files -n compat32-%{name}
204%defattr(-,root,root)
205%{_libdir}/libjpeg.so.*
206%{_libdir}/libturbojpeg.so.*
207
208%files -n compat32-%{name}-devel
209%defattr(-,root,root)
210%{_libdir}/*.so
211%endif
212
213%changelog
214* Sat Oct 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.3-2
215- built both of libjpeg.so.62 and libjpeg.so.8.
216
217* Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.3-1
218- new upstream release.
219- dropped all patches.
220- imported Patch0 and 1 from rawhide.
221
222* Tue Dec 19 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.5.3-1
223- update to 1.5.3
224- update Patch0,doc
225
226* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
227- update to 1.4.2
228- update Patch0
229
230* Sun Sep 07 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.3.1-1
231- update to 1.3.1
232- ship turbojpeg library and headers
233
234* Sun Jul 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-2
235- rebuild with VineSeed environment
236
237* Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
238- new upstream release
239
240* Tue Mar 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
241- new upstream release
242
243* Tue Sep 14 2010 Daisuke SUZUKI <daisuke@linux.or.jp>  1.0.0-1
244- initial build for Vine Linux
245
246* Wed Aug 04 2010 Adam Tkac <atkac redhat com> 1.0.0-3
247- fix huffman decoder to handle broken JPEGs well (#617469)
248
249* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.0-2
250- add libjpeg-devel%%{_isa} provides to -devel subpkg to satisfy imlib-devel
251  deps
252
253* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.0-1
254- update to 1.0.0
255- patches merged
256  - libjpeg-turbo-programs.patch
257  - libjpeg-turbo-nosimd.patch
258- add libjpeg provides to the main package to workaround problems with broken
259  java-1.6.0-openjdk package
260
261* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 0.0.93-13
262- remove libjpeg provides from -utils subpkg
263
264* Wed Jun 30 2010 Rex Dieter <rdieter@fedoraproject.org> 0.0.93-12
265- move Obsoletes: libjpeg to main pkg
266
267* Wed Jun 30 2010 Rex Dieter <rdieter@fedoraproject.org> 0.0.93-11
268- -utils: Requires: %%name ...
269
270* Wed Jun 30 2010 Adam Tkac <atkac redhat com> 0.0.93-10
271- add Provides = libjpeg to -utils subpackage
272
273* Mon Jun 28 2010 Adam Tkac <atkac redhat com> 0.0.93-9
274- merge review related fixes (#600243)
275
276* Wed Jun 16 2010 Adam Tkac <atkac redhat com> 0.0.93-8
277- merge review related fixes (#600243)
278
279* Mon Jun 14 2010 Adam Tkac <atkac redhat com> 0.0.93-7
280- obsolete -static libjpeg subpackage (#600243)
281
282* Mon Jun 14 2010 Adam Tkac <atkac redhat com> 0.0.93-6
283- improve package description a little (#600243)
284- include example.c as %%doc in the -devel subpackage
285
286* Fri Jun 11 2010 Adam Tkac <atkac redhat com> 0.0.93-5
287- don't use "fc12" disttag in obsoletes/provides (#600243)
288
289* Thu Jun 10 2010 Adam Tkac <atkac redhat com> 0.0.93-4
290- fix compilation on platforms without MMX/SSE (#600243)
291
292* Thu Jun 10 2010 Adam Tkac <atkac redhat com> 0.0.93-3
293- package review related fixes (#600243)
294
295* Wed Jun 09 2010 Adam Tkac <atkac redhat com> 0.0.93-2
296- package review related fixes (#600243)
297
298* Fri Jun 04 2010 Adam Tkac <atkac redhat com> 0.0.93-1
299- initial package
Note: See TracBrowser for help on using the repository browser.