source: projects/specs/trunk/lib/libj/libjpeg-turbo/libjpeg-turbo-vl.spec @ 11279

Revision 11279, 7.0 KB checked in by iwamoto, 6 years ago (diff)

libjpeg-turbo: update to 1.5.3

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        A MMX/SSE2 accelerated library for manipulating JPEG image files
4Summary(ja):    MMX/SSE2 でアクセラレーションされた libjpeg ライブラリ
5
6Name:           libjpeg-turbo
7Version:        1.5.3
8Release:        1%{?_dist_release}
9
10Group:          System Environment/Libraries
11License:        wxWidgets
12URL:            http://sourceforge.net/projects/libjpeg-turbo
13Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
14BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
15
16BuildRequires:  autoconf, automake, libtool
17%ifarch %{ix86} x86_64
18BuildRequires:  nasm
19%endif
20
21Obsoletes:      libjpeg < 6b-50vl6
22Provides:       libjpeg = 6b-50vl6
23
24Patch0:         libjpeg-turbo14-noinst.patch
25Patch1:         libjpeg-turbo-header-files.patch
26
27%description
28The libjpeg-turbo package contains a library of functions for manipulating
29JPEG images
30
31%package devel
32Summary:        Headers for the libjpeg-turbo library
33Summary(ja):    libjpeg-turbo ライブラリのヘッダファイル
34Group:          Development/Libraries
35Obsoletes:      libjpeg-devel < 6b-50vl6
36Obsoletes:      libjpeg-static < 6b-50vl6
37Provides:       libjpeg-devel = 6b-50vl6
38Requires:       libjpeg-turbo = %{version}-%{release}
39
40%description devel
41This package contains header files necessary for developing programs which
42will manipulate JPEG files using the libjpeg-turbo library
43
44%package utils
45Summary:        Utilities for manipulating JPEG images
46Summary(ja):    JPEG イメージを操作するためのユーティリティ
47Group:          Applications/Multimedia
48Requires:       libjpeg-turbo = %{version}-%{release}
49
50%description utils
51The libjpeg-turbo-utils package contains simple client programs for
52accessing the libjpeg functions. It contains cjpeg, djpeg, jpegtran,
53rdjpgcom and wrjpgcom. Cjpeg compresses an image file into JPEG format.
54Djpeg decompresses a JPEG file into a regular image file. Jpegtran
55can perform various useful transformations on JPEG files. Rdjpgcom
56displays any text comments included in a JPEG file. Wrjpgcom inserts
57text comments into a JPEG file.
58
59## to build compat32 for x86_64 architecture support
60%package -n compat32-%{name}
61Summary:        A MMX/SSE2 accelerated library for manipulating JPEG image files
62Summary(ja):    MMX/SSE2 でアクセラレーションされた libjpeg ライブラリ
63Group:          System Environment/Libraries
64Obsoletes:      compat32-libjpeg < 6b-50vl6
65Provides:       compat32-libjpeg = 6b-50vl6
66
67%description -n compat32-%{name}
68The libjpeg-turbo package contains a library of functions for manipulating
69JPEG images
70
71%package -n compat32-%{name}-devel
72Summary:        Headers for the libjpeg-turbo library
73Summary(ja):    libjpeg-turbo ライブラリのヘッダファイル
74Group:          Development/Libraries
75Obsoletes:      compat32-libjpeg-devel < 6b-50vl6
76Provides:       compat32-libjpeg-devel = 6b-50vl6
77Requires:       libjpeg-turbo = %{version}-%{release}
78
79%description -n compat32-%{name}-devel
80This package contains header files necessary for developing programs which
81will manipulate JPEG files using the libjpeg-turbo library
82
83%prep
84%setup -q
85
86%patch0 -p1 -b .noinst_jpgtest
87%patch1 -p1 -b .turbo_headers
88
89%build
90autoreconf -fiv
91
92%configure --disable-static
93
94make %{?_smp_mflags}
95
96%install
97rm -rf $RPM_BUILD_ROOT
98make install DESTDIR=$RPM_BUILD_ROOT
99
100# Remove unwanted files
101rm -f $RPM_BUILD_ROOT/%{_libdir}/lib{,turbo}jpeg.la
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%post -p /sbin/ldconfig
107%postun -p /sbin/ldconfig
108%post -n compat32-%{name} -p /sbin/ldconfig
109%postun -n compat32-%{name} -p /sbin/ldconfig
110
111%files
112%defattr(-,root,root,-)
113%doc README.md README.ijg ChangeLog.md
114%{_libdir}/libjpeg.so.62*
115%{_libdir}/libturbojpeg.so.0*
116
117%files devel
118%defattr(-,root,root,-)
119%doc coderules.txt jconfig.txt libjpeg.txt structure.txt example.c
120%{_includedir}/jconfig.h
121%{_includedir}/jerror.h
122%{_includedir}/jmorecfg.h
123%{_includedir}/jpegint.h
124%{_includedir}/jpeglib.h
125%{_includedir}/turbojpeg.h
126%{_libdir}/libjpeg.so
127%{_libdir}/libturbojpeg.so
128%{_libdir}/pkgconfig/libjpeg.pc
129%{_libdir}/pkgconfig/libturbojpeg.pc
130
131%files utils
132%defattr(-,root,root,-)
133%doc usage.txt wizard.txt
134%{_bindir}/cjpeg
135%{_bindir}/djpeg
136%{_bindir}/jpegtran
137%{_bindir}/rdjpgcom
138%{_bindir}/wrjpgcom
139%{_mandir}/man1/cjpeg.1*
140%{_mandir}/man1/djpeg.1*
141%{_mandir}/man1/jpegtran.1*
142%{_mandir}/man1/rdjpgcom.1*
143%{_mandir}/man1/wrjpgcom.1*
144
145## to build compat32 for x86_64 architecture support
146%if %{build_compat32}
147%files -n compat32-%{name}
148%defattr(-,root,root)
149%{_libdir}/libjpeg.so.*
150%{_libdir}/libturbojpeg.so.*
151
152%files -n compat32-%{name}-devel
153%defattr(-,root,root)
154%{_libdir}/*.so
155%endif
156
157%changelog
158* Tue Dec 19 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.5.3-1
159- update to 1.5.3
160- update Patch0,doc
161
162* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
163- update to 1.4.2
164- update Patch0
165
166* Sun Sep 07 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.3.1-1
167- update to 1.3.1
168- ship turbojpeg library and headers
169
170* Sun Jul 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-2
171- rebuild with VineSeed environment
172
173* Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
174- new upstream release
175
176* Tue Mar 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
177- new upstream release
178
179* Tue Sep 14 2010 Daisuke SUZUKI <daisuke@linux.or.jp>  1.0.0-1
180- initial build for Vine Linux
181
182* Wed Aug 04 2010 Adam Tkac <atkac redhat com> 1.0.0-3
183- fix huffman decoder to handle broken JPEGs well (#617469)
184
185* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.0-2
186- add libjpeg-devel%%{_isa} provides to -devel subpkg to satisfy imlib-devel
187  deps
188
189* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.0-1
190- update to 1.0.0
191- patches merged
192  - libjpeg-turbo-programs.patch
193  - libjpeg-turbo-nosimd.patch
194- add libjpeg provides to the main package to workaround problems with broken
195  java-1.6.0-openjdk package
196
197* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 0.0.93-13
198- remove libjpeg provides from -utils subpkg
199
200* Wed Jun 30 2010 Rex Dieter <rdieter@fedoraproject.org> 0.0.93-12
201- move Obsoletes: libjpeg to main pkg
202
203* Wed Jun 30 2010 Rex Dieter <rdieter@fedoraproject.org> 0.0.93-11
204- -utils: Requires: %%name ...
205
206* Wed Jun 30 2010 Adam Tkac <atkac redhat com> 0.0.93-10
207- add Provides = libjpeg to -utils subpackage
208
209* Mon Jun 28 2010 Adam Tkac <atkac redhat com> 0.0.93-9
210- merge review related fixes (#600243)
211
212* Wed Jun 16 2010 Adam Tkac <atkac redhat com> 0.0.93-8
213- merge review related fixes (#600243)
214
215* Mon Jun 14 2010 Adam Tkac <atkac redhat com> 0.0.93-7
216- obsolete -static libjpeg subpackage (#600243)
217
218* Mon Jun 14 2010 Adam Tkac <atkac redhat com> 0.0.93-6
219- improve package description a little (#600243)
220- include example.c as %%doc in the -devel subpackage
221
222* Fri Jun 11 2010 Adam Tkac <atkac redhat com> 0.0.93-5
223- don't use "fc12" disttag in obsoletes/provides (#600243)
224
225* Thu Jun 10 2010 Adam Tkac <atkac redhat com> 0.0.93-4
226- fix compilation on platforms without MMX/SSE (#600243)
227
228* Thu Jun 10 2010 Adam Tkac <atkac redhat com> 0.0.93-3
229- package review related fixes (#600243)
230
231* Wed Jun 09 2010 Adam Tkac <atkac redhat com> 0.0.93-2
232- package review related fixes (#600243)
233
234* Fri Jun 04 2010 Adam Tkac <atkac redhat com> 0.0.93-1
235- initial package
Note: See TracBrowser for help on using the repository browser.