source: projects/specs/trunk/lib/libi/libindi/libindi-vl.spec @ 846

Revision 846, 3.5 KB checked in by inagaki, 14 years ago (diff)

updated: libindi, libnova, cfitsio

Line 
1Name: libindi
2Version: 0.6
3Release: 11%{?_dist_release}
4Summary: Instrument Neutral Distributed Interface
5
6Group: System Environment/Libraries
7License: LGPLv2+ and GPLv2+
8# The code is LGPLv2+ except:
9# some files for v4l2 conversion under libs/webcam are GPLv2+
10# drivers/video/stvdriver (indi_stv driver) appears to contain GPL code
11# upstream bug https://sourceforge.net/tracker2/?func=detail&aid=2572902&group_id=90275&atid=593019
12
13URL: http://indi.sourceforge.net/
14
15%define majorver 0
16
17Source0: http://downloads.sourceforge.net/indi/%{name}%{majorver}_%{version}.tar.gz
18Patch0: libindi-suffix.patch
19Patch1: libindi-cfitsio.patch
20Buildroot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: cmake
22BuildRequires: cfitsio-devel
23BuildRequires: zlib-devel
24BuildRequires: libnova-devel libfli-devel
25
26%description
27INDI is a distributed control protocol designed to operate
28astronomical instrumentation. INDI is small, flexible, easy to parse,
29and scalable. It supports common DCS functions such as remote control,
30data acquisition, monitoring, and a lot more.
31
32
33%package devel
34Summary: Libraries, includes, etc. used to develop an application with %{name}
35Group: Development/Libraries
36Requires: %{name} = %{version}-%{release}
37Provides: libindi-static = %{version}-%{release}
38
39%description devel
40These are the header files needed to develop a %{name} application
41
42%prep
43%setup -q -n %{name}%{majorver}-%{version}
44%patch0 -p1
45%patch1 -p1
46
47%build
48mkdir -p %{_target_platform}
49pushd %{_target_platform}
50CFLAGS="${CFLAGS:-%optflags}" \
51CXXFLAGS="${CXXFLAGS:-%optflags}" \
52FFLAGS="${FFLAGS:-%optflags}" \
53%cmake \
54    -DCMAKE_BUILD_TYPE=release \
55    -DDATA_INSTALL_DIR:PATH=%{_datadir} \
56    ..
57popd
58
59make VERBOSE=1 %{?_smp_mflags} -C %{_target_platform}
60
61%install
62rm -fr %{buildroot}
63make install DESTDIR=%{buildroot} -C %{_target_platform}
64
65%clean
66rm -fr %{buildroot}
67
68%post -p /sbin/ldconfig
69
70%postun -p /sbin/ldconfig
71
72%files
73%defattr(-,root,root,-)
74%doc AUTHORS ChangeLog COPYING.LIB LICENSE README README.drivers README.robofocus
75%{_bindir}/*
76%{_libdir}/*.so.*
77%{_datadir}/indi
78
79%files devel
80%defattr(-,root,root,-)
81%doc README COPYING.LIB LICENSE
82%{_includedir}/*
83%{_libdir}/*.so
84%{_libdir}/*.a
85
86%changelog
87* Sat Apr 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6-11
88- rebuilt with new toolchain and libnova-0.13
89
90* Sat Sep 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> - 0.6-10
91- use %%cmake macro
92
93* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6-9
94- Inisital build for Vine Linux
95
96* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-8
97- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
98
99* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-7
100- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
101
102* Wed Feb 18 2009 Sergio Pascual <sergiopr at fedoraproject.org> -  0.6-6
103- Provides libindi-static
104
105* Tue Feb 17 2009 Sergio Pascual <sergiopr at fedoraproject.org> -  0.6-5
106- Need to provide the static library libindidriver.a to build indi-apogee
107
108* Sat Feb 14 2009 Sergio Pascual <sergiopr at fedoraproject.org> -  0.6-4
109- Fixed patch to find cfitsio
110
111* Sat Feb 14 2009 Sergio Pascual <sergiopr at fedoraproject.org> -  0.6-3
112- Patch to detect cfitsio in all architectures
113
114* Fri Feb 06 2009 Sergio Pascual <sergiopr at fedoraproject.org> -  0.6-2
115- Commands (rm, make) instead of macros
116- Upstream bug about licenses (GPLv2 missing)
117- Upstream bug about libindi calling exit
118
119* Mon Jan 28 2009 Sergio Pascual <sergiopr at fedoraproject.org> -  0.6-1
120- First version
Note: See TracBrowser for help on using the repository browser.