source: projects/specs/trunk/lib/libi/libindi/libindi-vl.spec @ 4722

Revision 4722, 4.0 KB checked in by inagaki, 13 years ago (diff)

update: libindi, libnova, cfitsio

Line 
1%define majorver 0
2
3Name: libindi
4Summary: Instrument Neutral Distributed Interface
5Version: 0.8
6Release: 1%{?_dist_release}
7
8Group: System Environment/Libraries
9License: LGPLv2+ and GPLv2+
10# The code is LGPLv2+ except:
11# some files for v4l2 conversion under libs/webcam are GPLv2+
12# drivers/video/stvdriver (indi_stv driver) appears to contain GPL code
13# upstream bug https://sourceforge.net/tracker2/?func=detail&aid=2572902&group_id=90275&atid=593019
14URL: http://indi.sourceforge.net/
15
16Source0: http://downloads.sourceforge.net/indi/%{name}_%{version}.tar.gz
17Patch0: libindi-suffix.patch
18
19Buildroot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: cmake
21BuildRequires: cfitsio-devel >= 3.03
22BuildRequires: libboost-devel
23BuildRequires: libnova-devel >= 0.12.1
24BuildRequires: libusb-devel
25BuildRequires: zlib-devel
26
27Conflicts: kdeedu3
28
29%description
30INDI is a distributed control protocol designed to operate
31astronomical instrumentation. INDI is small, flexible, easy to parse,
32and scalable. It supports common DCS functions such as remote control,
33data acquisition, monitoring, and a lot more.
34
35
36%package devel
37Summary: Libraries, includes, etc. used to develop an application with %{name}
38Group: Development/Libraries
39Requires: %{name} = %{version}-%{release}
40Provides: libindi-static = %{version}-%{release}
41
42%description devel
43These are the header files needed to develop a %{name} application
44
45%prep
46%setup -q -n %{name}-%{version}
47%patch0 -p1
48#patch1 -p1
49
50%build
51mkdir -p %{_target_platform}
52pushd %{_target_platform}
53CFLAGS="${CFLAGS:-%optflags}" \
54CXXFLAGS="${CXXFLAGS:-%optflags}" \
55FFLAGS="${FFLAGS:-%optflags}" \
56%cmake \
57    -DCMAKE_BUILD_TYPE=release \
58    -DDATA_INSTALL_DIR:PATH=%{_datadir} \
59    ..
60popd
61
62make VERBOSE=1 %{?_smp_mflags} -C %{_target_platform}
63
64%install
65rm -fr %{buildroot}
66make install DESTDIR=%{buildroot} -C %{_target_platform}
67
68%clean
69rm -fr %{buildroot}
70
71%post -p /sbin/ldconfig
72
73%postun -p /sbin/ldconfig
74
75%files
76%defattr(-,root,root,-)
77%doc AUTHORS ChangeLog COPYING.LIB LICENSE README README.drivers
78%{_bindir}/*
79%{_libdir}/*.so.*
80%{_datadir}/indi
81
82%files devel
83%defattr(-,root,root,-)
84%doc README COPYING.LIB LICENSE
85%{_includedir}/*
86%{_libdir}/*.so
87%{_libdir}/*.a
88%{_libdir}/pkgconfig/*.pc
89
90%changelog
91* Sun Aug 28 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.8.0-1
92- new upstream release
93- updated Patch0
94- built with libnova-0.14
95
96* Thu Sep 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6.3-1
97- rebuilt with rpm-4.8.1 for pkg-config
98
99* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6.2-1
100- new upstream release
101- updated Patch0
102
103* Wed Jul  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6-12
104- added Conflicts: kdeedu3
105
106* Sat Apr 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6-11
107- rebuilt with new toolchain and libnova-0.13
108
109* Sat Sep 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> - 0.6-10
110- use %%cmake macro
111
112* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6-9
113- Inisital build for Vine Linux
114
115* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-8
116- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
117
118* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-7
119- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
120
121* Wed Feb 18 2009 Sergio Pascual <sergiopr at fedoraproject.org> -  0.6-6
122- Provides libindi-static
123
124* Tue Feb 17 2009 Sergio Pascual <sergiopr at fedoraproject.org> -  0.6-5
125- Need to provide the static library libindidriver.a to build indi-apogee
126
127* Sat Feb 14 2009 Sergio Pascual <sergiopr at fedoraproject.org> -  0.6-4
128- Fixed patch to find cfitsio
129
130* Sat Feb 14 2009 Sergio Pascual <sergiopr at fedoraproject.org> -  0.6-3
131- Patch to detect cfitsio in all architectures
132
133* Fri Feb 06 2009 Sergio Pascual <sergiopr at fedoraproject.org> -  0.6-2
134- Commands (rm, make) instead of macros
135- Upstream bug about licenses (GPLv2 missing)
136- Upstream bug about libindi calling exit
137
138* Mon Jan 28 2009 Sergio Pascual <sergiopr at fedoraproject.org> -  0.6-1
139- First version
Note: See TracBrowser for help on using the repository browser.