source: projects/specs/trunk/lib/libi/libindi/libindi-vl.spec @ 10580

Revision 10580, 4.2 KB checked in by Takemikaduchi, 8 years ago (diff)

Xaw3d: new upstream release
others: rebuild with gcc-5.4.0

RevLine 
[4722]1%define majorver 0
2
[521]3Name: libindi
[1393]4Summary: Instrument Neutral Distributed Interface
[4722]5Version: 0.8
[10580]6Release: 3%{?_dist_release}
[521]7
[846]8Group: System Environment/Libraries
[521]9License: LGPLv2+ and GPLv2+
10# The code is LGPLv2+ except:
11# some files for v4l2 conversion under libs/webcam are GPLv2+
12# drivers/video/stvdriver (indi_stv driver) appears to contain GPL code
13# upstream bug https://sourceforge.net/tracker2/?func=detail&aid=2572902&group_id=90275&atid=593019
14URL: http://indi.sourceforge.net/
15
[1597]16Source0: http://downloads.sourceforge.net/indi/%{name}_%{version}.tar.gz
[521]17Patch0: libindi-suffix.patch
[1597]18
[521]19Buildroot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: cmake
[1597]21BuildRequires: cfitsio-devel >= 3.03
[4722]22BuildRequires: libboost-devel
[1597]23BuildRequires: libnova-devel >= 0.12.1
[4722]24BuildRequires: libusb-devel
[521]25BuildRequires: zlib-devel
26
[1393]27Conflicts: kdeedu3
28
[521]29%description
30INDI is a distributed control protocol designed to operate
31astronomical instrumentation. INDI is small, flexible, easy to parse,
32and scalable. It supports common DCS functions such as remote control,
33data acquisition, monitoring, and a lot more.
34
35
36%package devel
37Summary: Libraries, includes, etc. used to develop an application with %{name}
38Group: Development/Libraries
39Requires: %{name} = %{version}-%{release}
40Provides: libindi-static = %{version}-%{release}
41
42%description devel
43These are the header files needed to develop a %{name} application
44
45%prep
[1597]46%setup -q -n %{name}-%{version}
[521]47%patch0 -p1
[1597]48#patch1 -p1
[521]49
50%build
51mkdir -p %{_target_platform}
52pushd %{_target_platform}
53CFLAGS="${CFLAGS:-%optflags}" \
54CXXFLAGS="${CXXFLAGS:-%optflags}" \
55FFLAGS="${FFLAGS:-%optflags}" \
56%cmake \
57    -DCMAKE_BUILD_TYPE=release \
58    -DDATA_INSTALL_DIR:PATH=%{_datadir} \
59    ..
60popd
61
62make VERBOSE=1 %{?_smp_mflags} -C %{_target_platform}
63
64%install
65rm -fr %{buildroot}
66make install DESTDIR=%{buildroot} -C %{_target_platform}
67
68%clean
69rm -fr %{buildroot}
70
71%post -p /sbin/ldconfig
72
73%postun -p /sbin/ldconfig
74
75%files
76%defattr(-,root,root,-)
[4722]77%doc AUTHORS ChangeLog COPYING.LIB LICENSE README README.drivers
[521]78%{_bindir}/*
79%{_libdir}/*.so.*
80%{_datadir}/indi
81
82%files devel
83%defattr(-,root,root,-)
84%doc README COPYING.LIB LICENSE
85%{_includedir}/*
86%{_libdir}/*.so
87%{_libdir}/*.a
[1597]88%{_libdir}/pkgconfig/*.pc
[521]89
90%changelog
[10580]91* Sun Jul 10 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.0-3
92- rebuild with gcc-5.4.0
93
[9382]94* Wed Feb 25 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.8.0-2
95- rebuilt with cfitsio 3.370 and libnova 0.15.0
96
[4722]97* Sun Aug 28 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.8.0-1
98- new upstream release
99- updated Patch0
100- built with libnova-0.14
101
[1885]102* Thu Sep 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6.3-1
103- rebuilt with rpm-4.8.1 for pkg-config
104
[1597]105* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6.2-1
106- new upstream release
107- updated Patch0
108
[1393]109* Wed Jul  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6-12
110- added Conflicts: kdeedu3
111
[846]112* Sat Apr 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6-11
113- rebuilt with new toolchain and libnova-0.13
114
[521]115* Sat Sep 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> - 0.6-10
116- use %%cmake macro
117
118* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6-9
119- Inisital build for Vine Linux
120
121* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-8
122- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
123
124* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-7
125- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
126
127* Wed Feb 18 2009 Sergio Pascual <sergiopr at fedoraproject.org> -  0.6-6
128- Provides libindi-static
129
130* Tue Feb 17 2009 Sergio Pascual <sergiopr at fedoraproject.org> -  0.6-5
131- Need to provide the static library libindidriver.a to build indi-apogee
132
133* Sat Feb 14 2009 Sergio Pascual <sergiopr at fedoraproject.org> -  0.6-4
134- Fixed patch to find cfitsio
135
136* Sat Feb 14 2009 Sergio Pascual <sergiopr at fedoraproject.org> -  0.6-3
137- Patch to detect cfitsio in all architectures
138
139* Fri Feb 06 2009 Sergio Pascual <sergiopr at fedoraproject.org> -  0.6-2
140- Commands (rm, make) instead of macros
141- Upstream bug about licenses (GPLv2 missing)
142- Upstream bug about libindi calling exit
143
144* Mon Jan 28 2009 Sergio Pascual <sergiopr at fedoraproject.org> -  0.6-1
145- First version
Note: See TracBrowser for help on using the repository browser.