source: projects/specs/trunk/lib/libi/libiec61883/libiec61883-vl.spec @ 521

Revision 521, 3.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define vineseed 1
2
3Summary: Streaming library for IEEE1394
4SUmmary(ja): IEEE1394 用ストリーミングライブラリ
5Name: libiec61883
6Version: 1.1.0
7Release: 4%{?_dist_release}
8License: LGPL
9Group: System Environment/Libraries
10Source: http://linux1394.org/dl/%{name}-%{version}.tar.gz
11Patch: libiec61883-1.1.0-installtests.patch
12URL: http://linux1394.org
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14ExcludeArch: s390 s390x
15
16# Works only with newer libraw1394 versions
17%if %{vineseed}
18BuildRequires: libraw1394-devel >= 1.2.1
19%else
20BuildRequires: libraw1394_121-devel >= 1.2.1
21Requires: libraw1394_121 >= 1.2.1
22%endif
23BuildRequires: autoconf, automake, libtool
24
25%description
26
27The libiec61883 library provides an higher level API for streaming DV,
28MPEG-2 and audio over IEEE1394.  Based on the libraw1394 isochronous
29functionality, this library acts as a filter that accepts DV-frames,
30MPEG-2 frames or audio samples from the application and breaks these
31down to isochronous packets, which are transmitted using libraw1394.
32
33%package devel
34Summary:  Development files for libiec61883
35Group:    Development/Libraries
36Requires: %{name} = %{version}-%{release}
37Requires: pkgconfig
38%if %{vineseed}
39Requires: libraw1394-devel >= 1.2.1
40%else
41Requiers: libraw1394_121-devel >= 1.2.1
42%endif
43
44%description devel
45Development files needed to build applications against libiec61883
46
47%package utils
48Summary:  Utilities for use with libiec61883
49Group:    Applications/Multimedia
50Requires: %{name} = %{version}-%{release}
51
52%description utils
53Utilities that make use of iec61883
54
55%prep
56%setup -q
57%patch -p1 -b .installtests
58
59%build
60autoreconf
61export CFLAGS="%{optflags}"
62%configure
63make
64
65%install
66rm -rf %{buildroot}
67make DESTDIR=%{buildroot} install
68rm $RPM_BUILD_ROOT%{_libdir}/libiec61883.a
69rm $RPM_BUILD_ROOT%{_libdir}/libiec61883.la
70
71%clean
72rm -rf %{buildroot}
73
74%post -p /sbin/ldconfig
75
76%postun -p /sbin/ldconfig
77
78%files
79%defattr(-,root,root,-)
80%doc AUTHORS COPYING NEWS README
81%{_libdir}/libiec61883.so.*
82
83%files devel
84%defattr(-,root,root,-)
85%{_libdir}/libiec61883.so
86%{_includedir}/libiec61883/*.h
87%{_libdir}/pkgconfig/libiec61883.pc
88
89%files utils
90%defattr(-,root,root,-)
91%{_bindir}/*
92%{_mandir}/man1/*.1*
93
94%changelog
95* Sat Nov  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.1.0-4vl5
96- macros for VineSeed and VinePlus/4.0
97- spec in UTF-8
98
99* Wed Oct 29 2008 Seiichirou Babasaki - 1.1.0-3
100- Version 1.1.0 for VineLinux-4.2 (From VineSeed)
101- replase libraw1394(-devel) -> libraw1394_121(-devel)
102
103* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-2
104- new versioning policy
105
106* Sat Jun  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.1.0-1vl1
107- initial build for Vine Linux
108
109* Wed Oct 25 2006 Jarod Wilson <jwilson@redhat.com> - 1.1.0-1
110- Update to 1.1.0 release
111
112* Wed Oct 11 2006 Jarod Wilson <jwilson@redhat.com> - 1.0.0-11
113- Use %dist tag
114
115* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-10.fc5.2.1
116- rebuild
117
118* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-10.fc5.2
119- bump again for double-long bug on ppc(64)
120
121* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0-10.fc5.1
122- rebuilt for new gcc4.1 snapshot and glibc changes
123
124* Fri Dec 30 2005 Jarod Wilson <jarod@wilsonet.com> 1.0.0-10
125- Add missing autoconf, automake and libtool
126  BuildRequires
127
128* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
129- rebuilt
130
131* Fri Nov 11 2005 Warren Togami <wtogami@redhat.com> 1.0.0-9
132- incorporate some spec improvements from Matthias (#172105)
133
134* Mon Sep 19 2005 Warren Togami <wtogami@redhat.com> 1.0.0-8
135- split -devel for pkgconfig chain
136- remove .a and .la
137- exclude s390 and s390x
138
139* Tue Apr  5 2005 Axel Thimm <Axel.Thimm@ATrpms.net>
140- Fixes for building properly on x86_64.
141
142* Mon Mar 28 2005 Jarod Wilson <jarod@wilsonet.com>
143- Fixed utils so they build properly
144
145* Sat Feb 26 2005 Jarod Wilson <jarod@wilsonet.com>
146- Rolled in utils
147
148* Wed Feb 23 2005 Jarod Wilson <jarod@wilsonet.com>
149- Initial build
150
Note: See TracBrowser for help on using the repository browser.