source: projects/specs/trunk/lib/libi/libidn/libidn-vl.spec @ 12360

Revision 12360, 7.0 KB checked in by tomop, 4 years ago (diff)

updated 5 packages

libidn-1.35-1

libidn2-2.3.0-1

libusb-0.1.5-2

mktcapdir-0.6.0-3

rarian-0.8.1-7

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name: libidn
4Summary: Internationalized Domain Name support library
5Summary(ja): 国際化ドメイン名をサポートするためのライブラリ
6Version: 1.35
7Release: 1%{?_dist_release}
8Group: System Environment/Libraries
9
10Distribution: Vine Linux
11Vendor: Project Vine
12
13License: GPLv3+ and LGPLv3+
14URL: https://www.gnu.org/software/libidn/
15Source0: https://ftp.gnu.org/gnu/libidn/libidn-%{version}.tar.gz
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: gettext
19BuildRequires: pkgconfig
20Requires(post): /sbin/install-info
21Requires(preun): /sbin/install-info
22
23
24%global __provides_exclude_from ^%{_libdir}/pkgconfig/.*$
25
26
27%description
28GNU Libidn is an implementation of the Stringprep, Punycode and
29IDNA specifications defined by the IETF Internationalized Domain
30Names (IDN) working group, used for internationalized domain
31names.
32
33%package devel
34Summary: Development files for the libidn library
35Summary(ja): libidn ライブラリの開発用ファイル
36Group: Development/Libraries
37License: GPLv3+, LGPLv3+ and GFDLv1.3+
38Requires: %{name} = %{version}-%{release}
39Provides: pkgconfig(libidn) = %{version}
40
41%description devel
42This package includes header files and libraries necessary for
43developing programs which use the GNU libidn library.
44
45# compat32
46%package -n compat32-%{name}
47Summary: Internationalized Domain Name support library
48Summary(ja): 国際化ドメイン名をサポートするためのライブラリ
49Group: System Environment/Libraries
50Requires: %{name} = %{version}-%{release}
51
52%description -n compat32-%{name}
53GNU Libidn is an implementation of the Stringprep, Punycode and
54IDNA specifications defined by the IETF Internationalized Domain
55Names (IDN) working group, used for internationalized domain
56names.
57
58%package -n compat32-%{name}-devel
59Summary: Development files for the libidn library
60Summary(ja): libidn ライブラリの開発用ファイル
61Group: Development/Libraries
62License: GPLv3+, LGPLv3+ and GFDLv1.3+
63Requires: compat32-%{name} = %{version}-%{release}
64Requires: %{name}-devel = %{version}-%{release}
65
66%description -n compat32-%{name}-devel
67This package includes header files and libraries necessary for
68developing programs which use the GNU libidn library.
69
70%prep
71%setup -q
72
73# Disable static library creation by default.
74%define with_static 0
75
76%build
77%configure --disable-csharp --disable-java \
78%if ! %{with_static}
79           --disable-static
80%endif
81make %{?_smp_mflags}
82
83make %{?_smp_mflags} -C tests check
84
85%install
86[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
87%makeinstall
88
89rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.la
90
91# provide more examples
92make %{?_smp_mflags} -C examples distclean
93
94# clean up docs
95find doc -name "Makefile*" | xargs rm
96rm -rf $RPM_BUILD_ROOT%{_datadir}/info/dir
97
98%find_lang %{name}
99
100%post
101/sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir
102/sbin/ldconfig
103
104%preun
105if [ $1 = 0 ]; then
106    /sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir
107fi
108
109%postun -p /sbin/ldconfig
110
111%if %{build_compat32}
112%post -n compat32-%{name} -p /sbin/ldconfig
113
114%postun -n compat32-%{name} -p /sbin/ldconfig
115%endif
116
117%clean
118[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
119
120%files -f %{name}.lang
121%defattr(-,root,root)
122%license COPYING*
123%doc AUTHORS ChangeLog NEWS FAQ README THANKS
124%{_bindir}/idn
125%{_mandir}/man1/idn.1*
126%{_datadir}/emacs/site-lisp
127%{_libdir}/libidn.so.*
128#{_libdir}/libidn.la
129%{_infodir}/*
130
131%files devel
132%defattr(0644,root,root,755)
133%doc doc/libidn.html doc/libidn-components.png examples contrib
134%{_libdir}/libidn.so
135%if %{with_static}
136%{_libdir}/libidn.a
137%endif
138%{_includedir}/*.h
139%{_libdir}/pkgconfig/*.pc
140%{_mandir}/man3/*
141
142# compat32
143%if %{build_compat32}
144%files -n compat32-%{name}
145%defattr(-,root,root)
146%{_libdir}/libidn.so.*
147#{_libdir}/libidn.la
148
149%files -n compat32-%{name}-devel
150%defattr(0644,root,root,755)
151%{_libdir}/libidn.so
152%if %{with_static}
153%{_libdir}/libidn.a
154%endif
155%{_libdir}/pkgconfig/*.pc
156%endif
157
158%changelog
159* Sun Mar 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.35-1
160- new upstream release.
161
162* Wed Feb 18 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.29-1
163- new upstream release
164- added Japanese summary
165
166* Sat Oct  1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.22-1
167- new upstream release
168
169* Sat Sep 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.19-1
170- new upstream release
171- built with rpm-4.8.1
172
173* Sun Jun 28 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.11-2
174- added compat32 package for x86_64 arch support.
175- disabled static library creation by default.
176
177* Mon Nov 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.11-1
178- new upstream release
179
180* Thu Jun 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8-1
181- new upstream release
182- applied new versioning policy
183- added --disable-csharp and --disable-java options to %%configure
184
185* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.14-0vl1
186- new upstream release
187
188* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.9-0vl1
189- new upstream release
190
191* Wed Aug 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.18-0vl2
192- rebuild for VineSeed
193
194* Wed Aug 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.18-0vl1
195- new upstream release
196
197* Thu Dec 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.12-0vl2
198- rebuild for VineSeed
199
200* Wed Dec 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.12-0vl1
201- new upstream release
202- build for Vine Linux 3.1
203
204* Thu Oct  7 2004 Joe Orton <jorton@redhat.com> 0.5.6-1
205- update to 0.5.6 (#134343)
206
207* Thu Sep 30 2004 Miloslav Trmac <mitr@redhat.com> - 0.5.4-3
208- Fix Group: (#134068)
209
210* Tue Aug 31 2004 Joe Orton <jorton@redhat.com> 0.5.4-2
211- move ldconfig from preun to postun (#131280)
212
213* Sun Aug  8 2004 Joe Orton <jorton@redhat.com> 0.5.4-1
214- update to 0.5.4 (#129341)
215
216* Thu Jul 15 2004 Robert Scheck <redhat@linuxnetz.de> 0.5.2-1
217- upgrade to 0.5.2, enabled i18n support and info files (#127906)
218
219* Fri Jul  9 2004 Joe Orton <jorton@redhat.com> 0.5.1-1
220- update to 0.5.1 (#127496)
221
222* Mon Jun 28 2004 Joe Orton <jorton@redhat.com> 0.5.0-1
223- update to 0.5.0 (#126836)
224
225* Tue Jun 22 2004 Than Ngo <than@redhat.com> 0.4.9-2
226- add prereq: /sbin/ldconfig
227- move la file in main package
228
229* Tue Jun 15 2004 Robert Scheck <redhat@linuxnetz.de> 0.4.9-1
230- upgrade to 0.4.9 (#126353)
231
232* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
233- rebuilt
234
235* Thu Apr 29 2004 Joe Orton <jorton@redhat.com> 0.4.4-1
236- update to 0.4.4; remove contrib from -devel docs
237
238* Thu Apr 29 2004 Joe Orton <jorton@redhat.com> 0.4.3-1
239- update to 0.4.3, remove -rpath patch
240
241* Tue Jan 27 2004 Joe Orton <jorton@redhat.com> 0.3.7-1
242- update to 0.3.7, simplify
243
244* Wed Jan 07 2004 Lenny Cartier <lenny@mandrakesoft.com> 0.3.6-1mdk
245- 0.3.6
246
247* Mon Dec 15 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.5-1mdk
248- 0.3.5
249
250* Sun Oct 19 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.3-2mdk
251- drop the "soname fix" and use the correct way...
252
253* Sat Oct 18 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.3-1mdk
254- 0.3.3
255
256* Mon Oct 13 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.2-1mdk
257- initial cooker contrib
258- used the package from PLD as a start point
Note: See TracBrowser for help on using the repository browser.