source: projects/specs/trunk/lib/libi/libidn/libidn-vl.spec @ 9358

Revision 9358, 6.8 KB checked in by inagaki, 9 years ago (diff)

2015-02-18 Ryoichi INAGAKI <ryo1@…>

  • libidn: updated
  • libsndfile: rebuilt


Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name: libidn
4Summary: Internationalized Domain Name support library
5Summary(ja): 国際化ドメイン名をサポートするためのライブラリ
6Version: 1.29
7Release: 1%{?_dist_release}
8
9Group: System Environment/Libraries
10License: GPLv3+ and LGPLv3+
11URL: http://www.gnu.org/software/libidn/
12
13Source0: http://ftp.gnu.org/gnu/libidn/libidn-%{version}.tar.gz
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: gettext
17BuildRequires: pkgconfig
18Requires(post): /sbin/install-info
19Requires(preun): /sbin/install-info
20
21%description
22GNU Libidn is an implementation of the Stringprep, Punycode and
23IDNA specifications defined by the IETF Internationalized Domain
24Names (IDN) working group, used for internationalized domain
25names.
26
27%package devel
28Summary: Development files for the libidn library
29Summary(ja): libidn ライブラリの開発用ファイル
30Group: Development/Libraries
31License: GPLv3+, LGPLv3+ and GFDLv1.3+
32Requires: %{name} = %{version}-%{release}
33
34%description devel
35This package includes header files and libraries necessary for
36developing programs which use the GNU libidn library.
37
38# compat32
39%package -n compat32-%{name}
40Summary: Internationalized Domain Name support library
41Summary(ja): 国際化ドメイン名をサポートするためのライブラリ
42Group: System Environment/Libraries
43Requires: %{name} = %{version}-%{release}
44
45%description -n compat32-%{name}
46GNU Libidn is an implementation of the Stringprep, Punycode and
47IDNA specifications defined by the IETF Internationalized Domain
48Names (IDN) working group, used for internationalized domain
49names.
50
51%package -n compat32-%{name}-devel
52Summary: Development files for the libidn library
53Summary(ja): libidn ライブラリの開発用ファイル
54Group: Development/Libraries
55License: GPLv3+, LGPLv3+ and GFDLv1.3+
56Requires: compat32-%{name} = %{version}-%{release}
57Requires: %{name}-devel = %{version}-%{release}
58
59%description -n compat32-%{name}-devel
60This package includes header files and libraries necessary for
61developing programs which use the GNU libidn library.
62
63%prep
64%setup -q
65
66# Disable static library creation by default.
67%define with_static 0
68
69%build
70%configure --disable-csharp --disable-java \
71%if ! %{with_static}
72           --disable-static
73%endif
74make %{?_smp_mflags}
75
76make %{?_smp_mflags} -C tests check
77
78%install
79[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
80%makeinstall
81
82rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.la
83
84# provide more examples
85make %{?_smp_mflags} -C examples distclean
86
87# clean up docs
88find doc -name "Makefile*" | xargs rm
89rm -rf $RPM_BUILD_ROOT%{_datadir}/info/dir
90
91%find_lang %{name}
92
93%post
94/sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir
95/sbin/ldconfig
96
97%preun
98if [ $1 = 0 ]; then
99    /sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir
100fi
101
102%postun -p /sbin/ldconfig
103
104%if %{build_compat32}
105%post -n compat32-%{name} -p /sbin/ldconfig
106
107%postun -n compat32-%{name} -p /sbin/ldconfig
108%endif
109
110%clean
111[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
112
113%files -f %{name}.lang
114%defattr(-,root,root)
115%doc ChangeLog NEWS FAQ README THANKS COPYING*
116%{_bindir}/idn
117%{_mandir}/man1/idn.1*
118%{_datadir}/emacs/site-lisp
119%{_libdir}/libidn.so.*
120#{_libdir}/libidn.la
121%{_infodir}/*
122
123%files devel
124%defattr(0644,root,root,755)
125%doc doc/libidn.html doc/libidn-components.png examples contrib
126%{_libdir}/libidn.so
127%if %{with_static}
128%{_libdir}/libidn.a
129%endif
130%{_includedir}/*.h
131%{_libdir}/pkgconfig/*.pc
132%{_mandir}/man3/*
133
134# compat32
135%if %{build_compat32}
136%files -n compat32-%{name}
137%defattr(-,root,root)
138%{_libdir}/libidn.so.*
139#{_libdir}/libidn.la
140
141%files -n compat32-%{name}-devel
142%defattr(0644,root,root,755)
143%{_libdir}/libidn.so
144%if %{with_static}
145%{_libdir}/libidn.a
146%endif
147%{_libdir}/pkgconfig/*.pc
148%endif
149
150%changelog
151* Wed Feb 18 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.29-1
152- new upstream release
153- added Japanese summary
154
155* Sat Oct  1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.22-1
156- new upstream release
157
158* Sat Sep 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.19-1
159- new upstream release
160- built with rpm-4.8.1
161
162* Sun Jun 28 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.11-2
163- added compat32 package for x86_64 arch support.
164- disabled static library creation by default.
165
166* Mon Nov 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.11-1
167- new upstream release
168
169* Thu Jun 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8-1
170- new upstream release
171- applied new versioning policy
172- added --disable-csharp and --disable-java options to %%configure
173
174* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.14-0vl1
175- new upstream release
176
177* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.9-0vl1
178- new upstream release
179
180* Wed Aug 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.18-0vl2
181- rebuild for VineSeed
182
183* Wed Aug 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.18-0vl1
184- new upstream release
185
186* Thu Dec 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.12-0vl2
187- rebuild for VineSeed
188
189* Wed Dec 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.12-0vl1
190- new upstream release
191- build for Vine Linux 3.1
192
193* Thu Oct  7 2004 Joe Orton <jorton@redhat.com> 0.5.6-1
194- update to 0.5.6 (#134343)
195
196* Thu Sep 30 2004 Miloslav Trmac <mitr@redhat.com> - 0.5.4-3
197- Fix Group: (#134068)
198
199* Tue Aug 31 2004 Joe Orton <jorton@redhat.com> 0.5.4-2
200- move ldconfig from preun to postun (#131280)
201
202* Sun Aug  8 2004 Joe Orton <jorton@redhat.com> 0.5.4-1
203- update to 0.5.4 (#129341)
204
205* Thu Jul 15 2004 Robert Scheck <redhat@linuxnetz.de> 0.5.2-1
206- upgrade to 0.5.2, enabled i18n support and info files (#127906)
207
208* Fri Jul  9 2004 Joe Orton <jorton@redhat.com> 0.5.1-1
209- update to 0.5.1 (#127496)
210
211* Mon Jun 28 2004 Joe Orton <jorton@redhat.com> 0.5.0-1
212- update to 0.5.0 (#126836)
213
214* Tue Jun 22 2004 Than Ngo <than@redhat.com> 0.4.9-2
215- add prereq: /sbin/ldconfig
216- move la file in main package
217
218* Tue Jun 15 2004 Robert Scheck <redhat@linuxnetz.de> 0.4.9-1
219- upgrade to 0.4.9 (#126353)
220
221* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
222- rebuilt
223
224* Thu Apr 29 2004 Joe Orton <jorton@redhat.com> 0.4.4-1
225- update to 0.4.4; remove contrib from -devel docs
226
227* Thu Apr 29 2004 Joe Orton <jorton@redhat.com> 0.4.3-1
228- update to 0.4.3, remove -rpath patch
229
230* Tue Jan 27 2004 Joe Orton <jorton@redhat.com> 0.3.7-1
231- update to 0.3.7, simplify
232
233* Wed Jan 07 2004 Lenny Cartier <lenny@mandrakesoft.com> 0.3.6-1mdk
234- 0.3.6
235
236* Mon Dec 15 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.5-1mdk
237- 0.3.5
238
239* Sun Oct 19 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.3-2mdk
240- drop the "soname fix" and use the correct way...
241
242* Sat Oct 18 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.3-1mdk
243- 0.3.3
244
245* Mon Oct 13 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.2-1mdk
246- initial cooker contrib
247- used the package from PLD as a start point
Note: See TracBrowser for help on using the repository browser.