source: projects/specs/trunk/lib/libi/libical/libical-vl.spec @ 521

Revision 521, 5.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           libical
2Version:        0.43
3Release:        2%{?_dist_release}
4Summary:        Reference implementation of the iCalendar data type and serialization format
5Summary(pl):    Implementacja formatu iCalendar
6
7Group:          System Environment/Libraries
8License:        LGPLv2 or MPLv1.1
9URL:            http://freeassociation.sourceforge.net/
10
11Source0:        http://downloads.sourceforge.net/freeassociation/%{name}-%{version}.tar.gz
12Patch0:         %{name}-%{version}-implicit-pointer-conversion.patch
13Patch1:         %{name}-%{version}-makefile.patch
14Patch2:         %{name}-%{version}-pkgconfig.patch
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17BuildRequires:  bison
18BuildRequires:  byacc
19BuildRequires:  flex
20
21Vendor: Project Vine
22Distribution: Vine Linux
23Packager: babasaki, daisuke
24
25
26#----------------------------------------------------------------------------
27%description
28Reference implementation of the iCalendar data type and serialization format
29used in dozens of calendaring and scheduling products.
30
31%description -l pl
32Implementacja formatu iCalendar, używana w wielu kalendarzach i
33planerach/planistach.
34
35#----------------------------------------------------------------------------
36%package devel
37Summary:        Development files for libical
38Summary(pl):    Pliki deweloperskie dla libical
39Group:          Development/Libraries
40Requires:       %{name} = %{version}-%{release}
41
42%description devel
43The libical-devel package contains libraries and header files for developing
44applications that use libical.
45
46%description devel -l pl
47libical-devel zawiera biblioteki i pliki niezbędne do tworzenia aplikacji
48korzystających z libical.
49
50#----------------------------------------------------------------------------
51%prep
52%setup -q
53%patch0 -p1
54
55%build
56%configure --disable-static -enable-cxx --enable-reentrant
57
58# Omit unused direct shared library dependencies.
59sed --in-place --expression 's! -shared ! -Wl,--as-needed\0!g' libtool
60
61make %{?_smp_mflags}
62
63%check
64# make check
65# Fails on x86_64 and ppc64.
66
67#----------------------------------------------------------------------------
68%install
69rm -rf $RPM_BUILD_ROOT
70
71make install INSTALL="%{__install} -p" DESTDIR=$RPM_BUILD_ROOT
72find $RPM_BUILD_ROOT -type f -name "*.la" -delete
73
74%clean
75rm -rf $RPM_BUILD_ROOT
76
77#----------------------------------------------------------------------------
78%post -p /sbin/ldconfig
79
80%postun -p /sbin/ldconfig
81
82
83%files
84%defattr(-,root,root,-)
85%doc AUTHORS
86%doc ChangeLog
87%doc COPYING
88%doc LICENSE
89%doc NEWS
90%doc README
91%doc THANKS
92%doc TODO
93%{_libdir}/%{name}.so.*
94%{_libdir}/%{name}_cxx.so.*
95%{_libdir}/libicalss.so.*
96%{_libdir}/libicalss_cxx.so.*
97%{_libdir}/libicalvcal.so.*
98
99%files devel
100%defattr(-,root,root,-)
101%doc doc/UsingLibical.txt
102%{_includedir}/ical.h
103%{_libdir}/%{name}.so
104%{_libdir}/%{name}_cxx.so
105%{_libdir}/libicalss.so
106%{_libdir}/libicalss_cxx.so
107%{_libdir}/libicalvcal.so
108%{_libdir}/pkgconfig/libical.pc
109
110%dir %{_includedir}/%{name}
111%{_includedir}/%{name}/*.h
112
113%changelog
114* Fri May 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.43-2
115- remove comment line after %%postun
116- add Vendor/Distribution/Packager tags
117
118* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.43-1
119- new upstream release
120- add pkgconfig file to -devel subpackage.
121- move libicalvcal headers to /usr/include/libical (patch1,2)
122- add patch0 to fix implicit pointer conversion from Debian. Fixes Debian BTS
123  bug #511598.
124
125* Mon Oct 27 2008 Seiichirou Babasaki - 0.32-2
126- Import libical - Packager: Babasaki
127- Updated specfile
128
129* Tue Sep 03 2008 Debarshi Ray <rishi@fedoraproject.org> - 0.32-1
130- Version bump to 0.32.
131- Parallel build problems fixed.
132
133* Sun Jul 27 2008 Jeff Perry <jeffperry_fedora@sourcesink.com> - 0.31-3
134- Added 'BuildRequires: bison byacc flex'.
135
136* Sun Jul 27 2008 Debarshi Ray <rishi@fedoraproject.org> - 0.31-2
137- Fixed linkage problems and disabled parallel build till upstream accepts fix.
138
139* Thu Jul 17 2008 Jeff Perry <jeffperry_fedora@sourcesink.com> - 0.31-1
140- Version bump to 0.31.
141
142* Thu Jul 17 2008 Debarshi Ray <rishi@fedoraproject.org> - 0.30-4
143- Changed value of License according to Fedora licensing guidelines.
144- Enabled reentrant system calls and C++ bindings.
145- Omitted unused direct shared library dependencies.
146- Added ChangeLog, COPYING, LICENSE, NEWS and README to doc and dropped
147  examples.
148
149* Wed Apr 02 2008 Jakub 'Livio' Rusinek <jakub.rusinek@gmail.com> - 0.30-3
150- Source URL... Fixed
151
152* Wed Apr 02 2008 Jakub 'Livio' Rusinek <jakub.rusinek@gmail.com> - 0.30-2
153- Removed untrue note about libical's homepage (to get rid of eventuall mess)
154
155* Sat Feb 23 2008 David Nielsen <gnomeuser@gmail.com> - 0.30-1
156- Switch to freeassociation libical
157- bump to 0.30
158
159* Sat Feb 09 2008 Jakub 'Livio' Rusinek <jakub.rusinek@gmail.com> - 0.27-5
160- Mass rebuild for new GCC... Done
161
162* Sat Jan 19 2008 Jakub 'Livio' Rusinek <jakub.rusinek@gmail.com> - 0.27-4
163- Licence... Fixed
164
165* Fri Jan 18 2008 Jakub 'Livio' Rusinek <jakub.rusinek@gmail.com> - 0.27-3
166- Files section... Fixed
167
168* Thu Jan 17 2008 Jakub 'Livio' Rusinek <jakub.rusinek@gmail.com> - 0.27-2
169- Source... Changed
170- Debug information in libical main package... Excluded
171- Non-numbered .so files in libical main package... Moved
172- libical-devel documentation... Added
173
174* Mon Dec 24 2007 Jakub 'Livio' Rusinek <jakub.rusinek@gmail.com> - 0.27-1
175- Initial release
Note: See TracBrowser for help on using the repository browser.