source: projects/specs/trunk/lib/libi/libical/libical-vl.spec @ 12149

Revision 12149, 6.8 KB checked in by tomop, 5 years ago (diff)

libical-3.0.5-1

Line 
1%define _unpackaged_files_terminate_build 1
2
3Name:           libical
4Summary:        An Open Source implementation of the iCalendar protocols and protocol data units
5Version:        3.0.5
6Release:        1%{?_dist_release}
7
8Group:          System Environment/Libraries
9License:        LGPLv2 or MPLv1.1
10URL:            https://libical.github.io/libical/
11
12Source0:        https://github.com/libical/libical/releases/download/v%{version}/%{name}-%{version}.tar.gz
13
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  cmake
17BuildRequires:  libxml2-devel
18BuildRequires:  glib2-devel
19Requires:       tzdata
20
21Vendor:         Project Vine
22Distribution:   Vine Linux
23Packager:       babasaki, daisuke, inagaki
24
25#----------------------------------------------------------------------------
26%description
27Reference implementation of the iCalendar data type and serialization format
28used in dozens of calendaring and scheduling products.
29
30%description -l pl
31Implementacja formatu iCalendar, używana w wielu kalendarzach i
32planerach/planistach.
33
34#----------------------------------------------------------------------------
35%package devel
36Summary:        Development files for libical
37Summary(ja):    libical の開発用ファイル
38Group:          Development/Libraries
39Requires:       %{name} = %{version}-%{release}
40
41%description devel
42The libical-devel package contains libraries and header files for developing
43applications that use libical.
44
45%description devel -l pl
46libical-devel zawiera biblioteki i pliki niezbędne do tworzenia aplikacji
47korzystających z libical.
48
49#----------------------------------------------------------------------------
50%package glib
51Summary:        libical with glib
52Group:          System Environment/Libraries
53
54%description glib
55this package contains a library to use libical with glib.
56
57#----------------------------------------------------------------------------
58%package glib-devel
59Summary:        Development files for libical-glib
60Summary(ja):    libical-glib の開発用ファイル
61Group:          Development/Libraries
62Requires:       %{name} = %{version}-%{release}
63
64%description glib-devel
65The libical-glib-devel package contains libraries and header files for
66developing applications that use libical-glib.
67
68#----------------------------------------------------------------------------
69%prep
70%setup -q
71
72%build
73mkdir -p %{_target_platform}
74pushd %{_target_platform}
75%cmake \
76    -DCMAKE_BUILD_TYPE=release \
77    -DENABLE_GTK_DOC=OFF \
78    ..
79popd
80
81make %{?_smp_mflags} -C %{_target_platform}
82
83%check
84# make check
85# Fails on x86_64 and ppc64.
86
87#----------------------------------------------------------------------------
88%install
89rm -rf $RPM_BUILD_ROOT
90
91make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
92
93#make install INSTALL="%{__install} -p" DESTDIR=$RPM_BUILD_ROOT
94#find $RPM_BUILD_ROOT -type f -name "*.la" -delete
95
96rm -f %{buildroot}%{_libdir}/*.a
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101#----------------------------------------------------------------------------
102%post -p /sbin/ldconfig
103
104%postun -p /sbin/ldconfig
105
106
107%files
108%defattr(-,root,root,-)
109%doc AUTHORS COPYING LICENSE* ReadMe.* ReleaseNotes.txt THANKS TODO
110%{_libdir}/%{name}.so.*
111%{_libdir}/%{name}_cxx.so.*
112%{_libdir}/libicalss.so.*
113%{_libdir}/libicalss_cxx.so.*
114%{_libdir}/libicalvcal.so.*
115
116%files devel
117%defattr(-,root,root,-)
118%doc doc/UsingLibical.txt
119%dir %{_includedir}/%{name}
120%{_includedir}/%{name}/*.h
121%{_libdir}/%{name}.so
122%{_libdir}/libical_cxx.so
123%{_libdir}/libicalss.so
124%{_libdir}/libicalss_cxx.so
125%{_libdir}/libicalvcal.so
126%dir %{_libdir}/cmake/LibIcal
127%{_libdir}/cmake/LibIcal/*.cmake
128%{_libdir}/pkgconfig/libical.pc
129
130%files glib
131%defattr(-,root,root,-)
132%{_libdir}/%{name}-glib.so.*
133
134%files glib-devel
135%defattr(-,root,root,-)
136%doc doc/UsingLibical.txt
137%dir %{_includedir}/%{name}-glib
138%{_includedir}/%{name}-glib/*.h
139%{_libdir}/%{name}-glib.so
140%{_libdir}/pkgconfig/libical-glib.pc
141
142%changelog
143* Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.5-1
144- updated to 3.0.5.
145
146* Fri Jan 26 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.1-1
147- updated to 3.0.1.
148- added subpackages for glib.
149
150* Mon Feb 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.0.1-1
151- updated to 1.0.1
152- updated URL
153- added BR: cmake
154
155* Sun Sep 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48-1
156- update to 0.48
157- remove old patches
158
159* Sat Apr  2 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.46-1
160- new upstream release
161- added Patch0-2 from Fedora
162
163* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.44-2
164- rebuild with rpm-4.8.1 for pkg-config file
165
166* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.44-1
167- new upstream release
168- drop Patch0
169
170* Fri May 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.43-2
171- remove comment line after %%postun
172- add Vendor/Distribution/Packager tags
173
174* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.43-1
175- new upstream release
176- add pkgconfig file to -devel subpackage.
177- move libicalvcal headers to /usr/include/libical (patch1,2)
178- add patch0 to fix implicit pointer conversion from Debian. Fixes Debian BTS
179  bug #511598.
180
181* Mon Oct 27 2008 Seiichirou Babasaki - 0.32-2
182- Import libical - Packager: Babasaki
183- Updated specfile
184
185* Wed Sep 03 2008 Debarshi Ray <rishi@fedoraproject.org> - 0.32-1
186- Version bump to 0.32.
187- Parallel build problems fixed.
188
189* Sun Jul 27 2008 Jeff Perry <jeffperry_fedora@sourcesink.com> - 0.31-3
190- Added 'BuildRequires: bison byacc flex'.
191
192* Sun Jul 27 2008 Debarshi Ray <rishi@fedoraproject.org> - 0.31-2
193- Fixed linkage problems and disabled parallel build till upstream accepts fix.
194
195* Thu Jul 17 2008 Jeff Perry <jeffperry_fedora@sourcesink.com> - 0.31-1
196- Version bump to 0.31.
197
198* Thu Jul 17 2008 Debarshi Ray <rishi@fedoraproject.org> - 0.30-4
199- Changed value of License according to Fedora licensing guidelines.
200- Enabled reentrant system calls and C++ bindings.
201- Omitted unused direct shared library dependencies.
202- Added ChangeLog, COPYING, LICENSE, NEWS and README to doc and dropped
203  examples.
204
205* Wed Apr 02 2008 Jakub 'Livio' Rusinek <jakub.rusinek@gmail.com> - 0.30-3
206- Source URL... Fixed
207
208* Wed Apr 02 2008 Jakub 'Livio' Rusinek <jakub.rusinek@gmail.com> - 0.30-2
209- Removed untrue note about libical's homepage (to get rid of eventuall mess)
210
211* Sat Feb 23 2008 David Nielsen <gnomeuser@gmail.com> - 0.30-1
212- Switch to freeassociation libical
213- bump to 0.30
214
215* Sat Feb 09 2008 Jakub 'Livio' Rusinek <jakub.rusinek@gmail.com> - 0.27-5
216- Mass rebuild for new GCC... Done
217
218* Sat Jan 19 2008 Jakub 'Livio' Rusinek <jakub.rusinek@gmail.com> - 0.27-4
219- Licence... Fixed
220
221* Fri Jan 18 2008 Jakub 'Livio' Rusinek <jakub.rusinek@gmail.com> - 0.27-3
222- Files section... Fixed
223
224* Thu Jan 17 2008 Jakub 'Livio' Rusinek <jakub.rusinek@gmail.com> - 0.27-2
225- Source... Changed
226- Debug information in libical main package... Excluded
227- Non-numbered .so files in libical main package... Moved
228- libical-devel documentation... Added
229
230* Mon Dec 24 2007 Jakub 'Livio' Rusinek <jakub.rusinek@gmail.com> - 0.27-1
231- Initial release
Note: See TracBrowser for help on using the repository browser.