source: projects/specs/trunk/lib/libg/libgweather/libgweather-vl.spec @ 521

Revision 521, 4.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Library for accessing weather information
2Summary(ja): 天気予報情報にアクセスするライブラリ
3Name: libgweather
4Version: 2.28.0
5Release: 1%{?_dist_release}
6URL: http://www.gnome.org/
7License: GPL
8Group: System Environment/Libraries
9Source0: %{name}-%{version}.tar.bz2
10
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: glib2-devel
13BuildRequires: gtk2-devel
14BuildRequires: GConf2-devel
15BuildRequires: libsoup-devel
16Requires(post,pre,preun): GConf2
17
18%description
19
20libgweather is a library to access weather information from online
21services for numerous locations.
22
23%description -l ja
24
25libgweather はオンラインサービス上にある世界中の天気予報情報に
26アクセスするためのライブラリです。
27
28
29%package l10n
30Summary: Localized xml files for %{name}
31Summary(ja): %{name} の多言語データ
32Group: System Environment/Libraries
33Requires: %{name} = %{version}
34
35%description l10n
36This package contains localized xml files for libgweather.
37(except for English and Japanese)
38
39%description -l ja l10n
40このパッケージには libgweather 用の各種言語の xml ファイルが
41含まれています。(英語および日本語以外の言語)
42
43
44%package devel
45Summary: Libraries and headers for libgweather
46Summary(ja): libgweather 用ライブラリとヘッダ
47Group: Development/Libraries
48Requires: %{name} = %{version}
49Requires: gtk2-devel
50Requires: GConf2-devel
51Requires: libsoup-devel
52
53%description devel
54
55Libraries and headers for libgweather.
56
57%description devel -l ja
58
59libgweather 用ライブラリとヘッダ
60
61
62%prep
63%setup -q
64
65
66%build
67%configure --disable-schemas-install
68# do NOT use smp flag
69make
70
71
72%install
73rm -rf $RPM_BUILD_ROOT
74
75export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
76%makeinstall
77unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
78
79rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
80
81%find_lang %{name}
82
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87
88%post
89export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
90gconftool-2 --makefile-install-rule \
91    %{_sysconfdir}/gconf/schemas/gweather.schemas \
92    > /dev/null || :
93/sbin/ldconfig
94
95
96%pre
97if [ "$1" -gt 1 ]; then
98  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
99  gconftool-2 --makefile-uninstall-rule \
100    %{_sysconfdir}/gconf/schemas/gweather.schemas \
101    > /dev/null || :
102fi
103
104
105%preun
106if [ "$1" -eq 0 ]; then
107  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
108  gconftool-2 --makefile-uninstall-rule \
109    %{_sysconfdir}/gconf/schemas/gweather.schemas \
110    > /dev/null || :
111fi
112
113
114%postun -p /sbin/ldconfig
115
116 
117%files -f %{name}.lang
118%defattr(-,root,root)
119%doc AUTHORS COPYING NEWS README
120%{_sysconfdir}/gconf/schemas/*.schemas
121%{_libdir}/lib*.so.*
122%dir %{_datadir}/libgweather
123%{_datadir}/libgweather/Locations.xml
124%{_datadir}/libgweather/Locations.ja.xml
125%{_datadir}/libgweather/locations.dtd
126
127
128%files l10n
129%defattr(-,root,root)
130%{_datadir}/libgweather/*.xml
131%exclude %{_datadir}/libgweather/Locations.xml
132%exclude %{_datadir}/libgweather/Locations.ja.xml
133%exclude %{_datadir}/libgweather/locations.dtd
134
135
136%files devel
137%defattr(-,root,root)
138%{_libdir}/lib*.so
139%{_libdir}/pkgconfig/*
140%{_includedir}/*
141%{_datadir}/gtk-doc/html/libgweather
142
143
144%changelog
145* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
146- new upstream release
147- removed BR: gnome-vfs2-devel
148- added BR: libsoup-devel
149
150* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2.1-1
151- new upstream release
152
153* Wed Apr 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
154- split l10n xml files to -l10n subpackage.
155
156* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
157- new upstream release
158- remove static libs
159
160* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
161- new upstream release
162
163* Sun Oct 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.1-1
164- new upstream release
165
166* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
167- new upstream release
168
169* Wed Jul 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.22.3-1
170- new upstream release
171- added Japanese summary and description, in UTF-8
172
173* Sun Jun  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
174- new upstream release
175
176* Sat Apr 19 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.22.1.2-2
177- dropped %%{_smp_mflags} from make option
178
179* Thu Apr 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.2-1vl5
180- new upstream release
181
182* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
183- new upstream release
184
185* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
186- initial package for Vine Linux
Note: See TracBrowser for help on using the repository browser.