source: projects/specs/trunk/lib/libg/libgpod/libgpod-vl.spec @ 5701

Revision 5701, 4.8 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1Summary: Library to access the iPod
2Summary(ja): iPod にアクセスするためのライブラリ
3Name: libgpod
4Version: 0.8.0
5Release: 3%{?_dist_release}
6Group: System Environment/Libraries
7License: LGPLv2+
8URL: http://www.gtkpod.org/libgpod.html
9
10Source: %{name}-%{version}.tar.gz
11Patch0: libgpod-0.8.0-x86-32.patch
12
13Buildroot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: docbook-style-xsl
15BuildRequires: glib2-devel
16BuildRequires: gtk2-devel
17BuildRequires: gettext
18BuildRequires: intltool
19BuildRequires: libimobiledevice-devel >= 1.0.2
20BuildRequires: libplist-devel >= 1.0
21BuildRequires: libusb1-devel
22BuildRequires: libxml2-devel
23BuildRequires: libxslt
24BuildRequires: libffi-devel
25BuildRequires: perl(XML::Parser)
26BuildRequires: pygobject-devel
27BuildRequires: python-devel
28BuildRequires: python-mutagen
29BuildRequires: sg3_utils-devel
30BuildRequires: sqlite3-devel
31BuildRequires: swig
32Requires: udev
33
34Vendor: Project Vine
35Distribution: Vine Linux
36Packager: daisuke
37
38%description
39libgpod is a library meant to abstract access to an iPod content. It
40provides an easy to use API to retrieve the list of files and playlist
41stored on an iPod, to modify them and to save them back to the iPod.
42
43%description -l ja
44libgpod は iPod のコンテンツにアクセスするためのライブラリです。
45iPod に格納されているファイルリストやプレイリストを取得し、変更し、
46iPod に書き戻すための API が提供されています。
47
48%package devel
49Summary: Support files necessary to compile applications with libgpod.
50Summary(ja): libgpod を使うアプリケーションのコンパイルに必要なファイル.
51Group: Development/Libraries
52Requires: libgpod = %{version}-%{release}
53Requires: glib2-devel
54Requires: gtk2-devel
55
56%description devel
57Libraries, headers, and support files necessary to compile applications
58using libgpod.
59
60%description -l ja devel
61libgpod を使ったアプリケーションのコンパイルに必要なライブラリ,
62ヘッダファイルなどが含まれています.
63
64%package -n python-gpod
65Summary: Python module to access iPod content
66Group: Development/Languages
67Requires: %{name} = %{version}-%{release}
68Requires: python-mutagen
69
70%description -n python-gpod
71A python module to access iPod content.  This module provides bindings
72to the libgpod library.
73
74
75%prep
76%setup -q
77%patch0 -p1 -b .x86-32
78
79chmod -x bindings/python/examples/*.py
80
81%build
82%configure \
83  --without-hal \
84  --enable-udev \
85  --with-temp-mount-dir=%{_localstatedir}/run/%{name}
86make %{?_smp_mflags}
87
88%install
89if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
90
91make DESTDIR=%{buildroot} install
92
93%find_lang %{name}
94
95rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
96rm -f $RPM_BUILD_ROOT%{python_sitearch}/gpod/*.{a,la}
97
98%clean
99if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
100
101%post -p /sbin/ldconfig
102
103%postun -p /sbin/ldconfig
104
105%files -f %{name}.lang
106%defattr(-, root, root, 0755)
107%doc AUTHORS ChangeLog COPYING README
108%{_bindir}/*
109%{_libdir}/lib*.so.*
110%dir %{_localstatedir}/run/%{name}
111/lib/udev/iphone-set-info
112/lib/udev/ipod-set-info
113/lib/udev/rules.d/*.rules
114
115%files devel
116%defattr(-, root, root, 0755)
117%{_libdir}/lib*.so
118%{_libdir}/pkgconfig/*.pc
119%{_includedir}/gpod-1.0/
120%{_datadir}/gtk-doc/html/%{name}
121
122%files -n python-gpod
123%defattr(-, root, root, 0755)
124%doc COPYING bindings/python/README bindings/python/examples
125%{python_sitearch}/gpod
126
127%changelog
128* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-3
129- rebuild with python-2.7.2
130
131* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-2
132- rebuild with libimobiledevice-1.1.1
133
134* Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-1
135- update to 0.8.0
136
137* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 0.7.93-2
138- rebuilt with rpm-4.8.1 for pkg-config
139
140* Sat Jun 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.93-1
141- new upstream release
142- add configure option (disable hal, enable udev, specify temp mount dir)
143- add python subpackage
144- add BR:
145
146* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
147- new upstream release
148- remove static library
149
150* Sat Oct 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.0-3vl5
151- added BuildRequires: libffi-devel
152
153* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.6.0-2vl5
154- spec in utf-8
155
156* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.0-1vl5
157- applied new versioning policy
158
159* Thu Jan 03 2008 Satoshi MACHINO <machino@vinelinux.org> 0.6.0-0vl1
160- new upstream release
161
162* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.4.2-0vl2
163- for VineSeedPlus
164- new upstream release
165- built with new toolchain
166
167* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
168- new upstream release
169- build with dbus-0.62
170
171* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
172- new upstream release
173- build with dbus-0.61
174
175* Wed Dec 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl1
176- initial package
Note: See TracBrowser for help on using the repository browser.