source: projects/specs/trunk/lib/libg/libgpod/libgpod-vl.spec @ 1254

Revision 1254, 4.1 KB checked in by daisuke, 14 years ago (diff)

libgpod: fix permission

Line 
1Summary: Library to access the iPod
2Summary(ja): iPod にアクセスするためのライブラリ
3Name: libgpod
4Version: 0.7.93
5Release: 1%{?_dist_release}
6Group: System Environment/Libraries
7License: LGPL
8Buildroot: %{_tmppath}/%{name}-%{version}-root
9
10Source: %{name}-%{version}.tar.gz
11URL: http://www.gtkpod.org/libgpod.html
12
13BuildRequires: docbook-style-xsl
14BuildRequires: glib2-devel
15BuildRequires: gtk2-devel
16BuildRequires: gettext
17BuildRequires: intltool
18BuildRequires: libimobiledevice-devel >= 1.0.2
19BuildRequires: libplist-devel >= 1.0
20BuildRequires: libusb1-devel
21BuildRequires: libxml2-devel
22BuildRequires: libxslt
23BuildRequires: libffi-devel
24BuildRequires: perl(XML::Parser)
25BuildRequires: pygobject-devel
26BuildRequires: python-devel
27BuildRequires: python-mutagen
28BuildRequires: sg3_utils-devel
29BuildRequires: sqlite3-devel
30BuildRequires: swig
31Requires: udev
32
33Vendor: Project Vine
34Distribution: Vine Linux
35Packager: daisuke
36
37%description
38libgpod is a library meant to abstract access to an iPod content. It
39provides an easy to use API to retrieve the list of files and playlist
40stored on an iPod, to modify them and to save them back to the iPod.
41
42%package devel
43Summary: Support files necessary to compile applications with libgpod.
44Summary(ja): libgpod を使うアプリケーションのコンパイルに必要なファイル.
45Group: Development/Libraries
46Requires: libgpod = %{version}-%{release}
47Requires: glib2-devel
48Requires: gtk2-devel
49
50%description devel
51Libraries, headers, and support files necessary to compile applications
52using libgpod.
53
54%description -l ja devel
55libgpod を使ったアプリケーションのコンパイルに必要なライブラリ,
56ヘッダファイルなどが含まれています.
57
58%package -n python-gpod
59Summary: Python module to access iPod content
60Group: Development/Languages
61Requires: %{name} = %{version}-%{release}
62Requires: python-mutagen
63
64%description -n python-gpod
65A python module to access iPod content.  This module provides bindings
66to the libgpod library.
67
68
69%prep
70%setup -q
71
72%build
73%configure \
74  --without-hal \
75  --enable-udev \
76  --with-temp-mount-dir=%{_localstatedir}/run/%{name}
77make %{?_smp_mflags}
78
79%install
80if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
81
82make DESTDIR=%{buildroot} install
83
84%find_lang %{name}
85
86rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
87rm -f $RPM_BUILD_ROOT%{python_sitearch}/gpod/*.{a,la}
88
89%clean
90if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
91
92%post -p /sbin/ldconfig
93
94%postun -p /sbin/ldconfig
95
96%files -f %{name}.lang
97%defattr(-, root, root, 0755)
98%doc AUTHORS ChangeLog COPYING README
99%{_bindir}/*
100%{_libdir}/lib*.so.*
101%dir %{_localstatedir}/run/%{name}
102/lib/udev/iphone-set-info
103/lib/udev/ipod-set-info
104/lib/udev/rules.d/*.rules
105
106%files devel
107%defattr(-, root, root, 0755)
108%{_libdir}/lib*.so
109%{_libdir}/pkgconfig/*.pc
110%{_includedir}/gpod-1.0/
111%{_datadir}/gtk-doc/html/%{name}
112
113%files -n python-gpod
114%defattr(-, root, root, 0755)
115%doc COPYING bindings/python/README bindings/python/examples
116%{python_sitearch}/gpod
117
118%changelog
119* Sat Jun 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.93-1
120- new upstream release
121- add configure option (disable hal, enable udev, specify temp mount dir)
122- add python subpackage
123- add BR:
124
125* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
126- new upstream release
127- remove static library
128
129* Sat Oct 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.0-3vl5
130- added BuildRequires: libffi-devel
131
132* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.6.0-2vl5
133- spec in utf-8
134
135* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.0-1vl5
136- applied new versioning policy
137
138* Thu Jan 03 2008 Satoshi MACHINO <machino@vinelinux.org> 0.6.0-0vl1
139- new upstream release
140
141* Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.4.2-0vl2
142- for VineSeedPlus
143- new upstream release
144- built with new toolchain
145
146* Sun Oct  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
147- new upstream release
148- build with dbus-0.62
149
150* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
151- new upstream release
152- build with dbus-0.61
153
154* Wed Dec 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl1
155- initial package
Note: See TracBrowser for help on using the repository browser.