source: projects/specs/trunk/lib/libg/libgphoto2/libgphoto2-vl.spec @ 7856

Revision 7856, 7.3 KB checked in by tomop, 11 years ago (diff)

gd-2.1.0-1 and dependencies.

Line 
1Summary: Library for accessing digital cameras
2Summary(ja): デジタルカメラにアクセスするためのライブラリ
3Name: libgphoto2
4Version: 2.5.0
5Release: 2%{?_dist_release}
6
7# GPLV2+ for the main lib (due to exif.c) and most plugins, some plugins GPLv2
8License: GPLv2+ and GPLv2
9Group: System Environment/Libraries
10URL: http://www.gphoto.org/
11
12Source0: http://downloads.sourceforge.net/gphoto/libgphoto2-%{version}.tar.bz2
13Patch1: gphoto2-pkgcfg.patch
14Patch2: gphoto2-storage.patch
15Patch3: gphoto2-ixany.patch
16Patch5: gphoto2-device-return.patch
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires: libusb-devel >= 0.1.6a
20BuildRequires: libusb1-devel
21BuildRequires: libexif-devel
22BuildRequires: libjpeg-devel
23BuildRequires: pkgconfig, sharutils
24BuildRequires: libtool-ltdl-devel >= 2.2.6a
25BuildRequires: popt-devel
26BuildRequires: dbus-devel
27BuildRequires: gd-devel
28# we run autoreconf:
29BuildRequires: autoconf, automake, libtool, gettext, cvs
30Obsoletes: gphoto2 < 2.4.0
31Obsoletes: gphoto2-devel < 2.4.0
32
33Vendor: Project Vine
34Distribution: Vine Linux
35
36%description
37libgphoto2 is a library that can be used by applications to access
38various digital cameras. libgphoto2 itself is not a GUI application,
39opposed to gphoto. There are GUI frontends for the gphoto2 library,
40however, such as gtkam for example.
41
42%package devel
43Summary: Headers and links to compile against the libgphoto2 library
44Group: Development/Libraries
45Requires: %{name} = %{version}-%{release}
46Requires: pkgconfig
47Requires: libusb-devel >= 0.1.6a
48Requires: libusb1
49Requires: libexif-devel
50Obsoletes: gphoto2 < 2.4.0-11
51Obsoletes: gphoto2-devel < 2.4.0-11
52Provides: gphoto2-devel = %{version}-%{release}
53
54%description devel
55libgphoto2 is a library that can be used by applications to access
56various digital cameras. libgphoto2 itself is not a GUI application,
57opposed to gphoto. There are GUI frontends for the gphoto2 library,
58however, such as gtkam for example.
59
60This package contains files needed to compile applications that
61use libgphoto2.
62
63%prep
64%setup -q
65%patch1 -p1 -b .pkgcfg
66%patch2 -p1 -b .storage
67%patch3 -p1 -b .ixany
68%patch5 -p1 -b .device-return
69
70for i in AUTHORS COPYING libgphoto2_port/AUTHORS libgphoto2_port/COPYING.LIB $(find -name 'README.*'); do
71        mv ${i} ${i}.old
72        iconv -f ISO-8859-1 -t UTF-8 < ${i}.old > ${i}
73        touch -r ${i}.old ${i} || :
74        rm -f ${i}.old
75done
76                               
77# FIXME: These .pc.in files aren't actually being installed?
78cat > gphoto2.pc.in << \EOF
79prefix=@prefix@
80exec_prefix=@exec_prefix@
81libdir=@libdir@
82includedir=@includedir@
83VERSION=@VERSION@
84
85Name: gphoto2
86Description: Library for easy access to digital cameras
87Requires:
88Version: @VERSION@
89Libs: -L${libdir} -lgphoto2 -lgphoto2_port -lm
90Cflags: -I${includedir} -I${includedir}/gphoto2
91EOF
92sed 's/Name: gphoto2/Name: gphoto2-port/' < gphoto2.pc.in > gphoto2-port.pc.in
93
94%build
95export CFLAGS=$RPM_OPT_FLAGS
96%configure \
97        udevscriptdir='/lib/udev' \
98        --with-drivers=all \
99        --with-doc-dir=%{_docdir}/%{name} \
100        --disable-static \
101        --disable-rpath \
102        --without-aalib \
103        --without-hal
104make %{?_smp_mflags}
105
106%install
107rm -rf "${RPM_BUILD_ROOT}"
108
109make mandir=%{_mandir} DESTDIR=$RPM_BUILD_ROOT install
110
111pushd packaging/linux-hotplug/
112install -d -m755 %{buildroot}/usr/share/hal/fdi/information/20thirdparty/
113export LIBDIR=$RPM_BUILD_ROOT%{_libdir}
114export CAMLIBS=$RPM_BUILD_ROOT%{_libdir}/%{name}/%{version}
115export LD_LIBRARY_PATH=$RPM_BUILD_ROOT%{_libdir}
116$RPM_BUILD_ROOT%{_libdir}/%{name}/print-camera-list hal-fdi | \
117grep -v "<!-- This file was generated" > $RPM_BUILD_ROOT/%{_datadir}/hal/fdi/information/20thirdparty/10-camera-libgphoto2.fdi
118
119# Output udev rules for device identification; this is used by GVfs gphoto2
120# backend and others.
121#
122# Btw, since it's /lib/udev, never e.g. /lib64/udev, we hardcode the path
123#
124mkdir -p $RPM_BUILD_ROOT/lib/udev/rules.d
125$RPM_BUILD_ROOT%{_libdir}/%{name}/print-camera-list udev-rules version 136 > $RPM_BUILD_ROOT/lib/udev/rules.d/40-libgphoto2.rules
126popd
127
128rm -rf %{buildroot}%{_libdir}/libgphoto2/*/*a
129rm -rf %{buildroot}%{_libdir}/libgphoto2_port/*/*a
130rm -rf %{buildroot}%{_libdir}/*.a
131rm -rf %{buildroot}%{_libdir}/*.la
132
133%find_lang %{name}-6
134%find_lang %{name}_port-10
135cat libgphoto2*.lang >> %{name}.lang
136
137%clean
138rm -rf "${RPM_BUILD_ROOT}"
139
140%files -f %{name}.lang
141%defattr(-,root,root)
142%doc AUTHORS COPYING README NEWS
143%dir %{_libdir}/libgphoto2_port
144%dir %{_libdir}/libgphoto2_port/*
145%dir %{_libdir}/libgphoto2
146%dir %{_libdir}/libgphoto2/*
147%{_libdir}/libgphoto2_port/*/*.so
148%{_libdir}/libgphoto2/*/*.so
149%{_libdir}/*.so.*
150%{_datadir}/hal/fdi/information/20thirdparty/10-camera-libgphoto2.fdi
151/lib/udev/rules.d/40-libgphoto2.rules
152/lib/udev/check-ptp-camera
153
154%post -p /sbin/ldconfig
155
156%postun -p /sbin/ldconfig
157
158%files devel
159%defattr(-,root,root)
160%doc %{_docdir}/%{name}
161%{_datadir}/libgphoto2
162%{_bindir}/gphoto2-config*
163%{_bindir}/gphoto2-port-config
164%{_includedir}/gphoto2
165%{_libdir}/*.so
166%{_libdir}/pkgconfig/*
167%{_mandir}/man3/*
168
169
170%changelog
171* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.5.0-2
172- rebuilt with gd-2.1.0.
173
174* Fri Jan 11 2013 IWAI, Masaharu <iwai@alib.jp> 2.5.0-1
175- update to 2.5.0
176- drop MAX_ENTRIES patch (Patch4): obsolete
177- update libusb version: 0.1.5 -> 0.1.6a
178- add BuildRequires: libusb1-devel
179- add Requires: libusb1
180- add Vendor and Distribution tags
181
182* Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.11-2
183- add BR: dbus-devel, gd-devel
184- add --without-hal
185
186* Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.11-1
187- update to 2.4.11
188- install udev script to /lib/udev
189- add udev rules
190
191* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.5-2
192- rebuild with rpm-4.8.1 for pkg-config file
193
194* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-1
195- new upstream release
196- build with libtool-2.2.6a
197
198* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-1
199- new upstream release
200- dropped Patch6
201- changed Group to System Environment/Libraries
202- added BuildRequires: popt-devel instead of popt
203- added BuildRequires: cvs
204
205* Thu Jul 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
206- initial build for Vine Linux
207
208* Fri Jun 20 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 2.4.1-5
209- fix pkgcfg patch to match actual .pc file names (fixes kdegraphics build)
210
211* Thu Jun 12 2008 Jindrich Novy <jnovy@redhat.com> 2.4.1-3
212- libgphoto2-devel requires libusb-devel and libexif-devel for
213  pkgconfig
214
215* Wed Jun 04 2008 Jindrich Novy <jnovy@redhat.com> 2.4.1-2
216- fix obsoletes
217- workaround problem with coreutils-6.12 and RHEL5-xen kernels
218  what prevents libgphoto2 koji build
219
220* Mon Jun 02 2008 Jindrich Novy <jnovy@redhat.com> 2.4.1-1
221- update to 2.4.1 (#443515, #436138)
222
223* Thu May 29 2008 Stepan Kasal <skasal@redhat.com> 2.4.0-3
224- drop gphoto2-norpath.patch
225- use quoted here-document in %%prep
226- fix some typos in m4 sources
227- run autoreconf to get autotools right
228
229* Mon Apr 21 2008 Jindrich Novy <jnovy@redhat.com> 2.4.0-2
230- apply patch to fix build with libusb
231
232* Fri Apr 18 2008 Jindrich Novy <jnovy@redhat.com> 2.4.0-1
233- backport patch from upstream to avoid segfault when
234  data phase is skipped for certain devices (#435413)
235- initial build
236
237* Mon Apr 14 2008 Jindrich Novy <jnovy@redhat.com> 2.4.0-0.2
238- review fixes, thanks to Hans de Goede: (#437285)
239  - remove unused macro
240  - don't exclude s390/s390x
241  - preserve timestamps
242  - fix license
243
244* Thu Mar 13 2008 Jindrich Novy <jnovy@redhat.com> 2.4.0-0.1
245- initial libgphoto2 packaging
Note: See TracBrowser for help on using the repository browser.