source: projects/specs/trunk/lib/libg/libgphoto2/libgphoto2-vl.spec @ 9343

Revision 9343, 7.7 KB checked in by inagaki, 9 years ago (diff)

2015-02-08 Ryoichi INAGAKI <ryo1@…>

  • automoc4, cagibi, gtkglext: rebuilt
  • libgphoto2, perl-{Clagg-Gomor, Data-Phrasebook-Loader-YAML, Net-MAC-Vendor}: updated


RevLine 
[521]1Summary: Library for accessing digital cameras
2Summary(ja): デジタルカメラにアクセスするためのライブラリ
3Name: libgphoto2
[9343]4Version: 2.5.7
5Release: 1%{?_dist_release}
[4100]6
[521]7# GPLV2+ for the main lib (due to exif.c) and most plugins, some plugins GPLv2
8License: GPLv2+ and GPLv2
9Group: System Environment/Libraries
[4100]10URL: http://www.gphoto.org/
11
[521]12Source0: http://downloads.sourceforge.net/gphoto/libgphoto2-%{version}.tar.bz2
13Patch1: gphoto2-pkgcfg.patch
14Patch2: gphoto2-storage.patch
15Patch3: gphoto2-ixany.patch
[4100]16Patch5: gphoto2-device-return.patch
[521]17
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
[9343]19#BuildRequires: libusb-devel >= 0.1.6a
[7334]20BuildRequires: libusb1-devel
[521]21BuildRequires: libexif-devel
22BuildRequires: libjpeg-devel
23BuildRequires: pkgconfig, sharutils
24BuildRequires: libtool-ltdl-devel >= 2.2.6a
25BuildRequires: popt-devel
[4101]26BuildRequires: dbus-devel
27BuildRequires: gd-devel
[521]28# we run autoreconf:
[9343]29#BuildRequires: autoconf, automake, libtool, gettext, cvs
[521]30Obsoletes: gphoto2 < 2.4.0
31Obsoletes: gphoto2-devel < 2.4.0
32
[7334]33Vendor: Project Vine
34Distribution: Vine Linux
35
[521]36%description
37libgphoto2 is a library that can be used by applications to access
38various digital cameras. libgphoto2 itself is not a GUI application,
39opposed to gphoto. There are GUI frontends for the gphoto2 library,
40however, such as gtkam for example.
41
42%package devel
43Summary: Headers and links to compile against the libgphoto2 library
44Group: Development/Libraries
45Requires: %{name} = %{version}-%{release}
[7334]46Requires: pkgconfig
[9343]47#Requires: libusb-devel >= 0.1.6a
48#Requires: libusb1-devel
[7334]49Requires: libexif-devel
[521]50Obsoletes: gphoto2 < 2.4.0-11
51Obsoletes: gphoto2-devel < 2.4.0-11
52Provides: gphoto2-devel = %{version}-%{release}
53
54%description devel
55libgphoto2 is a library that can be used by applications to access
56various digital cameras. libgphoto2 itself is not a GUI application,
57opposed to gphoto. There are GUI frontends for the gphoto2 library,
58however, such as gtkam for example.
59
60This package contains files needed to compile applications that
61use libgphoto2.
62
63%prep
64%setup -q
65%patch1 -p1 -b .pkgcfg
66%patch2 -p1 -b .storage
67%patch3 -p1 -b .ixany
[4100]68%patch5 -p1 -b .device-return
[521]69
[9343]70for i in AUTHORS ChangeLog COPYING libgphoto2_port/AUTHORS libgphoto2_port/COPYING.LIB `find -name 'README.*'`; do
71    mv ${i} ${i}.old
72    iconv -f ISO-8859-1 -t UTF-8 < ${i}.old > ${i}
73    touch -r ${i}.old ${i} || :
74    rm -f ${i}.old
[4100]75done
[521]76
77%build
[9343]78export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
[521]79%configure \
[4100]80        udevscriptdir='/lib/udev' \
[521]81        --with-drivers=all \
82        --with-doc-dir=%{_docdir}/%{name} \
83        --disable-static \
84        --disable-rpath \
[4101]85        --without-aalib \
86        --without-hal
[9343]87
88# Don't use rpath!
89sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
90sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
91sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libgphoto2_port/libtool
92sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libgphoto2_port/libtool
93
[521]94make %{?_smp_mflags}
95
96%install
97rm -rf "${RPM_BUILD_ROOT}"
98
99make mandir=%{_mandir} DESTDIR=$RPM_BUILD_ROOT install
100
101pushd packaging/linux-hotplug/
102install -d -m755 %{buildroot}/usr/share/hal/fdi/information/20thirdparty/
103export LIBDIR=$RPM_BUILD_ROOT%{_libdir}
104export CAMLIBS=$RPM_BUILD_ROOT%{_libdir}/%{name}/%{version}
105export LD_LIBRARY_PATH=$RPM_BUILD_ROOT%{_libdir}
[4100]106
[9343]107#$RPM_BUILD_ROOT%{_libdir}/%{name}/print-camera-list hal-fdi | \
108#grep -v "<!-- This file was generated" > $RPM_BUILD_ROOT/%{_datadir}/hal/fdi/information/20thirdparty/10-camera-libgphoto2.fdi
109
[4100]110# Output udev rules for device identification; this is used by GVfs gphoto2
111# backend and others.
112#
113# Btw, since it's /lib/udev, never e.g. /lib64/udev, we hardcode the path
114#
115mkdir -p $RPM_BUILD_ROOT/lib/udev/rules.d
116$RPM_BUILD_ROOT%{_libdir}/%{name}/print-camera-list udev-rules version 136 > $RPM_BUILD_ROOT/lib/udev/rules.d/40-libgphoto2.rules
[521]117popd
118
[9343]119# remove circular symlink in /usr/include/gphoto2 (#460807)
120rm -f $RPM_BUILD_ROOT%{_includedir}/gphoto2/gphoto2
[521]121
[9343]122# remove unneeded print-camera-list from libdir (#745081)
123rm -f $RPM_BUILD_ROOT%{_libdir}/libgphoto2/print-camera-list
124
125rm -rf $RPM_BUILD_ROOT%{_libdir}/libgphoto2/*/*a
126rm -rf $RPM_BUILD_ROOT%{_libdir}/libgphoto2_port/*/*a
127rm -rf $RPM_BUILD_ROOT%{_libdir}/*.a
128rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
129
130rm -f libgphoto.lang
[7334]131%find_lang %{name}-6
[9343]132%find_lang %{name}_port-12
133cat %{name}*.lang >> libgphoto.lang
[521]134
[9343]135# https://fedoraproject.org/wiki/Packaging_tricks#With_.25doc
136rm -rf __doc
137mkdir -p __doc
138mv $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/* __doc
139rm -rf $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}
140
[521]141%clean
142rm -rf "${RPM_BUILD_ROOT}"
143
[9343]144%post -p /sbin/ldconfig
145
146%postun -p /sbin/ldconfig
147
148%files -f libgphoto.lang
[521]149%defattr(-,root,root)
150%doc AUTHORS COPYING README NEWS
151%dir %{_libdir}/libgphoto2_port
152%dir %{_libdir}/libgphoto2_port/*
153%dir %{_libdir}/libgphoto2
154%dir %{_libdir}/libgphoto2/*
155%{_libdir}/libgphoto2_port/*/*.so
156%{_libdir}/libgphoto2/*/*.so
157%{_libdir}/*.so.*
[9343]158#{_datadir}/hal/fdi/information/20thirdparty/10-camera-libgphoto2.fdi
[4100]159/lib/udev/rules.d/40-libgphoto2.rules
160/lib/udev/check-ptp-camera
[521]161
162%files devel
163%defattr(-,root,root)
[9343]164%doc __doc/*
[521]165%{_datadir}/libgphoto2
166%{_bindir}/gphoto2-config*
167%{_bindir}/gphoto2-port-config
168%{_includedir}/gphoto2
169%{_libdir}/*.so
170%{_libdir}/pkgconfig/*
171%{_mandir}/man3/*
172
[3735]173
[521]174%changelog
[9343]175* Sun Feb  8 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.5.7-1
176- updated to 2.5.7
177
[7856]178* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.5.0-2
179- rebuilt with gd-2.1.0.
180
[7334]181* Fri Jan 11 2013 IWAI, Masaharu <iwai@alib.jp> 2.5.0-1
182- update to 2.5.0
183- drop MAX_ENTRIES patch (Patch4): obsolete
184- update libusb version: 0.1.5 -> 0.1.6a
185- add BuildRequires: libusb1-devel
186- add Requires: libusb1
187- add Vendor and Distribution tags
188
[4101]189* Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.11-2
190- add BR: dbus-devel, gd-devel
191- add --without-hal
192
[4100]193* Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.11-1
194- update to 2.4.11
195- install udev script to /lib/udev
196- add udev rules
197
[3735]198* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.5-2
199- rebuild with rpm-4.8.1 for pkg-config file
200
[521]201* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-1
202- new upstream release
203- build with libtool-2.2.6a
204
205* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-1
206- new upstream release
207- dropped Patch6
208- changed Group to System Environment/Libraries
209- added BuildRequires: popt-devel instead of popt
210- added BuildRequires: cvs
211
212* Thu Jul 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
213- initial build for Vine Linux
214
215* Fri Jun 20 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 2.4.1-5
216- fix pkgcfg patch to match actual .pc file names (fixes kdegraphics build)
217
218* Thu Jun 12 2008 Jindrich Novy <jnovy@redhat.com> 2.4.1-3
219- libgphoto2-devel requires libusb-devel and libexif-devel for
220  pkgconfig
221
222* Wed Jun 04 2008 Jindrich Novy <jnovy@redhat.com> 2.4.1-2
223- fix obsoletes
224- workaround problem with coreutils-6.12 and RHEL5-xen kernels
225  what prevents libgphoto2 koji build
226
227* Mon Jun 02 2008 Jindrich Novy <jnovy@redhat.com> 2.4.1-1
228- update to 2.4.1 (#443515, #436138)
229
230* Thu May 29 2008 Stepan Kasal <skasal@redhat.com> 2.4.0-3
231- drop gphoto2-norpath.patch
232- use quoted here-document in %%prep
233- fix some typos in m4 sources
234- run autoreconf to get autotools right
235
236* Mon Apr 21 2008 Jindrich Novy <jnovy@redhat.com> 2.4.0-2
237- apply patch to fix build with libusb
238
239* Fri Apr 18 2008 Jindrich Novy <jnovy@redhat.com> 2.4.0-1
240- backport patch from upstream to avoid segfault when
241  data phase is skipped for certain devices (#435413)
242- initial build
243
244* Mon Apr 14 2008 Jindrich Novy <jnovy@redhat.com> 2.4.0-0.2
245- review fixes, thanks to Hans de Goede: (#437285)
246  - remove unused macro
247  - don't exclude s390/s390x
248  - preserve timestamps
249  - fix license
250
251* Thu Mar 13 2008 Jindrich Novy <jnovy@redhat.com> 2.4.0-0.1
252- initial libgphoto2 packaging
Note: See TracBrowser for help on using the repository browser.