source: projects/specs/trunk/lib/libg/libgnomeuimm/libgnomeuimm-vl.spec @ 521

Revision 521, 3.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        A C++ interface for libgnomeui
2Name:           libgnomeuimm
3Version:        2.24.0
4Release:        1%{?_dist_release}
5License:        LGPL
6Group:          System Environment/Libraries
7Source:         ftp://download.sourceforge.net/gtkmm/%{name}-%{version}.tar.bz2
8URL:            http://gtkmm.sourceforge.net/
9BuildRoot:      %{_tmppath}/%{name}-%{version}-root
10BuildRequires:  libgnomeui-devel >= 2.7.1
11BuildRequires:  libgnomemm-devel >= 2.16.0
12BuildRequires:  libgnomecanvasmm-devel >= 2.6.0
13BuildRequires:  gconfmm-devel >= 2.6.0
14BuildRequires:  libglademm2-devel >= 2.4.0
15BuildRequires:  gnome-vfsmm-devel >= 2.16.0
16
17%description
18This package provides a C++ interface for GnomeUI.  It is a subpackage
19of the Gtk-- project.  The interface provides a convenient interface for C++
20programmers to create Gnome GUIs with GTK+'s flexible object-oriented
21framework.
22
23%package        devel
24Summary:        Headers for developing programs that will use libgnomeuimm.
25Group:          Development/Libraries
26Requires:       %{name} = %{version}
27Requires:       libgnomeui-devel >= 2.7.1
28Requires:       libgnomemm-devel >= 2.16.0
29Requires:       libgnomecanvasmm-devel >= 2.6.0
30Requires:       gconfmm-devel >= 2.6.0
31Requires:       libglademm2-devel >= 2.4.0
32Requires:       gnome-vfsmm-devel >= 2.16.0
33
34%description    devel
35This package contains the headers that programmers will need to develop
36applications which will use Gnome--, part of Gtk-- the C++ interface to
37the GTK+ (the Gimp ToolKit) GUI library.
38
39%prep
40%setup -q
41
42%build
43# ...hope this can be removed soon
44%ifarch alpha
45        ARCH_FLAGS="--host=alpha-linux-gnu"
46%endif
47
48export CXXFLAGS="$RPM_OPT_FLAGS -shared -fPIC"
49%configure --enable-shared --disable-static --enable-docs
50make %{?_smp_mflags}
51
52if [ "$SMP" != "" ]; then
53  make -j$SMP "MAKE=make -j$SMP"
54  make
55else
56  make
57fi
58
59%install
60if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
61%makeinstall
62find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
63
64
65%post -p /sbin/ldconfig
66
67%postun -p /sbin/ldconfig
68
69%clean
70if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
71
72%files
73%defattr(-, root, root)
74%doc AUTHORS COPYING ChangeLog INSTALL NEWS README
75%{_libdir}/*.so.*
76
77%files  devel
78%defattr(-, root, root)
79%{_includedir}/libgnomeuimm-2.6
80#{_libdir}/*.la
81#{prefix}/lib/*.a # uncomment this one for static libs
82%{_libdir}/*.so
83%{_libdir}/libgnomeuimm-2.6
84%{_libdir}/pkgconfig/*.pc
85
86%changelog
87* Sat Oct  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.0-1vl5
88- new upstream release
89
90* Fri Sep 19 2008 Shu KONNO <owa@bg.wakwak.com> 2.18.0-1vl5
91- applied new versioning policy
92
93* Sat Jun  2 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.18.0-0vl4
94- build all object files with -fPIC so that sharlib is PIC
95
96* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl3
97- rebuilt without libstdc++2_10
98
99* Sun May 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl2
100- rebuilt with new toolchain
101- added -shared option to CXXFLAGS
102
103* Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl1
104- new upstream release
105
106* Sat Nov  4 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.0-1vl1
107- initial build for Vine Linux
108
109* Sun Dec 21 2003 Eric Bourque <ericb@computer.org>
110- fixed dependency to gtkmm2 instead of gtkmm
111
112* Thu Sep 25 2003 Eric Bourque <ericb@computer.org>
113- updated for libgnomeuimm-2.0
114
115* Tue Mar 20 2001 Eric Bourque <ericb@computer.org>
116- added gnome--.m4 to files devel section
117
118* Sat Mar 10 2001 Herbert Valerio Riedel <hvr@gnu.org>
119- improved examples.conf
120- fixed example build problems
121
122* Thu May 11 2000 Herbert Valerio Riedel <hvr@gnu.org>
123- removed lib/gtkmm from files section
124- removed empty obsolete tags
125
126* Sun Jan 30 2000 Karl Einar Nelson <kenelson@sourceforge.net>
127- adapted from gtk--.spec
Note: See TracBrowser for help on using the repository browser.