source: projects/specs/trunk/lib/libg/libgnomeprint/libgnomeprint-vl.spec @ 521

Revision 521, 12.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1## this could go, it's really just so we notice if the soname changes
2%define sover 0
3
4%define gettext_package libgnomeprint-2.2
5
6%define glib2_base_version 2.18.0
7%define glib2_version %{glib2_base_version}
8%define pango_version 1.22.0
9%define libxml2_version 2.5.8
10%define libart_lgpl_version 2.3.16
11%define libbonobo_version 2.24.0
12%define freetype_version 2.3.7
13%define gtk_doc_version 1.1
14
15Summary: Printing library for GNOME.
16Summary(ja): GNOME プリントライブラリ
17Name:           libgnomeprint
18Version:        2.18.6
19Release:        1%{?_dist_release}
20License:        LGPL
21Group:          System Environment/Libraries
22Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/2.18/%{name}-%{version}.tar.bz2
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-root
25BuildRequires: glib2-devel >= %{glib2_version}
26BuildRequires: pango-devel >= %{pango_version}
27BuildRequires: libxml2-devel >= %{libxml2_version}
28BuildRequires: libart_lgpl-devel >= %{libart_lgpl_version}
29BuildRequires: libbonobo-devel >= %{libbonobo_version}
30BuildRequires: freetype2 >= %{freetype_version}
31BuildRequires: gtk-doc >= %{gtk_doc_version}
32BuildRequires: libgnomecups-devel >= 0.2.0
33
34Requires: libgnomecups >= 0.1.13-0vl2
35PreReq: urw-fonts
36PreReq: ghostscript
37PreReq: ghostscript-fonts
38PreReq: libxml
39PreReq: perl
40
41
42%description
43GNOME (GNU Network Object Model Environment) is a user-friendly set of
44applications and desktop tools to be used in conjunction with a window
45manager for the X Window System. The gnome-print package contains
46libraries and fonts needed by GNOME applications for printing.
47
48You should install the gnome-print package if you intend to use any of
49the GNOME applications that can print. If you would like to develop
50GNOME applications that can print you will also need to install the
51gnome-print devel package.
52
53%package devel
54Summary: Libraries and include files for developing GNOME applications.
55Summary(ja): libgnomeprint のライブラリとヘッダファイル
56Group: Development/Libraries
57
58Requires: %{name} = %{PACKAGE_VERSION}
59Requires: glib2-devel >= %{glib2_version}
60Requires: pango-devel >= %{pango_version}
61Requires: libxml2-devel >= %{libxml2_version}
62Requires: libart_lgpl-devel >= %{libart_lgpl_version}
63Requires: libbonobo-devel >= %{libbonobo_version}
64Requires: freetype2 >= %{freetype_version}
65
66%description devel
67GNOME (GNU Network Object Model Environment) is a user-friendly set of
68applications and desktop tools to be used in conjunction with a window
69manager for the X Window System. The gnome-print-devel package
70includes the libraries and include files needed for developing
71applications that use the GNOME printing capabilities.
72
73You should install the gnome-print-devel package if you would like to
74develop GNOME applications that will use the GNOME print capabilities.
75You do not need to install the gnome-print-devel package if you just
76want to use the GNOME desktop environment.
77
78%prep
79%setup -q -n %{name}-%{version}
80
81%build
82%configure --disable-font-install --disable-gtk-doc
83make
84
85%install
86rm -rf $RPM_BUILD_ROOT
87
88# It would probably be cleaner to use install DESTDIR=$RPM_BUILD_ROOT
89# instead of %%makeinstall with this hack.
90%makeinstall
91
92# remove unpackaged files
93rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
94rm -f $RPM_BUILD_ROOT%{_libdir}/libgnomeprint/%{version}/modules/*.{a,la}
95rm -f $RPM_BUILD_ROOT%{_libdir}/libgnomeprint/%{version}/modules/*/*.{a,la}
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%post -p /sbin/ldconfig
101
102%postun -p /sbin/ldconfig
103
104%files
105%defattr(-, root, root)
106%doc AUTHORS COPYING ChangeLog NEWS README
107%dir %{_libdir}/libgnomeprint/%{version}
108%{_libdir}/libgnomeprint/%{version}/modules/*.so
109%{_libdir}/libgnomeprint/%{version}/modules/transports/*.so
110%{_libdir}/libgnomeprint/%{version}/modules/filters/*.so
111%{_libdir}/libgnomeprint*.so.*
112%{_datadir}/libgnomeprint
113%{_datadir}/locale/*/LC_MESSAGES/*.mo
114
115%files devel
116%defattr(-, root, root)
117%{_libdir}/libgnomeprint*.so
118%{_libdir}/*.a
119%{_includedir}/*
120%{_libdir}/pkgconfig/*.pc
121%{_datadir}/gtk-doc
122
123%changelog
124* Wed Mar 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.6-1
125- new upstream release
126
127* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.5-1
128- new upstream release
129- build with gtk+2.14
130
131* Tue Mar 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1vl5
132- new upstream release
133- removed BuildRequires: automake17
134
135* Wed Dec 12 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
136- new upstream release
137
138* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl2
139- rebuilt with new toolchain/environment
140
141* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
142- new upstream release
143
144* Fri May 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl3
145- changed Group to System Environment/Libraries
146
147* Sat Apr 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
148- add missing filter modules to %%files
149- remove unneeded static modules
150
151* Wed Sep 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
152- new upstream release
153
154* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
155- new upstream release
156
157* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.0-0vl1
158- new upstream release
159
160* Sun Jul  3 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.3-0vl1
161- new upstream version
162- drop all patches that are now upstream.
163
164* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
165- new upstream version
166- drop all patches that are now upstream.
167
168* Wed Mar 02 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-0vl1
169- new upstream release
170- updated patch7,8 from Fedora Development
171- added Japanese summary to devel package
172
173* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0.1-0vl1
174- new upstream release
175- add patch7,8 from fc
176
177* Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
178- add Patch11 from bugzilla.gnome.org to support ttc font's multiple face.
179
180* Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
181- new upstream release
182
183* Mon Sep 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
184- new upstream release
185
186* Sun Sep 14 2003 KAZUKI SHIMURA <rito@pos.to> 2.3.1-0vl2
187- Oops, spec was in Shift_JIS. Fixed.
188
189* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl1
190- new upstream release
191
192* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1.3-0vl1
193- new upstream release
194
195* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
196- new upstream release
197
198* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
199- new upstream release
200
201* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.8-0vl1
202- new upstream release
203
204* Thu Jan  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
205- new upstream release
206
207* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.6-0vl1
208- new upstream release
209
210* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
211- add patch1 to recognize .ttc font as TrueType font.
212
213* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
214- add %%{_datadir}/libgnomeprint for %%files
215
216* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
217- new upstream release
218
219* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
220- build for Vine Linux
221- new upstream release from gnome-2.1.4
222
223* Thu Aug 15 2002 Akira TAGOH <tagoh@redhat.com> 1.116.0-2
224- libgnomeprint-1.116.0-correctps.patch: applied to fix the invalid PostScript.
225
226* Tue Aug 13 2002 Akira TAGOH <tagoh@redhat.com> 1.116.0-1
227- libgnomeprint-1.116.0-perfprint.patch: applied to fix the printing
228  performance issue. (#66715)
229
230* Fri Jul 12 2002 Akira TAGOH <tagoh@redhat.com> 1.115.0-5
231- includes redhat-update-gnome-font-install2 script. (#66899)
232- fix the install path for fontmap.
233- add some directory owners.
234
235* Thu Jul 11 2002 Tim Powers <timp@redhat.com>
236- rebuilt
237
238* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
239- 1.115.0
240- include gtk-doc docs
241- move pkg-config files to -devel package
242
243* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
244- rebuild in different environment
245
246* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
247- 1.114.0
248
249* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
250- rebuild in different environment
251
252* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
253- rebuild in different environment
254- add bonobo-activation requires to make build system happy
255
256* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
257- 1.113.0
258
259* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
260- rebuild for new libraries
261
262* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
263- 1.112.0
264
265* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
266- 1.111.0
267
268* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
269- Version 1.110.0
270
271* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
272- automake14
273
274* Mon Jan  7 2002 Havoc Pennington <hp@redhat.com>
275- 1.109.0.90 snap
276- remove .options patch which is upstream
277- remove .nofontmaps patch, upstream uses sysconfdir sometimes now
278  and has --disable-font-install configure option
279- remove .fontmapdir, now fixed upstream
280
281* Tue Nov 27 2001 Havoc Pennington <hp@redhat.com>
282- rebuild due to build system fuckup
283
284* Tue Nov 27 2001 Havoc Pennington <hp@redhat.com>
285- cvs snap 1.106.0.90, glib 1.3.11
286
287* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
288- new cvs snap, rebuild for glib 1.3.10, remove bogus gtk dep
289
290* Tue Oct  9 2001 Havoc Pennington <hp@redhat.com>
291- remove epoch screwup
292
293* Mon Oct  8 2001 Havoc Pennington <hp@redhat.com>
294- libgnomeprint package based on the gnome-print package
295
296* Mon Oct  8 2001 Havoc Pennington <hp@redhat.com>
297- use 0.30 tarball
298
299* Sat Sep 22 2001 Havoc Pennington <hp@redhat.com>
300- new cvs snap, with headers moved
301
302* Wed Aug 15 2001 Owen Taylor <otaylor@redhat.com>
303- Back out freetype change, for now, until we can get it in upstream.
304- Move gnome-print/<ver>/profiles back to datadir, and remove the %config.
305  Making them %config doesn't seem compatible with locating them
306  in gnome-print/<ver>.
307
308* Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-5
309- no replace profiles.
310
311* Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-4
312- Move profiles directory to /etc/gnome-print/<ver>/profiles/
313
314* Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-3
315- Add freetype support patch. (Bug#50360)
316
317* Sat Jul 21 2001 Owen Taylor <otaylor@redhat.com>
318- Add missing directory
319
320* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
321- Upgrade to 0.29
322- Don't install run-gnome-font-install (#48466), run gnome-font-install directly.
323- Add BuildPrereq and make -devel package require gdk-pixbuf-devel
324- Make libgnomeprint package require gnome-print package; otherwise
325  packages requiring libgnomeprint might not get a runtime environment
326- Add Prereq on ghostscript, since run-gnome-font-install parses output of 'gs -h'
327
328* Mon Jul 16 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
329- Kill output from run-gnome-font-install
330- s/Copyright/License/
331- Add post/postun scripts for the libgnomeprint subpackage
332
333* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
334- Bump release + rebuild.
335
336* Fri Apr 20 2001 Jonathan Blandford <jrb@redhat.com>
337- new version (0.28)
338
339* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
340- Rebuild for GTK+-1.2.9 include paths
341
342* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
343- langify
344- patch it to compile (didn't include locale.h when needed)
345- use %%{_tmppath}
346
347* Fri Feb 23 2001 Akira TAGOH <tagoh@redhat.com>
348- Fixed font problem for Japanese.
349- Fixed library dependency on VFlib (Bug#28331)
350
351* Wed Feb 21 2001 Philipp Knirsch <pknirsch@redhat.de>
352- Fixed bugzilla bug #27417, simple specfile %post fix.
353
354* Sun Feb 18 2001 Akira TAGOH <tagoh@redhat.com>
355- Fixed PostScript broken.
356- Added autoheader,automake,autoconf stuff.
357
358* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
359- add libtoolize to make porting to new archs easy
360
361* Tue Feb 06 2001 Akira TAGOH <tagoh@redhat.com>
362- Updated Japanese patch for Gnumeric.
363  Created dummy .afm.
364
365* Mon Feb 05 2001 Akira TAGOH <tagoh@redhat.com>
366- Fixed gdk_fontset_load().
367- Added Japanese patch for Gnumeric.
368
369* Fri Feb 02 2001 Akira TAGOH <tagoh@redhat.com>
370- Added Japanese patch.
371  Fixed Print and Preview with Japanese.
372
373* Fri Dec 29 2000 Matt Wilson <msw@redhat.com>
374- 0.25
375
376* Sat Aug 19 2000 Preston Brown <pbrown@redhat.com>
377- added "|| true" to %%post so that if font-install screws up we don't get a
378  bad exit status.  gnome-font-install expects that the directory specified by
379  HOME env. var is writable, but it isn't always if you install with 'sudo'
380  or the equivalent.  bad. bad. bad.
381
382* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
383- Up Epoch and release
384
385* Fri Jul 14 2000 Matt Wilson <msw@redhat.com>
386- redirect %%post script output to /dev/null
387
388* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
389- automatic rebuild
390
391* Thu Jun 29 2000 Owen Taylor <otaylor@redhat.com>
392- Spec file fixes
Note: See TracBrowser for help on using the repository browser.