source: projects/specs/trunk/lib/libg/libgnomeprint/libgnomeprint-vl.spec @ 912

Revision 912, 12.6 KB checked in by Takemikaduchi, 14 years ago (diff)

change spec file

Line 
1## this could go, it's really just so we notice if the soname changes
2%define sover 0
3
4%define gettext_package libgnomeprint-2.2
5
6%define glib2_base_version 2.18.0
7%define glib2_version %{glib2_base_version}
8%define pango_version 1.22.0
9%define libxml2_version 2.5.8
10%define libart_lgpl_version 2.3.16
11%define libbonobo_version 2.24.0
12%define freetype_version 2.3.7
13%define gtk_doc_version 1.1
14
15Summary: Printing library for GNOME.
16Summary(ja): GNOME プリントライブラリ
17Name:           libgnomeprint
18Version:        2.18.7
19Release:        1%{?_dist_release}
20License:        LGPL
21Group:          System Environment/Libraries
22Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/2.18/%{name}-%{version}.tar.bz2
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-root
25BuildRequires: glib2-devel >= %{glib2_version}
26BuildRequires: pango-devel >= %{pango_version}
27BuildRequires: libxml2-devel >= %{libxml2_version}
28BuildRequires: libart_lgpl-devel >= %{libart_lgpl_version}
29BuildRequires: libbonobo-devel >= %{libbonobo_version}
30BuildRequires: freetype2 >= %{freetype_version}
31BuildRequires: gtk-doc >= %{gtk_doc_version}
32BuildRequires: libgnomecups-devel >= 0.2.0
33BuildRequires: bison
34BuildRequires: flex
35
36Requires: libgnomecups >= 0.1.13-0vl2
37Requires: urw-fonts
38Requires: ghostscript
39Requires: ghostscript-fonts
40Requires: libxml
41Requires: perl
42
43
44%description
45GNOME (GNU Network Object Model Environment) is a user-friendly set of
46applications and desktop tools to be used in conjunction with a window
47manager for the X Window System. The gnome-print package contains
48libraries and fonts needed by GNOME applications for printing.
49
50You should install the gnome-print package if you intend to use any of
51the GNOME applications that can print. If you would like to develop
52GNOME applications that can print you will also need to install the
53gnome-print devel package.
54
55%package devel
56Summary: Libraries and include files for developing GNOME applications.
57Summary(ja): libgnomeprint のライブラリとヘッダファイル
58Group: Development/Libraries
59
60Requires: %{name} = %{version}-%{release}
61Requires: glib2-devel >= %{glib2_version}
62Requires: pango-devel >= %{pango_version}
63Requires: libxml2-devel >= %{libxml2_version}
64Requires: libart_lgpl-devel >= %{libart_lgpl_version}
65Requires: libbonobo-devel >= %{libbonobo_version}
66Requires: freetype2 >= %{freetype_version}
67
68%description devel
69GNOME (GNU Network Object Model Environment) is a user-friendly set of
70applications and desktop tools to be used in conjunction with a window
71manager for the X Window System. The gnome-print-devel package
72includes the libraries and include files needed for developing
73applications that use the GNOME printing capabilities.
74
75You should install the gnome-print-devel package if you would like to
76develop GNOME applications that will use the GNOME print capabilities.
77You do not need to install the gnome-print-devel package if you just
78want to use the GNOME desktop environment.
79
80%prep
81%setup -q -n %{name}-%{version}
82
83%build
84%configure --disable-font-install --disable-gtk-doc
85make
86
87%install
88rm -rf $RPM_BUILD_ROOT
89
90# It would probably be cleaner to use install DESTDIR=$RPM_BUILD_ROOT
91# instead of %%makeinstall with this hack.
92%makeinstall
93
94# remove unpackaged files
95rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
96rm -f $RPM_BUILD_ROOT%{_libdir}/libgnomeprint/%{version}/modules/*.{a,la}
97rm -f $RPM_BUILD_ROOT%{_libdir}/libgnomeprint/%{version}/modules/*/*.{a,la}
98
99%clean
100rm -rf $RPM_BUILD_ROOT
101
102%post -p /sbin/ldconfig
103
104%postun -p /sbin/ldconfig
105
106%files
107%defattr(-, root, root)
108%doc AUTHORS COPYING ChangeLog NEWS README
109%dir %{_libdir}/libgnomeprint/%{version}
110%{_libdir}/libgnomeprint/%{version}/modules/*.so
111%{_libdir}/libgnomeprint/%{version}/modules/transports/*.so
112%{_libdir}/libgnomeprint/%{version}/modules/filters/*.so
113%{_libdir}/libgnomeprint*.so.*
114%{_datadir}/libgnomeprint
115%{_datadir}/locale/*/LC_MESSAGES/*.mo
116
117%files devel
118%defattr(-, root, root)
119%{_libdir}/libgnomeprint*.so
120%{_libdir}/*.a
121%{_includedir}/*
122%{_libdir}/pkgconfig/*.pc
123%{_datadir}/gtk-doc
124
125%changelog
126* Thu Apr 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.7-1
127- new upstream release
128- add BuildRequires: bison, flex
129
130* Wed Mar 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.6-1
131- new upstream release
132
133* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.5-1
134- new upstream release
135- build with gtk+2.14
136
137* Tue Mar 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1vl5
138- new upstream release
139- removed BuildRequires: automake17
140
141* Wed Dec 12 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
142- new upstream release
143
144* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl2
145- rebuilt with new toolchain/environment
146
147* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
148- new upstream release
149
150* Fri May 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl3
151- changed Group to System Environment/Libraries
152
153* Sat Apr 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
154- add missing filter modules to %%files
155- remove unneeded static modules
156
157* Wed Sep 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
158- new upstream release
159
160* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
161- new upstream release
162
163* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.0-0vl1
164- new upstream release
165
166* Sun Jul  3 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.3-0vl1
167- new upstream version
168- drop all patches that are now upstream.
169
170* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
171- new upstream version
172- drop all patches that are now upstream.
173
174* Wed Mar 02 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-0vl1
175- new upstream release
176- updated patch7,8 from Fedora Development
177- added Japanese summary to devel package
178
179* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0.1-0vl1
180- new upstream release
181- add patch7,8 from fc
182
183* Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
184- add Patch11 from bugzilla.gnome.org to support ttc font's multiple face.
185
186* Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
187- new upstream release
188
189* Mon Sep 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
190- new upstream release
191
192* Sun Sep 14 2003 KAZUKI SHIMURA <rito@pos.to> 2.3.1-0vl2
193- Oops, spec was in Shift_JIS. Fixed.
194
195* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl1
196- new upstream release
197
198* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1.3-0vl1
199- new upstream release
200
201* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
202- new upstream release
203
204* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
205- new upstream release
206
207* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.8-0vl1
208- new upstream release
209
210* Thu Jan  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
211- new upstream release
212
213* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.6-0vl1
214- new upstream release
215
216* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
217- add patch1 to recognize .ttc font as TrueType font.
218
219* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
220- add %%{_datadir}/libgnomeprint for %%files
221
222* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
223- new upstream release
224
225* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
226- build for Vine Linux
227- new upstream release from gnome-2.1.4
228
229* Thu Aug 15 2002 Akira TAGOH <tagoh@redhat.com> 1.116.0-2
230- libgnomeprint-1.116.0-correctps.patch: applied to fix the invalid PostScript.
231
232* Tue Aug 13 2002 Akira TAGOH <tagoh@redhat.com> 1.116.0-1
233- libgnomeprint-1.116.0-perfprint.patch: applied to fix the printing
234  performance issue. (#66715)
235
236* Fri Jul 12 2002 Akira TAGOH <tagoh@redhat.com> 1.115.0-5
237- includes redhat-update-gnome-font-install2 script. (#66899)
238- fix the install path for fontmap.
239- add some directory owners.
240
241* Thu Jul 11 2002 Tim Powers <timp@redhat.com>
242- rebuilt
243
244* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
245- 1.115.0
246- include gtk-doc docs
247- move pkg-config files to -devel package
248
249* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
250- rebuild in different environment
251
252* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
253- 1.114.0
254
255* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
256- rebuild in different environment
257
258* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
259- rebuild in different environment
260- add bonobo-activation requires to make build system happy
261
262* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
263- 1.113.0
264
265* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
266- rebuild for new libraries
267
268* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
269- 1.112.0
270
271* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
272- 1.111.0
273
274* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
275- Version 1.110.0
276
277* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
278- automake14
279
280* Mon Jan  7 2002 Havoc Pennington <hp@redhat.com>
281- 1.109.0.90 snap
282- remove .options patch which is upstream
283- remove .nofontmaps patch, upstream uses sysconfdir sometimes now
284  and has --disable-font-install configure option
285- remove .fontmapdir, now fixed upstream
286
287* Tue Nov 27 2001 Havoc Pennington <hp@redhat.com>
288- rebuild due to build system fuckup
289
290* Tue Nov 27 2001 Havoc Pennington <hp@redhat.com>
291- cvs snap 1.106.0.90, glib 1.3.11
292
293* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
294- new cvs snap, rebuild for glib 1.3.10, remove bogus gtk dep
295
296* Tue Oct  9 2001 Havoc Pennington <hp@redhat.com>
297- remove epoch screwup
298
299* Mon Oct  8 2001 Havoc Pennington <hp@redhat.com>
300- libgnomeprint package based on the gnome-print package
301
302* Mon Oct  8 2001 Havoc Pennington <hp@redhat.com>
303- use 0.30 tarball
304
305* Sat Sep 22 2001 Havoc Pennington <hp@redhat.com>
306- new cvs snap, with headers moved
307
308* Wed Aug 15 2001 Owen Taylor <otaylor@redhat.com>
309- Back out freetype change, for now, until we can get it in upstream.
310- Move gnome-print/<ver>/profiles back to datadir, and remove the %config.
311  Making them %config doesn't seem compatible with locating them
312  in gnome-print/<ver>.
313
314* Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-5
315- no replace profiles.
316
317* Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-4
318- Move profiles directory to /etc/gnome-print/<ver>/profiles/
319
320* Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-3
321- Add freetype support patch. (Bug#50360)
322
323* Sat Jul 21 2001 Owen Taylor <otaylor@redhat.com>
324- Add missing directory
325
326* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
327- Upgrade to 0.29
328- Don't install run-gnome-font-install (#48466), run gnome-font-install directly.
329- Add BuildPrereq and make -devel package require gdk-pixbuf-devel
330- Make libgnomeprint package require gnome-print package; otherwise
331  packages requiring libgnomeprint might not get a runtime environment
332- Add Prereq on ghostscript, since run-gnome-font-install parses output of 'gs -h'
333
334* Mon Jul 16 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
335- Kill output from run-gnome-font-install
336- s/Copyright/License/
337- Add post/postun scripts for the libgnomeprint subpackage
338
339* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
340- Bump release + rebuild.
341
342* Fri Apr 20 2001 Jonathan Blandford <jrb@redhat.com>
343- new version (0.28)
344
345* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
346- Rebuild for GTK+-1.2.9 include paths
347
348* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
349- langify
350- patch it to compile (didn't include locale.h when needed)
351- use %%{_tmppath}
352
353* Fri Feb 23 2001 Akira TAGOH <tagoh@redhat.com>
354- Fixed font problem for Japanese.
355- Fixed library dependency on VFlib (Bug#28331)
356
357* Wed Feb 21 2001 Philipp Knirsch <pknirsch@redhat.de>
358- Fixed bugzilla bug #27417, simple specfile %post fix.
359
360* Sun Feb 18 2001 Akira TAGOH <tagoh@redhat.com>
361- Fixed PostScript broken.
362- Added autoheader,automake,autoconf stuff.
363
364* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
365- add libtoolize to make porting to new archs easy
366
367* Tue Feb 06 2001 Akira TAGOH <tagoh@redhat.com>
368- Updated Japanese patch for Gnumeric.
369  Created dummy .afm.
370
371* Mon Feb 05 2001 Akira TAGOH <tagoh@redhat.com>
372- Fixed gdk_fontset_load().
373- Added Japanese patch for Gnumeric.
374
375* Fri Feb 02 2001 Akira TAGOH <tagoh@redhat.com>
376- Added Japanese patch.
377  Fixed Print and Preview with Japanese.
378
379* Fri Dec 29 2000 Matt Wilson <msw@redhat.com>
380- 0.25
381
382* Sat Aug 19 2000 Preston Brown <pbrown@redhat.com>
383- added "|| true" to %%post so that if font-install screws up we don't get a
384  bad exit status.  gnome-font-install expects that the directory specified by
385  HOME env. var is writable, but it isn't always if you install with 'sudo'
386  or the equivalent.  bad. bad. bad.
387
388* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
389- Up Epoch and release
390
391* Fri Jul 14 2000 Matt Wilson <msw@redhat.com>
392- redirect %%post script output to /dev/null
393
394* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
395- automatic rebuild
396
397* Thu Jun 29 2000 Owen Taylor <otaylor@redhat.com>
398- Spec file fixes
Note: See TracBrowser for help on using the repository browser.