source: projects/specs/trunk/lib/libg/libgnomeprint/libgnomeprint-vl.spec @ 1860

Revision 1860, 12.7 KB checked in by iwaim, 14 years ago (diff)

build with rpm 4.8.1-1; see [VineSeed:21799]

Line 
1## this could go, it's really just so we notice if the soname changes
2%define sover 0
3
4%define gettext_package libgnomeprint-2.2
5
6%define glib2_base_version 2.18.0
7%define glib2_version %{glib2_base_version}
8%define pango_version 1.22.0
9%define libxml2_version 2.5.8
10%define libart_lgpl_version 2.3.16
11%define libbonobo_version 2.24.0
12%define freetype_version 2.3.7
13%define gtk_doc_version 1.1
14
15Summary: Printing library for GNOME.
16Summary(ja): GNOME プリントライブラリ
17Name:           libgnomeprint
18Version:        2.18.7
19Release:        2%{?_dist_release}
20License:        LGPL
21Group:          System Environment/Libraries
22Source:         ftp://ftp.gnome.org/pub/gnome/sources/%{name}/2.18/%{name}-%{version}.tar.bz2
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-root
25BuildRequires: glib2-devel >= %{glib2_version}
26BuildRequires: pango-devel >= %{pango_version}
27BuildRequires: libxml2-devel >= %{libxml2_version}
28BuildRequires: libart_lgpl-devel >= %{libart_lgpl_version}
29BuildRequires: libbonobo-devel >= %{libbonobo_version}
30BuildRequires: freetype2 >= %{freetype_version}
31BuildRequires: gtk-doc >= %{gtk_doc_version}
32BuildRequires: libgnomecups-devel >= 0.2.0
33BuildRequires: bison
34BuildRequires: flex
35
36Requires: libgnomecups >= 0.1.13-0vl2
37Requires: urw-fonts
38Requires: ghostscript
39Requires: ghostscript-fonts
40Requires: libxml
41Requires: perl
42
43
44%description
45GNOME (GNU Network Object Model Environment) is a user-friendly set of
46applications and desktop tools to be used in conjunction with a window
47manager for the X Window System. The gnome-print package contains
48libraries and fonts needed by GNOME applications for printing.
49
50You should install the gnome-print package if you intend to use any of
51the GNOME applications that can print. If you would like to develop
52GNOME applications that can print you will also need to install the
53gnome-print devel package.
54
55%package devel
56Summary: Libraries and include files for developing GNOME applications.
57Summary(ja): libgnomeprint のライブラリとヘッダファイル
58Group: Development/Libraries
59
60Requires: %{name} = %{version}-%{release}
61Requires: glib2-devel >= %{glib2_version}
62Requires: pango-devel >= %{pango_version}
63Requires: libxml2-devel >= %{libxml2_version}
64Requires: libart_lgpl-devel >= %{libart_lgpl_version}
65Requires: libbonobo-devel >= %{libbonobo_version}
66Requires: freetype2 >= %{freetype_version}
67
68%description devel
69GNOME (GNU Network Object Model Environment) is a user-friendly set of
70applications and desktop tools to be used in conjunction with a window
71manager for the X Window System. The gnome-print-devel package
72includes the libraries and include files needed for developing
73applications that use the GNOME printing capabilities.
74
75You should install the gnome-print-devel package if you would like to
76develop GNOME applications that will use the GNOME print capabilities.
77You do not need to install the gnome-print-devel package if you just
78want to use the GNOME desktop environment.
79
80%prep
81%setup -q -n %{name}-%{version}
82
83%build
84%configure --disable-font-install --disable-gtk-doc
85make
86
87%install
88rm -rf $RPM_BUILD_ROOT
89
90# It would probably be cleaner to use install DESTDIR=$RPM_BUILD_ROOT
91# instead of %%makeinstall with this hack.
92%makeinstall
93
94# remove unpackaged files
95rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
96rm -f $RPM_BUILD_ROOT%{_libdir}/libgnomeprint/%{version}/modules/*.{a,la}
97rm -f $RPM_BUILD_ROOT%{_libdir}/libgnomeprint/%{version}/modules/*/*.{a,la}
98
99%clean
100rm -rf $RPM_BUILD_ROOT
101
102%post -p /sbin/ldconfig
103
104%postun -p /sbin/ldconfig
105
106%files
107%defattr(-, root, root)
108%doc AUTHORS COPYING ChangeLog NEWS README
109%dir %{_libdir}/libgnomeprint/%{version}
110%{_libdir}/libgnomeprint/%{version}/modules/*.so
111%{_libdir}/libgnomeprint/%{version}/modules/transports/*.so
112%{_libdir}/libgnomeprint/%{version}/modules/filters/*.so
113%{_libdir}/libgnomeprint*.so.*
114%{_datadir}/libgnomeprint
115%{_datadir}/locale/*/LC_MESSAGES/*.mo
116
117%files devel
118%defattr(-, root, root)
119%{_libdir}/libgnomeprint*.so
120%{_libdir}/*.a
121%{_includedir}/*
122%{_libdir}/pkgconfig/*.pc
123%{_datadir}/gtk-doc
124
125%changelog
126* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.18.7-2
127- build with rpm-4.8.1-1 for pkg-config file
128
129* Thu Apr 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.7-1
130- new upstream release
131- add BuildRequires: bison, flex
132
133* Wed Mar 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.6-1
134- new upstream release
135
136* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.5-1
137- new upstream release
138- build with gtk+2.14
139
140* Tue Mar 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1vl5
141- new upstream release
142- removed BuildRequires: automake17
143
144* Wed Dec 12 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
145- new upstream release
146
147* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl2
148- rebuilt with new toolchain/environment
149
150* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
151- new upstream release
152
153* Fri May 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl3
154- changed Group to System Environment/Libraries
155
156* Sat Apr 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
157- add missing filter modules to %%files
158- remove unneeded static modules
159
160* Wed Sep 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
161- new upstream release
162
163* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
164- new upstream release
165
166* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.0-0vl1
167- new upstream release
168
169* Sun Jul  3 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.3-0vl1
170- new upstream version
171- drop all patches that are now upstream.
172
173* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
174- new upstream version
175- drop all patches that are now upstream.
176
177* Wed Mar 02 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-0vl1
178- new upstream release
179- updated patch7,8 from Fedora Development
180- added Japanese summary to devel package
181
182* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0.1-0vl1
183- new upstream release
184- add patch7,8 from fc
185
186* Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
187- add Patch11 from bugzilla.gnome.org to support ttc font's multiple face.
188
189* Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
190- new upstream release
191
192* Mon Sep 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
193- new upstream release
194
195* Sun Sep 14 2003 KAZUKI SHIMURA <rito@pos.to> 2.3.1-0vl2
196- Oops, spec was in Shift_JIS. Fixed.
197
198* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl1
199- new upstream release
200
201* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1.3-0vl1
202- new upstream release
203
204* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
205- new upstream release
206
207* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
208- new upstream release
209
210* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.8-0vl1
211- new upstream release
212
213* Thu Jan  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
214- new upstream release
215
216* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.6-0vl1
217- new upstream release
218
219* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
220- add patch1 to recognize .ttc font as TrueType font.
221
222* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
223- add %%{_datadir}/libgnomeprint for %%files
224
225* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
226- new upstream release
227
228* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
229- build for Vine Linux
230- new upstream release from gnome-2.1.4
231
232* Thu Aug 15 2002 Akira TAGOH <tagoh@redhat.com> 1.116.0-2
233- libgnomeprint-1.116.0-correctps.patch: applied to fix the invalid PostScript.
234
235* Tue Aug 13 2002 Akira TAGOH <tagoh@redhat.com> 1.116.0-1
236- libgnomeprint-1.116.0-perfprint.patch: applied to fix the printing
237  performance issue. (#66715)
238
239* Fri Jul 12 2002 Akira TAGOH <tagoh@redhat.com> 1.115.0-5
240- includes redhat-update-gnome-font-install2 script. (#66899)
241- fix the install path for fontmap.
242- add some directory owners.
243
244* Thu Jul 11 2002 Tim Powers <timp@redhat.com>
245- rebuilt
246
247* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
248- 1.115.0
249- include gtk-doc docs
250- move pkg-config files to -devel package
251
252* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
253- rebuild in different environment
254
255* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
256- 1.114.0
257
258* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
259- rebuild in different environment
260
261* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
262- rebuild in different environment
263- add bonobo-activation requires to make build system happy
264
265* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
266- 1.113.0
267
268* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
269- rebuild for new libraries
270
271* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
272- 1.112.0
273
274* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
275- 1.111.0
276
277* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
278- Version 1.110.0
279
280* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
281- automake14
282
283* Mon Jan  7 2002 Havoc Pennington <hp@redhat.com>
284- 1.109.0.90 snap
285- remove .options patch which is upstream
286- remove .nofontmaps patch, upstream uses sysconfdir sometimes now
287  and has --disable-font-install configure option
288- remove .fontmapdir, now fixed upstream
289
290* Tue Nov 27 2001 Havoc Pennington <hp@redhat.com>
291- rebuild due to build system fuckup
292
293* Tue Nov 27 2001 Havoc Pennington <hp@redhat.com>
294- cvs snap 1.106.0.90, glib 1.3.11
295
296* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
297- new cvs snap, rebuild for glib 1.3.10, remove bogus gtk dep
298
299* Tue Oct  9 2001 Havoc Pennington <hp@redhat.com>
300- remove epoch screwup
301
302* Mon Oct  8 2001 Havoc Pennington <hp@redhat.com>
303- libgnomeprint package based on the gnome-print package
304
305* Mon Oct  8 2001 Havoc Pennington <hp@redhat.com>
306- use 0.30 tarball
307
308* Sat Sep 22 2001 Havoc Pennington <hp@redhat.com>
309- new cvs snap, with headers moved
310
311* Wed Aug 15 2001 Owen Taylor <otaylor@redhat.com>
312- Back out freetype change, for now, until we can get it in upstream.
313- Move gnome-print/<ver>/profiles back to datadir, and remove the %config.
314  Making them %config doesn't seem compatible with locating them
315  in gnome-print/<ver>.
316
317* Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-5
318- no replace profiles.
319
320* Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-4
321- Move profiles directory to /etc/gnome-print/<ver>/profiles/
322
323* Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-3
324- Add freetype support patch. (Bug#50360)
325
326* Sat Jul 21 2001 Owen Taylor <otaylor@redhat.com>
327- Add missing directory
328
329* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
330- Upgrade to 0.29
331- Don't install run-gnome-font-install (#48466), run gnome-font-install directly.
332- Add BuildPrereq and make -devel package require gdk-pixbuf-devel
333- Make libgnomeprint package require gnome-print package; otherwise
334  packages requiring libgnomeprint might not get a runtime environment
335- Add Prereq on ghostscript, since run-gnome-font-install parses output of 'gs -h'
336
337* Mon Jul 16 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
338- Kill output from run-gnome-font-install
339- s/Copyright/License/
340- Add post/postun scripts for the libgnomeprint subpackage
341
342* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
343- Bump release + rebuild.
344
345* Fri Apr 20 2001 Jonathan Blandford <jrb@redhat.com>
346- new version (0.28)
347
348* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
349- Rebuild for GTK+-1.2.9 include paths
350
351* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
352- langify
353- patch it to compile (didn't include locale.h when needed)
354- use %%{_tmppath}
355
356* Fri Feb 23 2001 Akira TAGOH <tagoh@redhat.com>
357- Fixed font problem for Japanese.
358- Fixed library dependency on VFlib (Bug#28331)
359
360* Wed Feb 21 2001 Philipp Knirsch <pknirsch@redhat.de>
361- Fixed bugzilla bug #27417, simple specfile %post fix.
362
363* Sun Feb 18 2001 Akira TAGOH <tagoh@redhat.com>
364- Fixed PostScript broken.
365- Added autoheader,automake,autoconf stuff.
366
367* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
368- add libtoolize to make porting to new archs easy
369
370* Tue Feb 06 2001 Akira TAGOH <tagoh@redhat.com>
371- Updated Japanese patch for Gnumeric.
372  Created dummy .afm.
373
374* Mon Feb 05 2001 Akira TAGOH <tagoh@redhat.com>
375- Fixed gdk_fontset_load().
376- Added Japanese patch for Gnumeric.
377
378* Fri Feb 02 2001 Akira TAGOH <tagoh@redhat.com>
379- Added Japanese patch.
380  Fixed Print and Preview with Japanese.
381
382* Fri Dec 29 2000 Matt Wilson <msw@redhat.com>
383- 0.25
384
385* Sat Aug 19 2000 Preston Brown <pbrown@redhat.com>
386- added "|| true" to %%post so that if font-install screws up we don't get a
387  bad exit status.  gnome-font-install expects that the directory specified by
388  HOME env. var is writable, but it isn't always if you install with 'sudo'
389  or the equivalent.  bad. bad. bad.
390
391* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
392- Up Epoch and release
393
394* Fri Jul 14 2000 Matt Wilson <msw@redhat.com>
395- redirect %%post script output to /dev/null
396
397* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
398- automatic rebuild
399
400* Thu Jun 29 2000 Owen Taylor <otaylor@redhat.com>
401- Spec file fixes
Note: See TracBrowser for help on using the repository browser.