source: projects/specs/trunk/lib/libg/libgnomemm/libgnomemm-vl.spec @ 521

Revision 521, 3.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# ...for those missing static libraries...
2#
3# in order to build devel packages with static libs included you have to
4# change '--disable-static' to '--enable-static' and uncomment the line
5# containing the pattern ".../*.a" at the files section
6Summary:        A C++ interface for Gnome libs (a GUI library for X).
7Summary(ja):    Gnome ライブラリの C++ インターフェイス
8Name:           libgnomemm
9Version:        2.24.0
10Release:        1%{?_dist_release}
11License:        LGPL
12Group:          System Environment/Libraries
13Source:         ftp://download.sourceforge.net/gtkmm/%{name}-%{version}.tar.bz2
14URL:            http://gtkmm.sourceforge.net/
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16Requires:       gtkmm2 >= 2.8.0
17Requires:       libgnome >= 2.6.0
18BuildRequires:  gtkmm2-devel >= 2.8.0
19BuildRequires:  libgnome-devel >= 2.6.0
20
21%description
22This package provides a C++ interface for GnomeUI.  It is a subpackage
23of the Gtk-- project.  The interface provides a convenient interface for C++
24programmers to create Gnome GUIs with GTK+'s flexible object-oriented
25framework.
26
27#'
28%package        devel
29Summary:        Headers for developing programs that will use Gnome--.
30Summary(ja):    Gnome-- を使うプログラムの開発用ファイル
31Group:          Development/Libraries
32Requires:       %{name} = %{version}
33Requires:       gtkmm2-devel >= 2.8.0
34Requires:       libgnome-devel >= 2.6.0
35
36%description devel
37This package contains the headers that programmers will need to develop
38applications which will use Gnome--, part of Gtk-- the C++ interface to
39the GTK+ (the Gimp ToolKit) GUI library.
40
41%prep
42%setup -q
43
44%build
45# ...hope this can be removed soon
46%ifarch alpha
47        ARCH_FLAGS="--host=alpha-redhat-linux"
48%endif
49%configure --disable-static $ARCH_FLAGS
50
51export tagname=CC
52make LIBTOOL=/usr/bin/libtool
53
54%install
55if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
56export tagname=CC
57%makeinstall LIBTOOL=/usr/bin/libtool
58
59rm -f $RPM_BUILD_ROOT%{_libdir}/libgnomemm-*.a
60
61%post -p /sbin/ldconfig
62
63%postun -p /sbin/ldconfig
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
68%files
69%defattr(-, root, root)
70%doc AUTHORS COPYING ChangeLog INSTALL NEWS README
71%{_libdir}/*.so.*
72
73%files  devel
74%defattr(-, root, root)
75%{_includedir}/*
76#{_libdir}/*.a
77%exclude %{_libdir}/*.la
78%{_libdir}/*.so
79%{_libdir}/pkgconfig/*.pc
80%{_libdir}/libgnomemm-2.6
81
82
83%changelog
84* Sat Oct  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.0-1
85- new upstream release
86
87* Fri Sep 19 2008 Shu KONNO <owa@bg.wakwak.com> 2.18.0-1vl5
88- applied new versioning policy, spec in utf-8
89- excluded *.la
90
91* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl3
92- rebuilt without libstdc++2_10
93
94* Fri May 11 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl2
95- rebuilt with new toolchains
96
97* Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl1
98- new upstream release
99
100* Sat Nov  4 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.0-0vl1
101- new upstream release
102
103* Tue Feb 14 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.12.2-0vl1
104- new upstream release
105
106* Fri Sep 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.0-0vl1
107- new upstream release
108
109* Fri Jan 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.0-0vl1
110- new upstream release
111
112* Thu Nov 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.0-0vl1
113- new upstream release
114- added Japanese summary
115
116* Sat Jan 31 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-0vl1
117- rebuild for Vine Linux
118
119* Tue Sep 23 2003 Eric Bourque <ericb@computer.org>
120- updated for changes to libgnomemm-2.0
121
122* Tue Mar 20 2001 Eric Bourque <ericb@computer.org>
123- added gnome--.m4 to files devel section
124
125* Sat Mar 10 2001 Herbert Valerio Riedel <hvr@gnu.org>
126- improved examples.conf
127- fixed example build problems
128
129* Thu May 11 2000 Herbert Valerio Riedel <hvr@gnu.org>
130- removed lib/gtkmm from files section
131- removed empty obsolete tags
132
133* Sun Jan 30 2000 Karl Einar Nelson <kenelson@sourceforge.net>
134- adapted from gtk--.spec
Note: See TracBrowser for help on using the repository browser.