source: projects/specs/trunk/lib/libg/libgnomedb/libgnomedb-vl.spec @ 521

Revision 521, 6.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:         Library for writing gnome database programs
2Name:            libgnomedb
3Version:         3.1.2
4Release:         1%{?_dist_release}
5Source:          %{name}-%{version}.tar.bz2
6Patch0:          libgnomedb-3.1.2-desktop.patch
7
8URL:             http://www.gnome-db.org/
9Group:           System Environment/Libraries
10License:         LGPL
11
12BuildRoot:       %{_tmppath}/%{name}-%{version}-root
13Requires:        libgda >= 3.0.0
14Requires:        gtk2 >= 2.6.0
15Requires:        libglade2
16Requires:        gtksourceview
17Requires(post,pre,preun): GConf2
18
19BuildRequires:   GConf2-devel
20BuildRequires:   gtk2-devel >= 2.6.0
21BuildRequires:   libgda-devel >= 3.0.0
22BuildRequires:   libgcrypt-devel
23BuildRequires:   libgnomecanvas-devel
24BuildRequires:   iso-codes
25BuildRequires:   libglade2-devel
26BuildRequires:   intltool >= 0.30
27BuildRequires:   gtk-doc >= 1.0
28BuildRequires:   gtksourceview-devel
29BuildRequires:   desktop-file-utils
30BuildRequires:   gamin-devel
31BuildRequires:   pkgconfig >= 0.8
32
33%description
34libgnomedb is a library that eases the task of writing
35gnome database programs.
36
37%package devel
38Summary:         Development libraries and header files for libgnomedb.
39Group:           Development/Libraries
40Requires:        %name = %{version}
41Requires:        pkgconfig >= 0.8
42Requires:        gtk2-devel >= 2.6.0
43Requires:        libgda-devel >= 3.0.0
44Requires:        libgnomecanvas-devel
45Requires:        libglade2-devel
46Requires:        gtksourceview-devel
47Requires:        iso-codes
48Requires(post,postun): scrollkeeper
49
50%description devel
51This package contains the header files and libraries needed to write
52or compile programs that use libgda.
53
54%prep
55%setup -q -n %{name}-%{version}
56%patch0 -p1 -b .desktop.patch
57
58%build
59%configure --disable-schemas-install
60make
61
62%install
63rm -rf %{buildroot}
64
65export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
66make install DESTDIR=$RPM_BUILD_ROOT
67unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
68
69%find_lang libgnomedb-3.0
70
71#desktop-file-install \
72#  --dir %{buildroot}%{_datadir}/applications \
73#  --vendor gnome --delete-original \
74#  %{buildroot}%{_datadir}/applications/database-properties.desktop
75
76# remove unpackaged files
77rm -f %{buildroot}/%{_libdir}/*.la
78rm -f %{buildroot}/%{_libdir}/gnome-db-3.0/plugins/*.{a,la}
79rm -f %{buildroot}/%{_libdir}/libglade/2.0/*.{a,la}
80
81%post
82/sbin/ldconfig
83export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
84/usr/bin/gconftool-2 --makefile-install-rule \
85    %{_sysconfdir}/gconf/schemas/libgnomedb-3.0.schemas > /dev/null || :
86
87%pre
88if [ "$1" -gt 1 ]; then
89    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
90    gconftool-2 --makefile-uninstall-rule \
91     %{_sysconfdir}/gconf/schemas/libgnomedb-3.0.schemas \
92     > /dev/null || :
93fi
94
95%preun
96if [ "$1" -eq 0 ]; then
97    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
98    gconftool-2 --makefile-uninstall-rule \
99     %{_sysconfdir}/gconf/schemas/libgnomedb-3.0.schemas \
100     > /dev/null || :
101fi
102
103%postun -p /sbin/ldconfig
104
105%post devel
106if which scrollkeeper-update >/dev/null 2>&1; then scrollkeeper-update; fi
107
108%postun devel
109if which scrollkeeper-update >/dev/null 2>&1; then scrollkeeper-update; fi
110
111%clean
112rm -rf %{buildroot}
113
114%files -f libgnomedb-3.0.lang
115%defattr(-,root,root)
116%doc AUTHORS COPYING ChangeLog README NEWS
117%{_bindir}/*
118%{_datadir}/applications/*.desktop
119%dir %{_datadir}/gnome-db-3.0
120%{_datadir}/gnome-db-3.0/*
121%{_datadir}/pixmaps/*
122%{_libdir}/lib*.so.*
123%{_libdir}/libglade/2.0/lib*.so
124%dir %{_libdir}/gnome-db-3.0/plugins
125%{_libdir}/gnome-db-3.0/plugins/lib*.so
126%config(noreplace) %{_sysconfdir}/gconf/schemas/*.schemas
127
128%files devel
129%defattr(-,root,root)
130%{_includedir}/libgnomedb-3.0
131%{_libdir}/*.a
132#{_libdir}/*.la
133%{_libdir}/*.so
134#{_libdir}/libglade/2.0/lib*.a
135#{_libdir}/libgnomedb/plugins/lib*.so
136%{_libdir}/pkgconfig/*.pc
137%{_datadir}/omf/*
138%{_datadir}/gtk-doc/*
139
140%changelog
141* Mon Jun 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.2-1
142- new upstream release
143- updated Patch0
144
145* Sat Dec 29 2007 Shu KONNO <owa@bg.wakwak.com> 1.9.100-0vl6
146- updated libgnomedb-*-desktop.patch
147
148* Sun May 27 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.100-0vl5
149- add BuildRequires: libgda-sharp, gtk-doc
150
151* Tue May 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl4
152- rebuilt with new toolchains
153
154* Wed Nov  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl3
155- added Patch0,1,2 and 3 from Fedora
156  * Thu May  4 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 1:1.9.100-7
157  - Add patch3 fixing a couple of x86_64 bugs (bz 190366)
158  * Mon Feb 13 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 1:1.9.100-5
159  - Attempt to properly install C-sharp/mono bindings
160  * Fri Mar 24 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 1:1.9.100-6
161  - Add patch2 fixing bz 186517
162  * Mon Feb 21 2005 Caolan McNamara <caolanm@redhat.com> 1.2.0-2
163  - rh#149232#/rh#149222# install .desktop to /usr/share/applications
164
165* Sun Jun 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl2
166- rebuilt with gamin-devel
167
168* Wed Feb  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl1
169- new upstream release
170- added development document to devel
171
172* Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
173- new upstream release
174
175* Sun Aug 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.6-0vl1
176- new upstream release
177- re-define __libtoolize to compile shared object
178
179* Sun Mar 28 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl1
180- new upstream release
181- to use intltool 0.30
182
183* Sat Dec  6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl1
184- new upstream release
185
186* Fri Oct 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.1-0vl1
187- new upstream release
188
189* Sat Sep 27 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.0-1vl1
190- build for Vine Linux
191
192* Tue Jan 28 2003 Yanko Kaneti <yaneti@delcera.com>
193- Package and add the omf/scrollkeeper bits.
194- --disable-gtk-doc to configure because the generated docs are in the tarball
195
196* Mon Aug 19 2002 Ben Liblit <liblit@acm.org>
197- Fixed version number substitutions
198- Updated files list to match what "make install" actually installs
199- Added URL tag pointing to GNOME-DB project's web site
200
201* Mon Feb 25 2002 Chris Chabot <chabotc@reviewboard.com>
202- Cleaned up formatting
203- Added requirements
204
205* Thu Feb 21 2002 Chris Chabot <chabotc@reviewboard.com>
206- Initial spec file
Note: See TracBrowser for help on using the repository browser.