source: projects/specs/trunk/lib/libg/libgnome/libgnome-vl.spec @ 521

Revision 521, 14.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define glib2_version 2.20.0
2%define libbonobo_version 2.24.2
3%define libxml2_version 2.6.0
4%define libxslt_version 1.0.30
5%define gconf2_version 2.26.0
6%define gnome_vfs2_version 2.24.2
7%define orbit2_version 2.14.17
8%define esound_version 0.2.31
9
10%define po_package libgnome-2.0
11
12%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
13
14Summary: GNOME base library
15Summary(ja): GNOME 基本ライブラリ
16Name: libgnome
17Version: 2.28.0
18Release: 1%{?_dist_release}
19URL: ftp://ftp.gnome.org/
20Source0: %{name}-%{version}.tar.bz2
21License: LGPLv2+
22Group: System Environment/Libraries
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24
25Requires:  glib2 >= %{glib2_version}
26Requires:  libbonobo >= %{libbonobo_version}
27Requires:  gnome-vfs2 >= %{gnome_vfs2_version}
28Requires:  libxml2 >= %{libxml2_version}
29Requires:  ORBit2 >= %{orbit2_version}
30Requires:  libxslt >= %{libxslt_version}
31Requires:  vine-backgrounds >= 2.0
32Requires(post,pre,preun):  GConf2 >= %{gconf2_version}
33# Added to avoid the warning messages about utmp group, bug #24171
34# fixme, just libzvt?
35Requires(post): utempter
36
37BuildRequires:  zlib-devel
38BuildRequires:  esound-devel >= %{esound_version}
39BuildRequires:  glib2-devel >= %{glib2_version}
40BuildRequires:  libbonobo-devel >= %{libbonobo_version}
41BuildRequires:  GConf2-devel >= %{gconf2_version}
42BuildRequires:  gnome-vfs2-devel >= %{gnome_vfs2_version}
43BuildRequires:  libxml2-devel >= %{libxml2_version}
44BuildRequires:  ORBit2-devel >= %{orbit2_version}
45BuildRequires:  libxslt-devel >= %{libxslt_version}
46BuildRequires:  intltool
47
48Patch0: libgnome-2.20.1.1-default-theme-vine.patch
49Patch1: libgnome-2.26.0-default-background-vine.patch
50Patch2: libgnome-2.8.0-default-cursor-vine.patch
51Patch3: libgnome-2.11.1-scoreloc.patch
52Patch5: libgnome-2.8.0-default-browser.patch
53Patch6: libgnome-2.22.0-default-settings-vine.patch
54Patch7: libgnome-2.9.1-popt.patch
55
56Patch10: libgnome-2.14.1-i18n-help.patch
57
58%description
59GNOME (GNU Network Object Model Environment) is a user-friendly set of
60GUI applications and desktop tools to be used in conjunction with a
61window manager for the X Window System. The libgnome package includes
62non-GUI-related libraries that are needed to run GNOME. The libgnomeui
63package contains X11-dependent GNOME library features.
64
65
66%package devel
67Summary: Libraries and headers for libgnome
68Summary(ja): libgnome の開発用ライブラリおよびヘッダファイル
69Group: Development/Libraries
70Requires: %{name} = %{version}-%{release}
71
72Conflicts: gnome-libs-devel < 1.4.1.2
73Requires: zlib-devel
74Requires: esound-devel
75Requires: ORBit2-devel >= %{orbit2_version}
76Requires: glib2-devel >= %{glib2_version}
77Requires: libbonobo-devel >= %{libbonobo_version}
78Requires: GConf2-devel >= %{gconf2_version}
79Requires: gnome-vfs2-devel >= %{gnome_vfs2_version}
80Requires: libxml2-devel >= %{libxml2_version}
81Requires: libxslt-devel >= %{libxslt_version}
82Requires: popt-devel
83
84%description devel
85GNOME (GNU Network Object Model Environment) is a user-friendly set of
86GUI applications and desktop tools to be used in conjunction with a
87window manager for the X Window System. The libgnome-devel package
88includes the libraries and include files that you will need to
89use libgnome.
90
91You should install the libgnome-devel package if you would like to
92compile GNOME applications. You do not need to install libgnome-devel
93if you just want to use the GNOME desktop environment.
94
95
96# compat32
97%package -n compat32-%{name}
98Summary: GNOME base library
99Summary(ja): GNOME 基本ライブラリ
100Group: System Environment/Libraries
101Requires: %{name} = %{version}-%{release}
102
103%description -n compat32-%{name}
104GNOME (GNU Network Object Model Environment) is a user-friendly set of
105GUI applications and desktop tools to be used in conjunction with a
106window manager for the X Window System. The libgnome package includes
107non-GUI-related libraries that are needed to run GNOME. The libgnomeui
108package contains X11-dependent GNOME library features.
109
110
111%package -n compat32-%{name}-devel
112Summary: Libraries and headers for libgnome
113Summary(ja): libgnome の開発用ライブラリおよびヘッダファイル
114Group: Development/Libraries
115Requires: %{name}-devel = %{version}-%{release}
116Requires: compat32-%{name} = %{version}-%{release}
117Requires: compat32-zlib-devel
118Requires: compat32-esound-devel
119Requires: compat32-ORBit2-devel >= %{orbit2_version}
120Requires: compat32-glib2-devel >= %{glib2_version}
121Requires: compat32-libbonobo-devel >= %{libbonobo_version}
122Requires: compat32-GConf2-devel >= %{gconf2_version}
123Requires: compat32-gnome-vfs2-devel >= %{gnome_vfs2_version}
124Requires: compat32-libxml2-devel >= %{libxml2_version}
125Requires: compat32-libxslt-devel >= %{libxslt_version}
126Requires: compat32-popt-devel
127
128%description -n compat32-%{name}-devel
129GNOME (GNU Network Object Model Environment) is a user-friendly set of
130GUI applications and desktop tools to be used in conjunction with a
131window manager for the X Window System. The libgnome-devel package
132includes the libraries and include files that you will need to
133use libgnome.
134
135You should install the libgnome-devel package if you would like to
136compile GNOME applications. You do not need to install libgnome-devel
137if you just want to use the GNOME desktop environment.
138
139%prep
140%setup -q
141
142%patch0 -p1 -b .default-theme
143%patch1 -p1 -b .default-background
144%patch2 -p1 -b .default-cursor
145%patch3 -p1 -b .scoreloc
146%patch5 -p1 -b .default-browser
147%patch6 -p1 -b .default-settings
148%patch7 -p1 -b .popt
149
150#patch10 -p1 -b .i18n-help
151
152%build
153%configure --disable-gtk-doc --disable-schemas-install --disable-static --disable-esd
154./config.status
155export tagname=CC
156make %{?_smp_mflags} LIBTOOL=%{_bindir}/libtool
157
158%install
159rm -rf $RPM_BUILD_ROOT
160export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
161export tagname=CC
162%makeinstall LIBTOOL=%{_bindir}/libtool
163unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
164
165rm $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
166rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/monikers/*.{a,la}
167
168for serverfile in $RPM_BUILD_ROOT%{_libdir}/bonobo/servers/*.server; do
169    sed -i -e 's|location *= *"/usr/lib\(64\)*/|location="/usr/$LIB/|' $serverfile
170done
171
172mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/skel/.gnome2
173
174# http://bugzilla.gnome.org/show_bug.cgi?id=477846
175rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome-background-properties
176rm -rf $RPM_BUILD_ROOT%{_datadir}/pixmaps
177
178%find_lang %{po_package}
179
180%clean
181rm -rf $RPM_BUILD_ROOT
182
183%post
184/sbin/ldconfig
185export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
186gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/desktop_gnome_*.schemas > /dev/null 2>&1 || :
187
188%pre
189if [ "$1" -gt 1 ]; then
190  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
191  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/desktop_gnome_*.schemas > /dev/null || :
192fi
193
194%preun
195if [ "$1" -eq 0 ]; then
196  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
197  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/desktop_gnome_*.schemas > /dev/null || :
198fi
199
200%postun -p /sbin/ldconfig
201
202%post -n compat32-%{name} -p /sbin/ldconfig
203
204%postun -n compat32-%{name} -p /sbin/ldconfig
205
206%files -f %{po_package}.lang
207%defattr(-,root,root)
208%doc AUTHORS COPYING.LIB ChangeLog NEWS README
209%{_bindir}/*
210%{_libdir}/lib*.so.*
211%{_libdir}/bonobo/*
212%{_sysconfdir}/gconf/schemas/*
213%{_sysconfdir}/sound
214%{_sysconfdir}/skel/.gnome2
215%{_mandir}/man?/*
216#{_datadir}/gnome-background-properties
217#{_datadir}/pixmaps/backgrounds/gnome/*
218
219%files devel
220%defattr(-,root,root)
221%{_libdir}/lib*.so
222%{_libdir}/pkgconfig/*.pc
223%{_includedir}/*
224%{_datadir}/gtk-doc/html/*
225
226# compat32
227%if %{build_compat32}
228%files -n compat32-%{name}
229%defattr(-,root,root)
230%{_libdir}/lib*.so.*
231%{_libdir}/bonobo/*
232
233%files -n compat32-%{name}-devel
234%defattr(-,root,root)
235%{_libdir}/lib*.so
236%{_libdir}/pkgconfig/*.pc
237%endif
238
239%changelog
240* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
241- new upstream release
242
243* Sun Jul 12 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.0-4
244- added compat32 package for x86_64 arch support
245
246* Tue May 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
247- add Requires: popt-devel to -devel
248
249* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
250- update Patch1 to set "zoom" for picture_options instead of "stretched"
251
252* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
253- new upstream release
254- disable static libs
255
256* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
257- new upstream release
258
259* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
260- new upstream release
261
262* Wed Apr  2 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-2vl5
263- added Patch6, dropped Patch10
264
265* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
266- new upstream release
267- dropped Patch6 (was merged into new upstream)
268
269* Tue Dec 11 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1.1-0vl1
270- new upstream release
271- updated Patch0 and 1
272
273* Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
274- new upstream release
275
276* Wed Feb  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl3
277- remove bonobo-activation-devel dependancy <BTS:464>
278
279* Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
280- add bindtextdomain/bindtextdomain_codeset before initilize help
281  options to fix corruption of help option message.
282
283* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
284- new upstream release
285
286* Mon Mar 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.90-0vl1
287- new upstream release
288
289* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0.1-0vl1
290- new upstream release
291
292* Sun Aug 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.3-0vl1
293- new upstream release
294
295* Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.2-0vl1
296- new upstream release
297
298* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.1-0vl1
299- new upstream release
300
301* Mon Jul 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
302- new upstream release
303
304* Mon Mar 28 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.0-0vl2
305- patch100 disabled (no va_list problem on current gcc)
306
307* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
308- new upstream version
309
310* Sun Mar 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl5
311- change default {icons,cursor,gtk} theme to Vine.
312
313* Sun Mar 06 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.1-0vl4
314- added patch100 for ppc
315- (FYI: Inagaki-san's 2.8.1-0vl1 was actually 0vl3)
316
317* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-0vl1
318- new upstream release
319
320* Thu Nov 11 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.0-0vl3
321- gnome_vfs2_version macro set to 2.5.3
322
323* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl2
324- update Vine default patches for gnome-2.8
325
326* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
327- new upstream release
328
329* Tue Mar  9 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
330- change default wallpaper to default.jpg
331- add Requires: vine-backgrouonds >= 2.0
332
333* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
334- fix default-theme patch
335
336* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
337- new upstream release
338
339* Tue Aug 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
340- new upstream release
341
342* Wed Jun 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl2
343- update patch0 to use NeoVine as default gtk theme
344
345* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
346- new upstream release
347
348* Tue Jun 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
349- new upstream release
350
351* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
352- new upstream release
353
354* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
355- new upstream release
356
357* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90-0vl1
358- new upstream release
359
360* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
361- new upstream release
362
363* Sat Dec 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
364- build for Vine Linux
365- new upstream release (gnome-2.1.4)
366
367* Wed Aug 28 2002 Matt Wilson <msw@redhat.com> 2.0.2-5
368- added libgnome-2.0.2-program-init.patch to enable correct module
369  initialization when gnome_program_init is called after
370  gnome_program_module_register
371
372* Wed Aug 21 2002 Elliot Lee <sopwith@redhat.com> 2.0.2-4
373- Fix #64908 with patch3 (scoreloc)
374- Add smp_mflags
375
376* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
377- s/Wonderland/Bluecurve/
378
379* Thu Aug  8 2002 Havoc Pennington <hp@redhat.com>
380- change default background to new spec from garrett
381
382* Wed Aug  7 2002 Havoc Pennington <hp@redhat.com>
383- 2.0.2
384
385* Wed Jul 24 2002 Owen Taylor <otaylor@redhat.com>
386- Add schema for monospaced font
387
388* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
389- Fix find_lang
390
391* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
392- 2.0.1
393- put bonobo monikers in file list (don't know what they
394  do, but assuming they do something)
395- include /etc/sound in file list
396
397* Mon Jun 10 2002 Havoc Pennington <hp@redhat.com>
398- rebuild in different environment
399
400* Mon Jun 10 2002 Havoc Pennington <hp@redhat.com>
401- change default gtk theme to Wonderland
402
403* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
404- rebuild in different environment
405
406* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
407- 1.117.2
408- add ldconfig calls
409
410* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
411- rebuild in different environment
412
413* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
414- rebuild in different environment
415- add bonobo-activation build requires
416
417* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
418- 1.117.1
419
420* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
421- 1.116.0
422
423* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
424- 1.114.0
425
426* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
427- 1.111.0
428
429* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
430- Version 1.110.0
431
432* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
433- remove bogus dependency on libdb1
434
435* Thu Jan  3 2002 Havoc Pennington <hp@redhat.com>
436- fix the post script
437
438* Thu Jan  3 2002 Havoc Pennington <hp@redhat.com>
439- 1.108.0.90 cvs snap
440
441* Tue Nov 27 2001 Havoc Pennington <hp@redhat.com>
442- fix .schemas in post
443
444* Tue Nov 27 2001 Havoc Pennington <hp@redhat.com>
445- update CVS snap to 1.107.0.90, glib 1.3.11
446- add libxslt dep
447- require specific versions of dependent libs
448- add bunch of missing stuff to file list
449- install gconf schemas in post
450
451* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
452- well, you only get the new CVS snap if you actually change the version in the spec file, doh
453
454* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
455- new cvs snap, rebuild for glib 1.3.10, remove gtk requires
456
457* Fri Sep 21 2001 Havoc Pennington <hp@redhat.com>
458- new CVS snap, rebuild in 7.2-gnome
459
460* Tue Sep 18 2001 Havoc Pennington <hp@redhat.com>
461- Initial build.
462- remove gtk2 dependency, doh
Note: See TracBrowser for help on using the repository browser.