source: projects/specs/trunk/lib/libg/libgnome-keyring/libgnome-keyring-vl.spec @ 7938

Revision 7938, 5.1 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.10.1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define glib2_version 2.38.0
4%define dbus_version 1.6.14
5%define eggdbus_version 0.6
6%define gcrypt_version 1.4.6
7
8Summary: Framework for managing passwords and other secrets
9Name: libgnome-keyring
10Version: 3.10.1
11Release: 1%{?_dist_release}
12License: GPLv2+ and LGPLv2+
13Group: System Environment/Libraries
14Source: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.10/%{name}-%{version}.tar.xz
15URL: http://live.gnome.org/GnomeKeyring
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18BuildRequires: glib2-devel >= %{glib2_version}
19BuildRequires: dbus-devel >= %{dbus_version}
20BuildRequires: eggdbus-devel >= %{eggdbus_version}
21BuildRequires: libgcrypt-devel >= %{gcrypt_version}
22BuildRequires: gobject-introspection-devel
23BuildRequires: intltool
24Conflicts: gnome-keyring < 2.29.4
25
26
27%description
28gnome-keyring is a program that keep password and other secrets for
29users. The library libgnome-keyring is used by applications to integrate
30with the gnome-keyring system.
31
32%package devel
33Summary: Development files for libgnome-keyring
34License: LGPLv2+
35Group: Development/Libraries
36Requires: %{name} = %{version}-%{release}
37Requires: glib2-devel
38Requires: pkgconfig
39Requires: gtk-doc
40Conflicts: gnome-keyring-devel < 2.29.4
41
42%description devel
43The libgnome-keyring-devel package contains the libraries and
44header files needed to develop applications that use libgnome-keyring.
45
46
47# compat32
48%package -n compat32-%{name}
49Summary: Framework for managing passwords and other secrets
50Group: System Environment/Libraries
51Requires: %{name} = %{version}-%{release}
52
53%description -n compat32-%{name}
54gnome-keyring is a program that keep password and other secrets for
55users. The library libgnome-keyring is used by applications to integrate
56with the gnome-keyring system.
57
58
59%package -n compat32-%{name}-devel
60Summary: Development files for libgnome-keyring
61License: LGPLv2+
62Group: Development/Libraries
63Requires: compat32-%{name} = %{version}-%{release}
64Requires: compat32-glib2-devel
65Conflicts: compat32-gnome-keyring-devel < 2.29.4
66
67%description -n compat32-%{name}-devel
68The libgnome-keyring-devel package contains the libraries and
69header files needed to develop applications that use libgnome-keyring.
70
71
72%prep
73%setup -q -n libgnome-keyring-%{version}
74
75%build
76%configure \
77        --disable-gtk-doc \
78        --enable-introspection
79
80
81make %{?_smp_mflags}
82
83%install
84rm -rf $RPM_BUILD_ROOT
85make install DESTDIR=$RPM_BUILD_ROOT
86rm $RPM_BUILD_ROOT%{_libdir}/*.la
87
88%find_lang libgnome-keyring
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93
94%post -p /sbin/ldconfig
95
96%postun -p /sbin/ldconfig
97
98%post -n compat32-%{name} -p /sbin/ldconfig
99
100%postun -n compat32-%{name} -p /sbin/ldconfig
101
102
103%files -f libgnome-keyring.lang
104%defattr(-, root, root, -)
105%doc AUTHORS NEWS README COPYING HACKING
106%{_libdir}/lib*.so.*
107%{_libdir}/girepository-1.0/GnomeKeyring-1.0.typelib
108
109%files devel
110%defattr(-, root, root, -)
111%{_libdir}/lib*.so
112%{_libdir}/pkgconfig/*
113%{_includedir}/*
114%{_datadir}/gir-1.0/GnomeKeyring-1.0.gir
115%doc %{_datadir}/gtk-doc/html/gnome-keyring/
116
117# compat32
118%if %{build_compat32}
119%files -n compat32-%{name}
120%defattr(-, root, root, -)
121%{_libdir}/lib*.so.*
122
123%files -n compat32-%{name}-devel
124%defattr(-, root, root, -)
125%{_libdir}/lib*.so
126%endif
127
128%changelog
129* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 3.10.1-1
130- new upstream release
131
132* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 3.8.0-1
133- new upstream release
134- add BuildRequires: gobject-introspection-devel
135
136* Thu Sep 27 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 3.6.0-1
137- new upstream release
138
139* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 3.4.1-1
140- new upstream release
141
142* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 3.2.0-1
143- new upstream release
144
145* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 3.1.92-1
146- new upstream release
147
148* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 3.1.90-1
149- new upstream release
150
151* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 3.1.4-1
152- new upstream release
153
154* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.32.0-1
155- new upstream release
156
157* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.1-2
158- build with rpm-4.8.1-1 for pkg-config file
159
160* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.30.1-1
161- new upstream release
162
163* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.30.0-1
164- initial build for Vine Linux
165
166
167* Mon Mar 22 2010 Tomas Bzatek <tbzatek@redhat.com> - 2.29.92-git20100322.1
168- Update to a new git snapshot
169
170* Wed Mar 17 2010 Tomas Bzatek <tbzatek@redhat.com> - 2.29.92-git20100317.1
171- Update to 2.29.92 git snapshot
172
173* Wed Feb 17 2010 Tomas Bzatek <tbzatek@redhat.com> - 2.29.4-4
174- When no password is found, return GNOME_KEYRING_RESULT_NO_MATCH
175
176* Tue Feb 16 2010 Tomas Bzatek <tbzatek@redhat.com> - 2.29.4-3
177- Fix assertion when password is not found
178
179* Mon Jan 25 2010 Tomas Bzatek <tbzatek@redhat.com> - 2.29.4-2
180- Fix assertion calling deprecated acl function
181- Clear the client's session when the service disconnects
182- Implement setting of Type property in gnome_keyring_item_set_info()
183
184* Thu Jan  7 2010 Tomas Bzatek <tbzatek@redhat.com> - 2.29.4-1
185- Initial packaging
Note: See TracBrowser for help on using the repository browser.