source: projects/specs/trunk/lib/libg/libglade/libglade-vl.spec @ 521

Revision 521, 4.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# Note that this is NOT a relocatable package
2%define name    libglade
3%define ver     0.17
4%define rel     15%{?_dist_release}
5
6Summary:        libglade library
7Summary(ja):    libglade ライブラリ
8Name:           %{name}
9Version:        %{ver}
10Release:        %{rel}
11License:        LGPL
12Group:          System Environment/Libraries
13URL:            http://www.gnome.org
14Source:         ftp://ftp.gnome.org/pub/GNOME/stable/sources/%{name}/%{name}-%{ver}.tar.gz
15Patch0:         libglade-0.16-fixquote.patch
16Patch1:         libglade-0.17-gtkdoc.patch
17Patch2:         libglade-0.17-clist-gettext.patch
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20BuildRequires:  libxml-devel >= 1.8.16
21BuildRequires:  gnome-libs-devel >= 1.4.2-2vl5
22Requires:       libxml >= 1.8.16
23Requires:       gnome-libs >= 1.4.2-2vl5
24
25%description
26This library allows you to load user interfaces in your program, which are
27stored externally.  This allows alteration of the interface without
28recompilation of the program.
29
30The interfaces can also be edited with GLADE.
31
32%description -l ja
33このライブラリを使うと、外部に格納されたユーザインタフェースを
34プログラムに読み込むことができます。これによりプログラムを
35再コンパイルすることなくインタフェースの見た目を変えることが
36可能になります。
37
38このインタフェースは GLADE を使って編集することができます。
39
40%package devel
41Summary:        Libraries, includes, etc to develop libglade applications
42Summary(ja):    libglade アプリケーション開発の為のライブラリ/ヘッダ等
43Group:          Development/Libraries
44Requires:       %{name} = %{version}-%{release}
45Requires:       libxml-devel >= 1.8.16
46Requires:       gnome-libs-devel >= 1.4.2-2vl5
47
48
49%description devel
50Libraries, include files, etc you can use to develop libglade applications.
51
52%description devel -l ja
53libglade アプリケーションを開発するのに必要なライブラリ/ヘッダファイル等
54
55
56%prep
57%setup -q
58%patch0 -p1 -b .fixquote
59%patch1 -p1 -b .gtkdoc
60%patch2 -p1 -b .clist-gettext
61
62%build
63autoconf
64%configure --without-bonobo --disable-static
65make %{?_smp_mflags}
66
67
68%install
69[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
70
71%makeinstall
72
73# remove unpackaged files from the buildroot
74rm -f $RPM_BUILD_ROOT%{_libdir}/{libglade-gnome.la,libglade.la}
75
76%clean
77[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
78
79%post -p /sbin/ldconfig
80
81%postun -p /sbin/ldconfig
82
83
84%files
85%defattr(-, root, root)
86%doc AUTHORS ChangeLog NEWS README COPYING
87%{_libdir}/lib*.so.*
88
89%files devel
90%defattr(-, root, root)
91%{_bindir}/*
92%{_libdir}/lib*.so
93#{_libdir}/*a
94%{_libdir}/*Conf.sh
95%{_libdir}/pkgconfig/*.pc
96%{_includedir}/*
97%{_datadir}/aclocal/*
98
99%doc test-libglade.c
100%doc *.glade
101%doc %{_datadir}/gnome/html/libglade/*
102
103
104%changelog
105* Fri Feb 12 2010 NAKAMURA Kenta <kenta@vinelinux.org> 0.17-15
106- rebuilt with db4-4.8
107
108* Sat May  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-14
109- rebuilt with gnome-libs-1.4.2-2vl5 (linking db-4.6.21)
110- removed lib*.a files
111
112* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.17-13vl5
113- applied new versioning policy and spec in utf-8
114
115* Sun May 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-12vl3
116- rebuilt with db4-4.3.29
117
118* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.17-12vl2
119- rebuilt with db4-4.2.52
120
121* Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.17-12vl1
122- based on Fedora 0.17-12.2
123  * Wed Jun 19 2002 Jeremy Katz <katzj@redhat.com>
124  - remove .la files
125  * Tue Apr 16 2002 Havoc Pennington <hp@redhat.com>
126  - patch from Harald to call gettext on clist column titles, #63338
127  * Tue Mar  5 2002 Havoc Pennington <hp@redhat.com>
128  - install .pc files, #59522
129  - fix more prefix/lib->libdir sort of things
130  - use autoconf-2.52 binary- s/Copyright/License/
131- rebuild with new toolchains
132
133* Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.17-0vl2
134- rebuilt against gnome-libs-1.4.2-0vl2 (for db1/db4 matters)
135
136* Tue Dec 18 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.17-0vl1
137- New upstream release.
138
139* Tue Mar 13 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.16-0vl1
140- New upstream release.
141- Added relative execute for config.
142
143* Wed Jan 24 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
144- corrected Group
145
146* Wed Sep 06 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
147- 0.14-0vl1
148- updated to 0.14
149- added Japanese summary and description
150
151* Sun Nov  1 1998 James Henstridge <james@daa.com.au>
152- Updated the dependencies of the devel package, so users must have gtk+-devel.
153
154* Sun Oct 25 1998 James Henstridge <james@daa.com.au>
155- Initial release 0.0.1
Note: See TracBrowser for help on using the repository browser.