source: projects/specs/trunk/lib/libg/libgit2/libgit2-vl.spec @ 12054

Revision 12054, 2.7 KB checked in by ara_t, 5 years ago (diff)

libgit2: correct date

Line 
1Summary:  C implementation of the Git core methods as a library with a solid API
2Name:    libgit2
3Version: 0.27.8
4Release: 2%{?_dist_release}
5License: GPLv2
6Group:   System Environment/Libraries
7URL:     https://libgit2.github.com/
8
9# https://github.com/libgit2/libgit2/archive/v0.23.3.tar.gz
10Source0:  %{name}-%{version}.tar.gz
11
12BuildRequires: cmake
13BuildRequires: openssl-devel
14BuildRequires: http-parser-devel
15BuildRequires: curl-devel
16BuildRequires: libssh2-devel
17BuildRequires: zlib-devel
18
19BuildRoot:  %{_tmppath}/%{name}-%{version}-root
20
21Vendor:   Project Vine
22Distribution: Vine Linux
23Packager: Takemikaduchi
24
25%description
26libgit2 is a portable, pure C implementation of the Git core methods
27provided as a re-entrant linkable library with a solid API, allowing
28you to write native speed custom Git applications in any language
29which supports C bindings.
30
31
32%package        devel
33Summary:        Development tools for %{name}
34Summary(ja):    %{name} の開発環境
35Group:          Development/Libraries
36Requires:       %{name} = %{version}-%{release}
37Requires:       pkgconfig
38Requires:       openssl-devel
39Requires:       http-parser-devel
40Requires:       libssh2-devel
41Requires:       zlib-devel
42
43%description    devel
44Header files and libraries for building a extension library for the %{name}.
45
46
47%prep
48%setup -q
49
50%build
51rm -rf build && mkdir build && pushd build
52%cmake -DINSTALL_DOCS=OFF \
53    ../
54
55make %{?_smp_mflags}
56popd
57
58
59%install
60rm -rf ${RPM_BUILD_ROOT}
61pushd build
62make install DESTDIR=${RPM_BUILD_ROOT}
63popd
64
65find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
66find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
67
68
69%clean
70%{__rm} -rf ${RPM_BUILD_ROOT}
71
72%post -p /sbin/ldconfig
73
74%postun -p /sbin/ldconfig
75
76
77%files
78%defattr(-,root,root,-)
79%doc COPYING CHANGELOG.md README.md
80%{_libdir}/%{name}.so.*
81
82%files devel
83%defattr(-,root,root,-)
84%{_includedir}/git2/
85%{_includedir}/git2.h
86%{_libdir}/%{name}.so
87%{_libdir}/pkgconfig/%{name}.pc
88
89
90%changelog
91* Mon Mar 25 2019 Toshiaki Ara <ara_t@384.jp> 0.27.8-2
92- correct date
93
94* Mon Mar 25 2019 Toshiaki Ara <ara_t@384.jp> 0.27.8-1
95- update to 0.27.8
96- add BuildRequires: curl-devel
97
98* Thu Nov 01 2018 Toshiaki Ara <ara_t@384.jp> 0.27.4-2
99- rebuild with openssl-1.1.1
100
101* Mon Aug 20 2018 Toshiaki Ara <ara_t@384.jp> 0.27.4-1
102- new upstream release
103
104* Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.24.1-1
105- new upstream release
106
107* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.23.3-1
108- new upstream release
109
110* Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.2-2
111- add BuildRequires: openssl-devel, http-parser-devel, libssh2-devel, zlib-devel
112
113* Wed Apr 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.2-1
114- initial build
115
Note: See TracBrowser for help on using the repository browser.