source: projects/specs/trunk/lib/libg/libgit2/libgit2-vl.spec @ 9791

Revision 9791, 2.2 KB checked in by Takemikaduchi, 9 years ago (diff)

GNOME 3.18.1, BlueZ 5.35, ICU 56.1, Mesa 11.0.4, PulseAudio 7.1, xserver 1.17.4, etc.

Line 
1Summary:        C implementation of the Git core methods as a library with a solid API
2Name:           libgit2
3Version:        0.23.3
4Release:        1%{?_dist_release}
5License:        GPLv2
6Group:          System Environment/Libraries
7URL:            https://libgit2.github.com/
8
9# https://github.com/libgit2/libgit2/archive/v0.23.3.tar.gz
10Source0:        %{name}-%{version}.tar.gz
11
12BuildRequires: cmake
13BuildRequires: openssl-devel
14BuildRequires: http-parser-devel
15BuildRequires: libssh2-devel
16BuildRequires: zlib-devel
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19
20Vendor:         Project Vine
21Distribution:   Vine Linux
22Packager:       Takemikaduchi
23
24%description
25libgit2 is a portable, pure C implementation of the Git core methods
26provided as a re-entrant linkable library with a solid API, allowing
27you to write native speed custom Git applications in any language
28which supports C bindings.
29
30
31%package        devel
32Summary:        Development tools for %{name}
33Summary(ja):    %{name} の開発環境
34Group:          Development/Libraries
35Requires:       %{name} = %{version}-%{release}
36Requires:       pkgconfig
37Requires:       openssl-devel
38Requires:       http-parser-devel
39Requires:       libssh2-devel
40Requires:       zlib-devel
41
42%description    devel
43Header files and libraries for building a extension library for the %{name}.
44
45
46%prep
47%setup -q
48
49
50%build
51rm -rf build && mkdir build && pushd build
52%cmake -DINSTALL_DOCS=OFF \
53                ../
54
55make %{?_smp_mflags}
56popd
57
58
59%install
60rm -rf ${RPM_BUILD_ROOT}
61pushd build
62make install DESTDIR=${RPM_BUILD_ROOT}
63popd
64
65find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
66find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
67
68
69%clean
70%{__rm} -rf ${RPM_BUILD_ROOT}
71
72%post -p /sbin/ldconfig
73
74%postun -p /sbin/ldconfig
75
76
77%files
78%defattr(-,root,root,-)
79%doc COPYING CHANGELOG.md README.md
80%{_libdir}/%{name}.so.*
81
82%files devel
83%defattr(-,root,root,-)
84%{_includedir}/git2/
85%{_includedir}/git2.h
86%{_libdir}/%{name}.so
87%{_libdir}/pkgconfig/%{name}.pc
88
89
90%changelog
91* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.23.3-1
92- new upstream release
93
94* Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.2-2
95- add BuildRequires: openssl-devel, http-parser-devel, libssh2-devel, zlib-devel
96
97* Wed Apr 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.2-1
98- initial build
99
Note: See TracBrowser for help on using the repository browser.