source: projects/specs/trunk/lib/libg/libghc-old-locale/libghc-old-locale-vl.spec @ 11988

Revision 11988, 1.8 KB checked in by ara_t, 5 years ago (diff)

libghc-*: (re)build with ghc-8.6.3

Line 
1%define pkg_name    old-locale
2%define pkg_version 1.0.0.7
3%define pkg_release 4%{?_dist_release}
4
5Summary: Haskell libraries: %{pkg_name}
6Name:    libghc-%{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: BSD3
11Group:   Applications/Text
12URL:     http://hackage.haskell.org
13
14Source0: packages
15
16Source11: old-locale-1.0.0.7.tar.gz
17Source12: old-locale.cabal
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20
21BuildRequires: ghc haskell-platform
22BuildRequires: libffi-devel gmp-devel zlib-devel
23BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
24
25Requires: ghc haskell-platform
26Requires: haskell-platform-dep
27
28
29Vendor: Project Vine
30Distribution: Vine Linux
31Packager: ara_t
32
33
34%description
35Haskell libraries: %{pkg_name}-%{version}
36
37
38%prep
39%{__rm} -rf ${RPM_BUILD_ROOT}
40
41%build
42%ghc_pkg_init
43
44cd %{_builddir}
45for pkg in `cat %{SOURCE0}`; do
46    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
47    pushd ${pkg}
48        %ghc_fix_dependencies ${pkg}
49        %cabal_configure2 %{name} ${pkg}
50        %cabal_build
51        %cabal_haddock
52        %cabal_copy_resister %{name}_${pkg}
53    popd
54done
55
56
57%install
58# copy documents
59pushd %{_builddir}/%{pkg_name}-%{version}
60    %{__cp} changelog.md \
61     ${RPM_BUILD_ROOT}%{_docdir}/%{name}/%{pkg_name}-%{version}
62popd
63
64
65%clean
66%{__rm} -rf ${RPM_BUILD_ROOT}
67
68%post
69%ghc_pkg_recache
70
71%postun
72%ghc_pkg_recache
73
74
75%files
76%defattr(-, root, root)
77%{_libdir}/ghc-%{ghc_version}/
78%{_libdir}/ghc-lib/
79%{_datadir}/
80
81
82%changelog
83* Mon Dec 17 2018 Toshiaki Ara <ara_t@384.jp> 1.0.0.7-4
84- rebuild with ghc-8.6.3-1
85
86* Wed Aug 08 2018 Toshiaki Ara <ara_t@384.jp> 1.0.0.7-3
87- rebuild with ghc-8.4.3-2
88
89* Fri Jul 20 2018 Toshiaki Ara <ara_t@384.jp> 1.0.0.7-2
90- build using ghc-8.4.3
91
92* Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 1.0.0.7-1
93- new package
Note: See TracBrowser for help on using the repository browser.