source: projects/specs/trunk/lib/libg/libghc-haddock-library/libghc-haddock-library.spec @ 11761

Revision 11761, 2.0 KB checked in by ara_t, 6 years ago (diff)

libghc*: rebuild with ghc-8.4.3-2

Line 
1%define pkg_name    haddock-library
2%define pkg_version 1.6.0
3%define pkg_release 2%{?_dist_release}
4
5Summary: Haskell libraries: %{pkg_name}
6Name:    libghc-%{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: BSD3
11Group:   Applications/Text
12URL:     http://hackage.haskell.org
13
14Source0: packages
15
16Source11: haddock-library-1.6.0.tar.gz
17Source12: haddock-library.cabal
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20
21BuildRequires: ghc haskell-platform
22BuildRequires: libffi-devel gmp-devel zlib-devel
23BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
24
25Requires: ghc haskell-platform
26Requires: haskell-platform-dep
27
28
29Vendor: Project Vine
30Distribution: Vine Linux
31Packager: ara_t
32
33
34%description
35Haskell libraries: %{pkg_name}-%{version}
36
37
38%prep
39%{__rm} -rf ${RPM_BUILD_ROOT}
40
41%build
42%ghc_pkg_init
43
44cd %{_builddir}
45for pkg in `cat %{SOURCE0}`; do
46    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
47    pushd ${pkg}
48        %ghc_fix_dependencies ${pkg}
49        %cabal_configure1 ${pkg}
50        %cabal_build
51        %cabal_haddock
52        %cabal_copy_resister ${pkg}
53    popd
54done
55
56
57%install
58# move conf files to correct site
59pushd ${RPM_BUILD_ROOT}/%{_libdir}/ghc-%{ghc_version}/package.conf.d
60    %{__mv} %{pkg_name}-%{version}.conf/* .
61    for conf in *-%{pkg_name}-%{version}-*; do
62        %{__mv} ${conf} `echo ${conf} | sed -e "s/[0-9.]\+-//"`.conf
63    done
64    %{__rm} -rf %{pkg_name}-%{version}.conf
65popd
66
67# copy documents
68pushd %{_builddir}/%{pkg_name}-%{version}
69    %{__cp} CHANGES.md \
70     ${RPM_BUILD_ROOT}%{_docdir}/%{pkg_name}-%{version}
71popd
72
73
74%clean
75%{__rm} -rf ${RPM_BUILD_ROOT}
76
77%post
78%ghc_pkg_recache
79
80%postun
81%ghc_pkg_recache
82
83
84%files
85%defattr(-, root, root)
86%{_libdir}/ghc-%{ghc_version}/
87%{_libdir}/ghc-lib/
88%{_datadir}/
89
90
91%changelog
92* Wed Aug 08 2018 Toshiaki Ara <ara_t@384.jp> 1.6.0-2
93- rebuild with ghc-8.4.3-2
94
95* Sat Jul 21 2018 Toshiaki Ara <ara_t@384.jp> 1.6.0-1
96- update to 1.6.0
97- build using ghc-8.4.3
98
99* Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 1.5.0.1-1
100- new package
101
Note: See TracBrowser for help on using the repository browser.