source: projects/specs/trunk/lib/libg/libghc-build-pandoc/libghc-build-pandoc-vl.spec @ 11636

Revision 11636, 4.2 KB checked in by ara_t, 6 years ago (diff)

libghc-build-pandoc: correct dependencies

Line 
1%define pkg_name    build-pandoc
2%define pkg_version 2.2.1
3%define pkg_release 2%{?_dist_release}
4
5Summary: Haskell libraries: %{pkg_name} and dependent libraries
6Name:    libghc-%{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: BSD3
11Group:   Applications/Text
12URL:     http://hackage.haskell.org
13
14Source0: packages
15
16Source11: Glob-0.9.2.tar.gz
17Source12: Glob.cabal
18Source13: JuicyPixels-3.2.9.5.tar.gz
19Source14: JuicyPixels.cabal
20Source15: SHA-1.6.4.4.tar.gz
21Source16: SHA.cabal
22Source17: base64-bytestring-1.0.0.1.tar.gz
23Source18: base64-bytestring.cabal
24Source19: blaze-markup-0.8.2.1.tar.gz
25Source20: blaze-markup.cabal
26Source21: cmark-gfm-0.1.3.tar.gz
27Source22: cmark-gfm.cabal
28Source23: cmdargs-0.10.20.tar.gz
29Source24: cmdargs.cabal
30Source25: colour-2.3.4.tar.gz
31Source26: colour.cabal
32Source27: digest-0.0.1.2.tar.gz
33Source28: digest.cabal
34Source29: fail-4.9.0.0.tar.gz
35Source30: fail.cabal
36Source31: hxt-charproperties-9.2.0.1.tar.gz
37Source32: hxt-charproperties.cabal
38Source33: old-time-1.1.0.3.tar.gz
39Source34: old-time.cabal
40Source35: pandoc-types-1.17.4.2.tar.gz
41Source36: pandoc-types.cabal
42Source37: regex-pcre-builtin-0.94.4.8.8.35.tar.gz
43Source38: regex-pcre-builtin.cabal
44Source39: safe-0.3.17.tar.gz
45Source40: safe.cabal
46Source41: tagsoup-0.14.6.tar.gz
47Source42: tagsoup.cabal
48Source43: temporary-1.3.tar.gz
49Source44: temporary.cabal
50Source45: utf8-string-1.0.1.1.tar.gz
51Source46: utf8-string.cabal
52Source47: xml-1.3.14.tar.gz
53Source48: xml.cabal
54Source49: blaze-html-0.9.0.1.tar.gz
55Source50: blaze-html.cabal
56Source51: aeson-pretty-0.8.7.tar.gz
57Source52: aeson-pretty.cabal
58Source53: ansi-terminal-0.8.0.4.tar.gz
59Source54: ansi-terminal.cabal
60Source55: hslua-0.9.5.2.tar.gz
61Source56: hslua.cabal
62Source57: hxt-unicode-9.0.2.4.tar.gz
63Source58: hxt-unicode.cabal
64Source59: hxt-regex-xmlschema-9.2.0.3.tar.gz
65Source60: hxt-regex-xmlschema.cabal
66Source61: zip-archive-0.3.2.4.tar.gz
67Source62: zip-archive.cabal
68Source63: texmath-0.11.tar.gz
69Source64: texmath.cabal
70Source65: doctemplates-0.2.2.1.tar.gz
71Source66: doctemplates.cabal
72Source67: hslua-module-text-0.1.2.1.tar.gz
73Source68: hslua-module-text.cabal
74Source69: hxt-9.3.1.16.tar.gz
75Source70: hxt.cabal
76Source71: skylighting-core-0.7.1.tar.gz
77Source72: skylighting-core.cabal
78Source73: skylighting-0.7.1.tar.gz
79Source74: skylighting.cabal
80
81BuildRequires: ghc haskell-platform
82BuildRequires: libghc-data-default-class
83BuildRequires: libghc-dlist
84BuildRequires: libghc-old-locale
85BuildRequires: libghc-data-default
86BuildRequires: libghc-aeson
87BuildRequires: libghc-semigroups
88BuildRequires: yaml
89BuildRequires: libghc-http-client-tls
90BuildRequires: libghc-haddock-library
91
92BuildRequires: zlib-devel
93BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
94
95Requires: ghc haskell-platform
96Requires: haskell-platform-dep
97Requires: libghc-data-default-class
98Requires: libghc-dlist
99Requires: libghc-old-locale
100Requires: libghc-data-default
101Requires: libghc-aeson
102Requires: libghc-semigroups
103Requires: yaml
104Requires: libghc-http-client-tls
105Requires: libghc-haddock-library
106
107Vendor: Project Vine
108Distribution: Vine Linux
109Packager: ara_t
110
111
112%description
113Haskell libraries: %{pkg_name}
114
115
116%build
117%ghc_pkg_init
118
119cd %{_builddir}
120for pkg in `cat %{SOURCE0}`; do
121    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
122    pushd ${pkg}
123        %ghc_fix_dependencies ${pkg}
124        %cabal_configure2 %{name} ${pkg}
125        %cabal_build
126        %cabal_haddock
127        %cabal_copy_resister %{name}_${pkg}
128    popd
129done
130
131
132%clean
133%{__rm} -rf ${RPM_BUILD_ROOT}
134
135%post
136%ghc_pkg_recache
137
138%postun
139%ghc_pkg_recache
140
141
142%files
143%defattr(-, root, root)
144%{_bindir}/
145%{_libdir}/ghc-%{ghc_version}/
146%{_libdir}/ghc-lib/
147%{_datadir}/%{name}/
148%{_docdir}/%{name}/
149
150
151%changelog
152* Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 2.2.1-2
153- correct BuildRequires and Requires (add libghc-data-default)
154
155* Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 2.2.1-1
156- update to 2.2.1
157- rebuild using ghc-8.4.2
158- rewrite using macro
159
160* Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 2.0.6-1
161- update to 2.0.6
162- build using ghc-8.2.2
163
164* Tue Feb 21 2017 Toshiaki Ara <ara_t@384.jp> 1.19.2.1-1
165- update to 1.19.2.1
166- build using ghc-8.0.2
167
168* Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 1.17.1-1
169- update to 1.17.1
170- build using ghc-8.0.1
171
172* Fri May 06 2016 Toshiaki Ara <ara_t@384.jp> 1.17.0.3-1
173- new package
Note: See TracBrowser for help on using the repository browser.