source: projects/specs/trunk/lib/libg/libgda/libgda-vl.spec @ 8842

Revision 8842, 14.7 KB checked in by yasumichi, 10 years ago (diff)

rebuild with libpq-devel instead of postgresql-devel

Line 
1%define major   5
2%define minor   2
3%define micro   2
4%define version %{major}.%{minor}.%{micro}
5
6%define __libtoolize :
7# Default provider build options (MySQL, Postgres & unixODBC)
8#
9# Package build options:
10# --with tds
11# --with db2
12# --with oracle
13# --without sqlite
14# --with sybase
15# --with mdb
16# --without ldap
17# --without mysql
18# --without odbc
19# --without postgres
20#
21
22%define           FREETDS  0
23%define           IBMDB2   0
24%define           MYSQL    1
25%define           ODBC     0
26%define           ORACLE   0
27%define           POSTGRES 1
28%define           SQLITE   1
29%define           SYBASE   0
30%define           MDB      0
31%define           LDAP     0
32
33%{?_with_tds:%define FREETDS    1}
34%{?_with_db2:%define IBMDB2     1}
35%{?_without_ldap:%define LDAP   0}
36%{?_with_mdb:%define MDB        1}
37%{?_with_oracle:%define ORACLE  1}
38%{?_without_sqlite:%define SQLITE 0}
39%{?_with_sybase:%define SYBASE  1}
40%{?_without_mysql:%define MYSQL 0}
41%{?_without_odbc:%define ODBC   0}
42%{?_without_postgres:%define POSTGRES   0}
43
44%define libver  5.0
45
46Summary:        A (relatively small) database access library
47Name:           libgda
48Version:        %{version}
49Release:        2%{?_dist_release}
50Source:         %{name}-%{version}.tar.xz
51URL:            http://www.gnome-db.org/
52Group:          System Environment/Libraries
53License:        LGPL
54BuildRoot:      %{_tmppath}/%{name}-%{version}-root
55Summary(ja):    比較的小規模なデータベース接続ライブラリ
56
57Patch0:         libgda-4.2.0-disable-mdb.patch
58
59Vendor: Project Vine
60Distribution: Vine Linux
61Packager: yasumichi
62
63BuildRequires:  pkgconfig       >= 0.8
64BuildRequires:  intltool        >= 0.35.5
65BuildRequires:  glib2-devel     >= 2.12.0
66BuildRequires:  gtk3-devel
67BuildRequires:  gobject-introspection-devel
68BuildRequires:  libxml2-devel
69BuildRequires:  libxslt-devel >= 1.0.9
70BuildRequires:  db4-devel ncurses-devel
71BuildRequires:  gamin-devel >= 0.1.8
72BuildRequires:  libgcrypt-devel >= 1.1.42
73BuildRequires:  gtksourceview3-devel
74BuildRequires:  libsoup-devel
75BuildRequires:  libsecret-devel
76BuildRequires:  iso-codes
77BuildRequires:  yelp-tools
78
79%if %{FREETDS}
80BuildRequires:    freetds-devel
81%endif
82
83%if %{MYSQL}
84BuildRequires:    MySQL-devel
85%endif
86
87%if %{POSTGRES}
88BuildRequires:    libpq-devel
89%endif
90
91%if %{ODBC}
92BuildRequires:    unixODBC-devel
93%endif
94
95%if %{SQLITE}
96BuildRequires:    sqlite3-devel
97%endif
98
99%if %{MDB}
100BuildRequires:    mdbtools-devel
101%endif
102
103%if %{LDAP}
104BuildRequires:    openldap-devel
105%endif
106
107%description
108Libgda is a (relatively small) database access library:
109 - a wrapper like ODBC but with more features to access several database
110   engines
111 - a meta data extractor (to know all about database objects in a common
112   way)
113 - comes with an SQL console application (like mysql, psql or sqlite3
114   consoles)
115 - relies on GLib, coded in C, its API is easy to use
116 - at the moment supports SQLite, MySQL, PostgreSQL, MSAccess and Bdb, work
117   is in progress for other database types (such as Firebird and Oracle) and
118   to wrap JDBC for more wider usage.
119     
120Build option is:
121 --with mysql postgres sqlite
122 --without tds ibmdb2 ldap mdb odbc oracle sybase
123
124%package devel
125Summary:          Development libraries and header files for libgda.
126Group:            Development/Libraries
127Requires:         %{name} = %{version}
128Requires:         glib2-devel   >= 2.12.0
129Requires:         libxml2-devel
130Requires:         libxslt-devel >= 1.0.9
131
132%description devel
133This package contains the header files and libraries needed to write
134or compile programs that use libgda.
135
136
137#%package sharp
138#Summary:          Mono bindings for libgda
139#Group:            System Environment/Libraries
140#Requires:         %{name} = %{version}-%{release}
141#Requires:         mono-core
142#
143#%description sharp
144#This package contains the dll files needed to run (and compile) Mono
145#applications which use libgda.
146
147
148%if %{FREETDS}
149%package -n gda-freetds
150Summary:        GDA FreeTDS Provider
151Group:          System Environment/Libraries
152%description -n gda-freetds
153This package includes the GDA FreeTDS provider.
154%endif
155
156%if %{IBMDB2}
157%package -n gda-ibmdb2
158Summary:        GDA IBM DB2 Provider
159Group:          System Environment/Libraries
160%description -n gda-ibmdb2
161This package includes the GDA IBM DB2 provider.
162%endif
163
164%if %{MYSQL}
165%package -n gda-mysql
166Summary:        GDA MySQL Provider
167Group:          System Environment/Libraries
168%description -n gda-mysql
169This package includes the GDA MySQL provider.
170%endif
171
172%if %{ODBC}
173%package -n gda-odbc
174Summary:        GDA ODBC Provider
175Group:          System Environment/Libraries
176%description -n gda-odbc
177This package includes the GDA ODBC provider.
178%endif
179
180%if %{ORACLE}
181%package -n gda-oracle
182Summary:        GDA Oracle Provider
183Group:          System Environment/Libraries
184%description -n gda-oracle
185This package includes the GDA Oracle provider.
186%endif
187
188%if %{POSTGRES}
189%package -n gda-postgres
190Summary:        GDA PostgreSQL Provider
191Group:          System Environment/Libraries
192%description -n gda-postgres
193This package includes the GDA PostgreSQL provider.
194%endif
195
196%if %{SQLITE}
197%package -n gda-sqlite
198Summary:        GDA SQLite Provider
199Group:          System Environment/Libraries
200%description -n gda-sqlite
201This package includes the GDA SQLite provider.
202%endif
203
204%if %{SYBASE}
205%package -n gda-sybase
206Summary:        GDA Sybase Provider
207Group:          System Environment/Libraries
208%description -n gda-sybase
209This package includes the GDA Sybase provider.
210%endif
211
212%if %{MDB}
213%package -n gda-mdb
214Summary:        GDA MDB Provider
215Group:          System Environment/Libraries
216%description -n gda-mdb
217This package includes the GDA MDB provider.
218%endif
219
220%if %{LDAP}
221%package -n gda-ldap
222Summary:        GDA LDAP Provider
223Group:          System Environment/Libraries
224%description -n gda-ldap
225This package includes the GDA LDAP provider.
226%endif
227
228%prep
229%setup -q -n %{name}-%{version}
230%patch0 -p1 -b .mdb
231
232%build
233%if %{FREETDS}
234CONFIG="$CONFIG --with-tds"
235%else
236CONFIG="$CONFIG --without-tds"
237%endif
238
239%if %{IBMDB2}
240CONFIG="$CONFIG --with-ibmdb2"
241%else
242CONFIG="$CONFIG --without-ibmdb2"
243%endif
244
245%if %{MYSQL}
246CONFIG="$CONFIG --with-mysql"
247%else
248CONFIG="$CONFIG --without-mysql"
249%endif
250
251%if %{POSTGRES}
252CONFIG="$CONFIG --with-postgres"
253%else
254CONFIG="$CONFIG --without-postgres"
255%endif
256
257%if %{ODBC}
258CONFIG="$CONFIG --with-odbc"
259%else
260CONFIG="$CONFIG --without-odbc"
261%endif
262
263%if %{ORACLE}
264CONFIG="$CONFIG --with-oracle"
265%else
266CONFIG="$CONFIG --without-oracle"
267%endif
268
269%if %{SQLITE}
270CONFIG="$CONFIG --with-sqlite"
271%else
272CONFIG="$CONFIG --without-sqlite"
273%endif
274
275%if %{SYBASE}
276CONFIG="$CONFIG --with-sybase"
277%else
278CONFIG="$CONFIG --without-sybase"
279%endif
280
281%if %{MDB}
282CONFIG="$CONFIG --with-mdb"
283%else
284CONFIG="$CONFIG --without-mdb"
285%endif
286
287%if %{LDAP}
288CONFIG="$CONFIG --with-ldap"
289%else
290CONFIG="$CONFIG --without-ldap"
291%endif
292
293%configure $CONFIG \
294        --disable-static \
295        --enable-introspection \
296        --disable-gtk-doc \
297        --with-libdir-name=%{_lib}
298make
299
300%install
301rm -rf $RPM_BUILD_ROOT
302#makeinstall LIBGDA_DTDDIR=%{buildroot}%{_datadir}/libgda/dtd
303make install DESTDIR=$RPM_BUILD_ROOT
304
305#fixup mono / sharp related files install
306#mkdir -p %{buildroot}/%{_datadir}/gapi-2.0
307#mv %{buildroot}/%{_libdir}/libgda/gda-api.xml %{buildroot}/%{_datadir}/gapi-2.0
308#mkdir -p %{buildroot}/usr/lib/mono/gda-sharp-2.0
309#mv %{buildroot}/%{_libdir}/libgda/* %{buildroot}/usr/lib/mono/gda-sharp-2.0
310#rmdir %{buildroot}/%{_libdir}/libgda
311
312# Cleanup unnecessary, unpackaged files
313find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
314rm -f %{buildroot}/%{_sysconfdir}/libgda-%{libver}/sales_test.db
315
316%find_lang libgda-%{libver}
317
318%post -p /sbin/ldconfig
319
320%postun -p /sbin/ldconfig
321
322%clean
323rm -rf $RPM_BUILD_ROOT
324
325
326%files
327%defattr(-,root,root)
328%doc AUTHORS COPYING COPYING.LIB ChangeLog README NEWS
329%dir %{_sysconfdir}/libgda-%{libver}
330%config(noreplace) %{_sysconfdir}/libgda-%{libver}/config
331%{_bindir}/*
332%{_libdir}/*.so.*
333%{_libdir}/girepository-1.0/Gda-5.0.typelib
334
335%dir %{_libdir}/libgda-%{libver}
336%dir %{_libdir}/libgda-%{libver}/plugins
337%{_libdir}/libgda-%{libver}/plugins/*.xml
338%{_libdir}/libgda-%{libver}/plugins/libgda-ui-plugins.so
339%dir %{_libdir}/libgda-%{libver}/providers
340%{_libdir}/libgda-%{libver}/providers/libgda-bdb.so
341%{_libdir}/libgda-%{libver}/providers/libgda-sqlcipher.so
342%{_libdir}/libgda-%{libver}/providers/libgda-web.so
343
344%{_datadir}/applications/*.desktop
345%{_datadir}/icons/hicolor/*/*/*
346%{_datadir}/pixmaps/gda-browser-5.0.png
347%{_datadir}/help/*/gda-browser
348
349%dir %{_datadir}/libgda-%{libver}
350%{_datadir}/libgda-%{libver}/demo
351%{_datadir}/libgda-%{libver}/dtd
352%{_datadir}/libgda-%{libver}/gda_trml2html
353%{_datadir}/libgda-%{libver}/gda_trml2pdf
354%{_datadir}/libgda-%{libver}/icons
355%{_datadir}/libgda-%{libver}/language-specs/gda-sql.lang
356%{_datadir}/libgda-%{libver}/php
357%{_datadir}/libgda-%{libver}/pixmaps
358%{_datadir}/libgda-%{libver}/server_operation.glade
359%{_datadir}/libgda-%{libver}/ui
360%{_datadir}/libgda-%{libver}/*.xml
361%{_datadir}/libgda-%{libver}/web
362
363%{_mandir}/man1/*
364%{_datadir}/locale/*/LC_MESSAGES/*
365
366%files devel
367%defattr(-,root,root)
368%{_includedir}/libgda-%{libver}
369%{_libdir}/*.so
370%{_libdir}/pkgconfig/*
371%{_datadir}/gir-1.0/Gda-5.0.gir
372%{_datadir}/gtk-doc/html/*
373
374#files sharp
375#defattr(-,root,root)
376#{_datadir}/gapi-2.0
377#/usr/lib/mono/gda-sharp-2.0
378#{_libdir}/pkgconfig/gda-sharp-2.0.pc
379
380%if %{FREETDS}
381%files -n gda-freetds
382%{_libdir}/libgda-%{libver}/providers/libgda-freetds.so
383%endif
384
385%if %{IBMDB2}
386%files -n gda-ibmdb2
387%{_libdir}/libgda-%{libver}/providers/libgda-ibmdb2.so
388%endif
389
390%if %{MYSQL}
391%files -n gda-mysql
392%{_libdir}/libgda-%{libver}/providers/libgda-mysql.so
393%{_datadir}/libgda-%{libver}/mysql_*.xml
394%endif
395
396%if %{ODBC}
397%files -n gda-odbc
398%{_libdir}/libgda-%{libver}/providers/libgda-odbc.so
399%{_datadir}/libgda-%{libver}/odbc_*.xml
400%endif
401
402%if %{ORACLE}
403%files -n gda-oracle
404%{_libdir}/libgda-%{libver}/providers/libgda-oracle.so
405%endif
406
407%if %{POSTGRES}
408%files -n gda-postgres
409%{_libdir}/libgda-%{libver}/providers/libgda-postgres.so
410%{_datadir}/libgda-%{libver}/postgres_*.xml
411%endif
412
413%if %{SQLITE}
414%files -n gda-sqlite
415%{_libdir}/libgda-%{libver}/providers/libgda-sqlite.so
416%{_datadir}/libgda-%{libver}/sqlite_*.xml
417%endif
418
419%if %{SYBASE}
420%files -n gda-sybase
421%{_libdir}/libgda-%{libver}/providers/libgda-sybase.so
422%endif
423
424%if %{MDB}
425%files -n gda-mdb
426%{_libdir}/libgda-%{libver}/providers/libgda-mdb.so
427%endif
428
429%if %{LDAP}
430%files -n gda-ldap
431%{_libdir}/libgda-%{libver}/providers/libgda-ldap.so
432%{_datadir}/libgda-%{libver}/ldap_*.xml
433%endif
434
435
436%changelog
437* Sat Jul 19 2014 Yasumichi Akahoshi <yasumichi@vinelinux.org> 5.2.2-2
438- rebuild with libpq-devel instead of postgresql-devel
439
440* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.2.2-1
441- new upstream release
442
443* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.2.1-1
444- new upstream release
445- add BuildRequires: yelp-tools
446
447* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.1.2-1
448- new upstream release
449
450* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.1.1-1
451- new upstream release
452- add BuildRequires: gtksourceview3-devel, libsoup-devel, libsecret-devel
453- remove BuildRequires: gcr-devel
454
455* Tue Apr 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0.3-1
456- new upstream release
457- add BuildRequires: gtk3-devel, gobject-introspection-devel, gcr-devel, iso-codes
458
459* Wed Dec 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.12-1
460- new upstream release
461
462* Mon Nov 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.11-1
463- new upstream release
464
465* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.9-1
466- new upstream release
467
468* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.8-1
469- new upstream release
470
471* Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.0-1
472- new upstream release
473- add Patch0 (libgda-4.2.0-disable-mdb.patch)
474- change %%{libver}
475
476* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.9-2
477- rebuild with rpm-4.8.1 for pkg-config file
478
479* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.9-1
480- new upstream release
481
482* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.8-1
483- new upstream release
484
485* Mon Nov 02 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 4.0.5-1
486- new upstream release
487- remove gnome-vfs2-devel from BR.(use gio-2.0)
488- add Vendor, Distribution and Packager.
489- update summary and description.
490
491* Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 4.0.2-3
492- rebuilt with postgresql-8.4.0
493
494* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.2-2
495- added intltool to BuildRequires.
496- rebuilt with MySQL-5.1.34.
497
498* Wed Apr 29 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 4.0.2-1
499- update from upstream.
500- update description and files.
501- ODBC,LDAP outdated
502
503* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 3.1.4-2
504- rebuilt with postgresql-8.3.3
505
506* Sun Jun 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.4-1
507- new upstream release
508- not build sharp subpackage
509- built with db4-4.6.21, MySQL-5.0.51a
510
511* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 1.9.100-0vl8
512- rebuilt with postgresql-8.2.6
513
514* Wed Sep 19 2007 Shu KONNO <owa@bg.wakwak.com> 1.9.100-0vl7
515- rebuilt with postgresql-8.2.5
516
517* Sun May 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl6
518- rebuilt with new toolchain
519
520* Wed Nov  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl5
521- rebuilt with openldap 2.3.27, MySQL 5.0.27
522- added Patch0 from Fedora
523
524* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl4
525- rebuilt with openldap-devel-2.3.24-0vl4
526
527* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.100-0vl3
528- rebuilt with gamin-devel in place of fam-devel
529
530* Sun Apr 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl2
531- rebuilt with readline 5.1
532- added subpackage for Mono binding
533
534* Mon Jan  9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl1
535- new upstream release
536
537* Tue May 31 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
538- new upstream release
539- rebuild with postgresql-devel-8.0.3-0vl2 and sqlite3-devel
540
541* Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
542- new upstream release
543- fixed %files on devel package
544
545* Sun Aug 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.6-0vl1
546- new upstream release
547- re-define __libtoolize to compile shared object
548- updated summary
549- make sqlite package by default
550
551* Sun Mar 28 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl1
552- new upstream release
553- build with new MySQL
554- make ldap package by default
555
556* Sat Dec  6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl1
557- new upstream release
558
559* Fri Oct 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.1-0vl1
560- new upstream release
561
562* Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.0-1vl1
563- updated to 1.0.0
564- based on original spec
565- disabled smp_flag at compile time
566
567* Sun Apr 20 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.2.96-0vl3
568- added BuildPreReq: bonobo >= 1.0.9
569  (0.2.96-0vl2 seems to be lost by accident, so putting again here)
570
571* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.2.96-0vl1
572- New upstream release.
573- use gcc-2.95.3 and g++-2.95.3
574
575* Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 0.2.94-0vl1
576- New upstream release.
577
578* Fri Jan  4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 0.2.93-0vl1
579- Rebuild for Vine.
580
581* Thu May 31 2001 Serge Pavlovsky <pal@re.com.ua>
582- Cleaned
583
584* Sat Sep 2 2000 Rodrigo Moya <rodrigo@linuxave.net>
585- Initial spec imported from old GNOME-DB spec
586
Note: See TracBrowser for help on using the repository browser.