source: projects/specs/trunk/lib/libg/libgda/libgda-vl.spec @ 1897

Revision 1897, 12.5 KB checked in by Takemikaduchi, 14 years ago (diff)

rebuild with rpm-4.8.1

Line 
1%define major   4
2%define minor   0
3%define micro   9
4%define version %{major}.%{minor}.%{micro}
5
6%define __libtoolize :
7# Default provider build options (MySQL, Postgres & unixODBC)
8#
9# Package build options:
10# --with tds
11# --with db2
12# --with oracle
13# --without sqlite
14# --with sybase
15# --with mdb
16# --without ldap
17# --without mysql
18# --without odbc
19# --without postgres
20#
21
22%define           FREETDS  0
23%define           IBMDB2   0
24%define           MYSQL    1
25%define           ODBC     0
26%define           ORACLE   0
27%define           POSTGRES 1
28%define           SQLITE   1
29%define           SYBASE   0
30%define           MDB      0
31%define           LDAP     0
32
33%{?_with_tds:%define FREETDS    1}
34%{?_with_db2:%define IBMDB2     1}
35%{?_without_ldap:%define LDAP   0}
36%{?_with_mdb:%define MDB        1}
37%{?_with_oracle:%define ORACLE  1}
38%{?_without_sqlite:%define SQLITE 0}
39%{?_with_sybase:%define SYBASE  1}
40%{?_without_mysql:%define MYSQL 0}
41%{?_without_odbc:%define ODBC   0}
42%{?_without_postgres:%define POSTGRES   0}
43
44%define libver  %{major}.%{minor}
45
46Summary:        A (relatively small) database access library
47Name:           libgda
48Version:        %{version}
49Release:        2%{?_dist_release}
50Source:         %{name}-%{version}.tar.bz2
51URL:            http://www.gnome-db.org/
52Group:          System Environment/Libraries
53License:        LGPL
54BuildRoot:      %{_tmppath}/%{name}-%{version}-root
55Summary(ja):    比較的小規模なデータベース接続ライブラリ
56
57Vendor: Project Vine
58Distribution: Vine Linux
59Packager: yasumichi
60
61BuildRequires:  pkgconfig       >= 0.8
62BuildRequires:  intltool        >= 0.35.5
63BuildRequires:  glib2-devel     >= 2.12.0
64BuildRequires:  libxml2-devel
65BuildRequires:  libxslt-devel >= 1.0.9
66BuildRequires:  db4-devel ncurses-devel
67BuildRequires:  gamin-devel >= 0.1.8
68BuildRequires:  libgcrypt-devel >= 1.1.42
69#BuildRequires: gnome-vfs2-devel >= 2.20        # use gio-2.0(in glib2)
70#BuildRequires: mono-devel gtk-sharp2 gtk-sharp2-gapi
71
72%if %{FREETDS}
73BuildRequires:    freetds-devel
74%endif
75
76%if %{MYSQL}
77BuildRequires:    MySQL-devel
78%endif
79
80%if %{POSTGRES}
81BuildRequires:    postgresql-devel
82%endif
83
84%if %{ODBC}
85BuildRequires:    unixODBC-devel
86%endif
87
88%if %{SQLITE}
89BuildRequires:    sqlite3-devel
90%endif
91
92%if %{MDB}
93BuildRequires:    mdbtools-devel
94%endif
95
96%if %{LDAP}
97BuildRequires:    openldap-devel
98%endif
99
100%description
101Libgda is a (relatively small) database access library:
102 - a wrapper like ODBC but with more features to access several database
103   engines
104 - a meta data extractor (to know all about database objects in a common
105   way)
106 - comes with an SQL console application (like mysql, psql or sqlite3
107   consoles)
108 - relies on GLib, coded in C, its API is easy to use
109 - at the moment supports SQLite, MySQL, PostgreSQL, MSAccess and Bdb, work
110   is in progress for other database types (such as Firebird and Oracle) and
111   to wrap JDBC for more wider usage.
112     
113Build option is:
114 --with mysql postgres sqlite
115 --without tds ibmdb2 ldap mdb odbc oracle sybase
116
117%package devel
118Summary:          Development libraries and header files for libgda.
119Group:            Development/Libraries
120Requires:         %{name} = %{version}
121Requires:         glib2-devel   >= 2.12.0
122Requires:         libxml2-devel
123Requires:         libxslt-devel >= 1.0.9
124
125%description devel
126This package contains the header files and libraries needed to write
127or compile programs that use libgda.
128
129
130#%package sharp
131#Summary:          Mono bindings for libgda
132#Group:            System Environment/Libraries
133#Requires:         %{name} = %{version}-%{release}
134#Requires:         mono-core
135#
136#%description sharp
137#This package contains the dll files needed to run (and compile) Mono
138#applications which use libgda.
139
140
141%if %{FREETDS}
142%package -n gda-freetds
143Summary:        GDA FreeTDS Provider
144Group:          System Environment/Libraries
145%description -n gda-freetds
146This package includes the GDA FreeTDS provider.
147%endif
148
149%if %{IBMDB2}
150%package -n gda-ibmdb2
151Summary:        GDA IBM DB2 Provider
152Group:          System Environment/Libraries
153%description -n gda-ibmdb2
154This package includes the GDA IBM DB2 provider.
155%endif
156
157%if %{MYSQL}
158%package -n gda-mysql
159Summary:        GDA MySQL Provider
160Group:          System Environment/Libraries
161%description -n gda-mysql
162This package includes the GDA MySQL provider.
163%endif
164
165%if %{ODBC}
166%package -n gda-odbc
167Summary:        GDA ODBC Provider
168Group:          System Environment/Libraries
169%description -n gda-odbc
170This package includes the GDA ODBC provider.
171%endif
172
173%if %{ORACLE}
174%package -n gda-oracle
175Summary:        GDA Oracle Provider
176Group:          System Environment/Libraries
177%description -n gda-oracle
178This package includes the GDA Oracle provider.
179%endif
180
181%if %{POSTGRES}
182%package -n gda-postgres
183Summary:        GDA PostgreSQL Provider
184Group:          System Environment/Libraries
185%description -n gda-postgres
186This package includes the GDA PostgreSQL provider.
187%endif
188
189%if %{SQLITE}
190%package -n gda-sqlite
191Summary:        GDA SQLite Provider
192Group:          System Environment/Libraries
193%description -n gda-sqlite
194This package includes the GDA SQLite provider.
195%endif
196
197%if %{SYBASE}
198%package -n gda-sybase
199Summary:        GDA Sybase Provider
200Group:          System Environment/Libraries
201%description -n gda-sybase
202This package includes the GDA Sybase provider.
203%endif
204
205%if %{MDB}
206%package -n gda-mdb
207Summary:        GDA MDB Provider
208Group:          System Environment/Libraries
209%description -n gda-mdb
210This package includes the GDA MDB provider.
211%endif
212
213%if %{LDAP}
214%package -n gda-ldap
215Summary:        GDA LDAP Provider
216Group:          System Environment/Libraries
217%description -n gda-ldap
218This package includes the GDA LDAP provider.
219%endif
220
221%prep
222%setup -q -n %{name}-%{version}
223
224%build
225%if %{FREETDS}
226CONFIG="$CONFIG --with-tds"
227%else
228CONFIG="$CONFIG --without-tds"
229%endif
230
231%if %{IBMDB2}
232CONFIG="$CONFIG --with-ibmdb2"
233%else
234CONFIG="$CONFIG --without-ibmdb2"
235%endif
236
237%if %{MYSQL}
238CONFIG="$CONFIG --with-mysql"
239%else
240CONFIG="$CONFIG --without-mysql"
241%endif
242
243%if %{POSTGRES}
244CONFIG="$CONFIG --with-postgres"
245%else
246CONFIG="$CONFIG --without-postgres"
247%endif
248
249%if %{ODBC}
250CONFIG="$CONFIG --with-odbc"
251%else
252CONFIG="$CONFIG --without-odbc"
253%endif
254
255%if %{ORACLE}
256CONFIG="$CONFIG --with-oracle"
257%else
258CONFIG="$CONFIG --without-oracle"
259%endif
260
261%if %{SQLITE}
262CONFIG="$CONFIG --with-sqlite"
263%else
264CONFIG="$CONFIG --without-sqlite"
265%endif
266
267%if %{SYBASE}
268CONFIG="$CONFIG --with-sybase"
269%else
270CONFIG="$CONFIG --without-sybase"
271%endif
272
273%if %{MDB}
274CONFIG="$CONFIG --with-mdb"
275%else
276CONFIG="$CONFIG --without-mdb"
277%endif
278
279%if %{LDAP}
280CONFIG="$CONFIG --with-ldap"
281%else
282CONFIG="$CONFIG --without-ldap"
283%endif
284
285%configure $CONFIG --disable-gtk-doc
286make
287
288%install
289rm -rf $RPM_BUILD_ROOT
290#makeinstall LIBGDA_DTDDIR=%{buildroot}%{_datadir}/libgda/dtd
291make install DESTDIR=$RPM_BUILD_ROOT
292
293#fixup mono / sharp related files install
294#mkdir -p %{buildroot}/%{_datadir}/gapi-2.0
295#mv %{buildroot}/%{_libdir}/libgda/gda-api.xml %{buildroot}/%{_datadir}/gapi-2.0
296#mkdir -p %{buildroot}/usr/lib/mono/gda-sharp-2.0
297#mv %{buildroot}/%{_libdir}/libgda/* %{buildroot}/usr/lib/mono/gda-sharp-2.0
298#rmdir %{buildroot}/%{_libdir}/libgda
299
300# Cleanup unnecessary, unpackaged files
301rm -f %{buildroot}/%{_libdir}/lib*.la
302rm -f %{buildroot}/%{_libdir}/libgda-%{libver}/providers/*.{a,la}
303rm -f %{buildroot}/%{_sysconfdir}/libgda-%{libver}/sales_test.db
304
305%find_lang libgda-%{libver}
306
307%post -p /sbin/ldconfig
308
309%postun -p /sbin/ldconfig
310
311%clean
312rm -rf $RPM_BUILD_ROOT
313
314
315%files -f libgda-%{libver}.lang
316%defattr(-,root,root)
317%doc AUTHORS COPYING COPYING.LIB ChangeLog README NEWS
318%dir %{_sysconfdir}/libgda-%{libver}
319%config(noreplace) %{_sysconfdir}/libgda-%{libver}/config
320%{_bindir}/*
321%{_libdir}/*.so.*
322
323%dir %{_libdir}/libgda-%{libver}
324%dir %{_libdir}/libgda-%{libver}/providers
325%{_libdir}/libgda-%{libver}/providers/libgda-bdb.so
326
327%dir %{_datadir}/libgda-%{libver}
328%{_datadir}/libgda-%{libver}/dtd
329%{_datadir}/libgda-%{libver}/*.xml
330%{_datadir}/libgda-%{libver}/web
331
332%{_mandir}/man1/*
333
334%files devel
335%defattr(-,root,root)
336%{_includedir}/libgda-%{libver}
337%{_libdir}/*.a
338#{_libdir}/*.la
339%{_libdir}/*.so
340%{_libdir}/pkgconfig/*
341%{_datadir}/gtk-doc/html/*
342#%{_datadir}/omf/*
343#%{_mandir}/man5/*
344
345#files sharp
346#defattr(-,root,root)
347#{_datadir}/gapi-2.0
348#/usr/lib/mono/gda-sharp-2.0
349#{_libdir}/pkgconfig/gda-sharp-2.0.pc
350
351%if %{FREETDS}
352%files -n gda-freetds
353%{_libdir}/libgda-%{libver}/providers/libgda-freetds.so
354%endif
355
356%if %{IBMDB2}
357%files -n gda-ibmdb2
358%{_libdir}/libgda-%{libver}/providers/libgda-ibmdb2.so
359%endif
360
361%if %{MYSQL}
362%files -n gda-mysql
363%{_libdir}/libgda-%{libver}/providers/libgda-mysql.so
364%{_datadir}/libgda-%{libver}/mysql_*.xml
365%endif
366
367%if %{ODBC}
368%files -n gda-odbc
369%{_libdir}/libgda-%{libver}/providers/libgda-odbc.so
370%{_datadir}/libgda-%{libver}/odbc_*.xml
371%endif
372
373%if %{ORACLE}
374%files -n gda-oracle
375%{_libdir}/libgda-%{libver}/providers/libgda-oracle.so
376%endif
377
378%if %{POSTGRES}
379%files -n gda-postgres
380%{_libdir}/libgda-%{libver}/providers/libgda-postgres.so
381%{_datadir}/libgda-%{libver}/postgres_*.xml
382%endif
383
384%if %{SQLITE}
385%files -n gda-sqlite
386%{_libdir}/libgda-%{libver}/providers/libgda-sqlite.so
387%{_datadir}/libgda-%{libver}/sqlite_*.xml
388%endif
389
390%if %{SYBASE}
391%files -n gda-sybase
392%{_libdir}/libgda-%{libver}/providers/libgda-sybase.so
393%endif
394
395%if %{MDB}
396%files -n gda-mdb
397%{_libdir}/libgda-%{libver}/providers/libgda-mdb.so
398%endif
399
400%if %{LDAP}
401%files -n gda-ldap
402%{_libdir}/libgda-%{libver}/providers/libgda-ldap.so
403%{_datadir}/libgda-%{libver}/ldap_*.xml
404%endif
405
406
407%changelog
408* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.9-2
409- rebuild with rpm-4.8.1 for pkg-config file
410
411* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.9-1
412- new upstream release
413
414* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.8-1
415- new upstream release
416
417* Mon Nov 02 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 4.0.5-1
418- new upstream release
419- remove gnome-vfs2-devel from BR.(use gio-2.0)
420- add Vendor, Distribution and Packager.
421- update summary and description.
422
423* Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 4.0.2-3
424- rebuilt with postgresql-8.4.0
425
426* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.2-2
427- added intltool to BuildRequires.
428- rebuilt with MySQL-5.1.34.
429
430* Wed Apr 29 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 4.0.2-1
431- update from upstream.
432- update description and files.
433- ODBC,LDAP outdated
434
435* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 3.1.4-2
436- rebuilt with postgresql-8.3.3
437
438* Sun Jun 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.4-1
439- new upstream release
440- not build sharp subpackage
441- built with db4-4.6.21, MySQL-5.0.51a
442
443* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 1.9.100-0vl8
444- rebuilt with postgresql-8.2.6
445
446* Wed Sep 19 2007 Shu KONNO <owa@bg.wakwak.com> 1.9.100-0vl7
447- rebuilt with postgresql-8.2.5
448
449* Sun May 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl6
450- rebuilt with new toolchain
451
452* Wed Nov  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl5
453- rebuilt with openldap 2.3.27, MySQL 5.0.27
454- added Patch0 from Fedora
455
456* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl4
457- rebuilt with openldap-devel-2.3.24-0vl4
458
459* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.100-0vl3
460- rebuilt with gamin-devel in place of fam-devel
461
462* Sun Apr 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl2
463- rebuilt with readline 5.1
464- added subpackage for Mono binding
465
466* Mon Jan  9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl1
467- new upstream release
468
469* Tue May 31 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
470- new upstream release
471- rebuild with postgresql-devel-8.0.3-0vl2 and sqlite3-devel
472
473* Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
474- new upstream release
475- fixed %files on devel package
476
477* Sun Aug 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.6-0vl1
478- new upstream release
479- re-define __libtoolize to compile shared object
480- updated summary
481- make sqlite package by default
482
483* Sun Mar 28 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl1
484- new upstream release
485- build with new MySQL
486- make ldap package by default
487
488* Sat Dec  6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl1
489- new upstream release
490
491* Fri Oct 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.1-0vl1
492- new upstream release
493
494* Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.0-1vl1
495- updated to 1.0.0
496- based on original spec
497- disabled smp_flag at compile time
498
499* Sun Apr 20 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.2.96-0vl3
500- added BuildPreReq: bonobo >= 1.0.9
501  (0.2.96-0vl2 seems to be lost by accident, so putting again here)
502
503* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.2.96-0vl1
504- New upstream release.
505- use gcc-2.95.3 and g++-2.95.3
506
507* Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 0.2.94-0vl1
508- New upstream release.
509
510* Fri Jan  4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 0.2.93-0vl1
511- Rebuild for Vine.
512
513* Thu May 31 2001 Serge Pavlovsky <pal@re.com.ua>
514- Cleaned
515
516* Sat Sep 2 2000 Rodrigo Moya <rodrigo@linuxave.net>
517- Initial spec imported from old GNOME-DB spec
518
Note: See TracBrowser for help on using the repository browser.