source: projects/specs/trunk/lib/libg/libgda/libgda-vl.spec @ 7633

Revision 7633, 14.4 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.8.1

Line 
1%define major   5
2%define minor   1
3%define micro   2
4%define version %{major}.%{minor}.%{micro}
5
6%define __libtoolize :
7# Default provider build options (MySQL, Postgres & unixODBC)
8#
9# Package build options:
10# --with tds
11# --with db2
12# --with oracle
13# --without sqlite
14# --with sybase
15# --with mdb
16# --without ldap
17# --without mysql
18# --without odbc
19# --without postgres
20#
21
22%define           FREETDS  0
23%define           IBMDB2   0
24%define           MYSQL    1
25%define           ODBC     0
26%define           ORACLE   0
27%define           POSTGRES 1
28%define           SQLITE   1
29%define           SYBASE   0
30%define           MDB      0
31%define           LDAP     0
32
33%{?_with_tds:%define FREETDS    1}
34%{?_with_db2:%define IBMDB2     1}
35%{?_without_ldap:%define LDAP   0}
36%{?_with_mdb:%define MDB        1}
37%{?_with_oracle:%define ORACLE  1}
38%{?_without_sqlite:%define SQLITE 0}
39%{?_with_sybase:%define SYBASE  1}
40%{?_without_mysql:%define MYSQL 0}
41%{?_without_odbc:%define ODBC   0}
42%{?_without_postgres:%define POSTGRES   0}
43
44%define libver  5.0
45
46Summary:        A (relatively small) database access library
47Name:           libgda
48Version:        %{version}
49Release:        1%{?_dist_release}
50Source:         %{name}-%{version}.tar.xz
51URL:            http://www.gnome-db.org/
52Group:          System Environment/Libraries
53License:        LGPL
54BuildRoot:      %{_tmppath}/%{name}-%{version}-root
55Summary(ja):    比較的小規模なデータベース接続ライブラリ
56
57Patch0:         libgda-4.2.0-disable-mdb.patch
58
59Vendor: Project Vine
60Distribution: Vine Linux
61Packager: yasumichi
62
63BuildRequires:  pkgconfig       >= 0.8
64BuildRequires:  intltool        >= 0.35.5
65BuildRequires:  glib2-devel     >= 2.12.0
66BuildRequires:  gtk3-devel
67BuildRequires:  gobject-introspection-devel
68BuildRequires:  libxml2-devel
69BuildRequires:  libxslt-devel >= 1.0.9
70BuildRequires:  db4-devel ncurses-devel
71BuildRequires:  gamin-devel >= 0.1.8
72BuildRequires:  libgcrypt-devel >= 1.1.42
73BuildRequires:  gtksourceview3-devel
74BuildRequires:  libsoup-devel
75BuildRequires:  libsecret-devel
76BuildRequires:  iso-codes
77
78%if %{FREETDS}
79BuildRequires:    freetds-devel
80%endif
81
82%if %{MYSQL}
83BuildRequires:    MySQL-devel
84%endif
85
86%if %{POSTGRES}
87BuildRequires:    postgresql-devel
88%endif
89
90%if %{ODBC}
91BuildRequires:    unixODBC-devel
92%endif
93
94%if %{SQLITE}
95BuildRequires:    sqlite3-devel
96%endif
97
98%if %{MDB}
99BuildRequires:    mdbtools-devel
100%endif
101
102%if %{LDAP}
103BuildRequires:    openldap-devel
104%endif
105
106%description
107Libgda is a (relatively small) database access library:
108 - a wrapper like ODBC but with more features to access several database
109   engines
110 - a meta data extractor (to know all about database objects in a common
111   way)
112 - comes with an SQL console application (like mysql, psql or sqlite3
113   consoles)
114 - relies on GLib, coded in C, its API is easy to use
115 - at the moment supports SQLite, MySQL, PostgreSQL, MSAccess and Bdb, work
116   is in progress for other database types (such as Firebird and Oracle) and
117   to wrap JDBC for more wider usage.
118     
119Build option is:
120 --with mysql postgres sqlite
121 --without tds ibmdb2 ldap mdb odbc oracle sybase
122
123%package devel
124Summary:          Development libraries and header files for libgda.
125Group:            Development/Libraries
126Requires:         %{name} = %{version}
127Requires:         glib2-devel   >= 2.12.0
128Requires:         libxml2-devel
129Requires:         libxslt-devel >= 1.0.9
130
131%description devel
132This package contains the header files and libraries needed to write
133or compile programs that use libgda.
134
135
136#%package sharp
137#Summary:          Mono bindings for libgda
138#Group:            System Environment/Libraries
139#Requires:         %{name} = %{version}-%{release}
140#Requires:         mono-core
141#
142#%description sharp
143#This package contains the dll files needed to run (and compile) Mono
144#applications which use libgda.
145
146
147%if %{FREETDS}
148%package -n gda-freetds
149Summary:        GDA FreeTDS Provider
150Group:          System Environment/Libraries
151%description -n gda-freetds
152This package includes the GDA FreeTDS provider.
153%endif
154
155%if %{IBMDB2}
156%package -n gda-ibmdb2
157Summary:        GDA IBM DB2 Provider
158Group:          System Environment/Libraries
159%description -n gda-ibmdb2
160This package includes the GDA IBM DB2 provider.
161%endif
162
163%if %{MYSQL}
164%package -n gda-mysql
165Summary:        GDA MySQL Provider
166Group:          System Environment/Libraries
167%description -n gda-mysql
168This package includes the GDA MySQL provider.
169%endif
170
171%if %{ODBC}
172%package -n gda-odbc
173Summary:        GDA ODBC Provider
174Group:          System Environment/Libraries
175%description -n gda-odbc
176This package includes the GDA ODBC provider.
177%endif
178
179%if %{ORACLE}
180%package -n gda-oracle
181Summary:        GDA Oracle Provider
182Group:          System Environment/Libraries
183%description -n gda-oracle
184This package includes the GDA Oracle provider.
185%endif
186
187%if %{POSTGRES}
188%package -n gda-postgres
189Summary:        GDA PostgreSQL Provider
190Group:          System Environment/Libraries
191%description -n gda-postgres
192This package includes the GDA PostgreSQL provider.
193%endif
194
195%if %{SQLITE}
196%package -n gda-sqlite
197Summary:        GDA SQLite Provider
198Group:          System Environment/Libraries
199%description -n gda-sqlite
200This package includes the GDA SQLite provider.
201%endif
202
203%if %{SYBASE}
204%package -n gda-sybase
205Summary:        GDA Sybase Provider
206Group:          System Environment/Libraries
207%description -n gda-sybase
208This package includes the GDA Sybase provider.
209%endif
210
211%if %{MDB}
212%package -n gda-mdb
213Summary:        GDA MDB Provider
214Group:          System Environment/Libraries
215%description -n gda-mdb
216This package includes the GDA MDB provider.
217%endif
218
219%if %{LDAP}
220%package -n gda-ldap
221Summary:        GDA LDAP Provider
222Group:          System Environment/Libraries
223%description -n gda-ldap
224This package includes the GDA LDAP provider.
225%endif
226
227%prep
228%setup -q -n %{name}-%{version}
229%patch0 -p1 -b .mdb
230
231%build
232%if %{FREETDS}
233CONFIG="$CONFIG --with-tds"
234%else
235CONFIG="$CONFIG --without-tds"
236%endif
237
238%if %{IBMDB2}
239CONFIG="$CONFIG --with-ibmdb2"
240%else
241CONFIG="$CONFIG --without-ibmdb2"
242%endif
243
244%if %{MYSQL}
245CONFIG="$CONFIG --with-mysql"
246%else
247CONFIG="$CONFIG --without-mysql"
248%endif
249
250%if %{POSTGRES}
251CONFIG="$CONFIG --with-postgres"
252%else
253CONFIG="$CONFIG --without-postgres"
254%endif
255
256%if %{ODBC}
257CONFIG="$CONFIG --with-odbc"
258%else
259CONFIG="$CONFIG --without-odbc"
260%endif
261
262%if %{ORACLE}
263CONFIG="$CONFIG --with-oracle"
264%else
265CONFIG="$CONFIG --without-oracle"
266%endif
267
268%if %{SQLITE}
269CONFIG="$CONFIG --with-sqlite"
270%else
271CONFIG="$CONFIG --without-sqlite"
272%endif
273
274%if %{SYBASE}
275CONFIG="$CONFIG --with-sybase"
276%else
277CONFIG="$CONFIG --without-sybase"
278%endif
279
280%if %{MDB}
281CONFIG="$CONFIG --with-mdb"
282%else
283CONFIG="$CONFIG --without-mdb"
284%endif
285
286%if %{LDAP}
287CONFIG="$CONFIG --with-ldap"
288%else
289CONFIG="$CONFIG --without-ldap"
290%endif
291
292%configure $CONFIG \
293        --disable-static \
294        --enable-introspection \
295        --disable-gtk-doc \
296        --with-libdir-name=%{_lib}
297make
298
299%install
300rm -rf $RPM_BUILD_ROOT
301#makeinstall LIBGDA_DTDDIR=%{buildroot}%{_datadir}/libgda/dtd
302make install DESTDIR=$RPM_BUILD_ROOT
303
304#fixup mono / sharp related files install
305#mkdir -p %{buildroot}/%{_datadir}/gapi-2.0
306#mv %{buildroot}/%{_libdir}/libgda/gda-api.xml %{buildroot}/%{_datadir}/gapi-2.0
307#mkdir -p %{buildroot}/usr/lib/mono/gda-sharp-2.0
308#mv %{buildroot}/%{_libdir}/libgda/* %{buildroot}/usr/lib/mono/gda-sharp-2.0
309#rmdir %{buildroot}/%{_libdir}/libgda
310
311# Cleanup unnecessary, unpackaged files
312find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
313rm -f %{buildroot}/%{_sysconfdir}/libgda-%{libver}/sales_test.db
314
315%find_lang libgda-%{libver}
316
317%post -p /sbin/ldconfig
318
319%postun -p /sbin/ldconfig
320
321%clean
322rm -rf $RPM_BUILD_ROOT
323
324
325%files
326%defattr(-,root,root)
327%doc AUTHORS COPYING COPYING.LIB ChangeLog README NEWS
328%dir %{_sysconfdir}/libgda-%{libver}
329%config(noreplace) %{_sysconfdir}/libgda-%{libver}/config
330%{_bindir}/*
331%{_libdir}/*.so.*
332#%{_libdir}/girepository-1.0/*.typelib
333
334%dir %{_libdir}/libgda-%{libver}
335%dir %{_libdir}/libgda-%{libver}/plugins
336%{_libdir}/libgda-%{libver}/plugins/*.xml
337%{_libdir}/libgda-%{libver}/plugins/libgda-ui-plugins.so
338%dir %{_libdir}/libgda-%{libver}/providers
339%{_libdir}/libgda-%{libver}/providers/libgda-bdb.so
340%{_libdir}/libgda-%{libver}/providers/libgda-sqlcipher.so
341%{_libdir}/libgda-%{libver}/providers/libgda-web.so
342
343%{_datadir}/applications/*.desktop
344%{_datadir}/icons/hicolor/*/*/*
345%{_datadir}/gnome/help/gda-sql/C/gda-sql-help.xml
346%{_datadir}/pixmaps/gda-browser-5.0.png
347
348%dir %{_datadir}/libgda-%{libver}
349%{_datadir}/libgda-%{libver}/demo
350%{_datadir}/libgda-%{libver}/dtd
351%{_datadir}/libgda-%{libver}/gda_trml2html
352%{_datadir}/libgda-%{libver}/gda_trml2pdf
353%{_datadir}/libgda-%{libver}/icons
354%{_datadir}/libgda-%{libver}/language-specs/gda-sql.lang
355%{_datadir}/libgda-%{libver}/php
356%{_datadir}/libgda-%{libver}/pixmaps
357%{_datadir}/libgda-%{libver}/server_operation.glade
358%{_datadir}/libgda-%{libver}/ui
359%{_datadir}/libgda-%{libver}/*.xml
360%{_datadir}/libgda-%{libver}/web
361
362%{_mandir}/man1/*
363%{_datadir}/locale/*/LC_MESSAGES/*
364
365%files devel
366%defattr(-,root,root)
367%{_includedir}/libgda-%{libver}
368%{_libdir}/*.so
369%{_libdir}/pkgconfig/*
370#%{_datadir}/gir-1.0/*.gir
371%{_datadir}/gtk-doc/html/*
372
373#files sharp
374#defattr(-,root,root)
375#{_datadir}/gapi-2.0
376#/usr/lib/mono/gda-sharp-2.0
377#{_libdir}/pkgconfig/gda-sharp-2.0.pc
378
379%if %{FREETDS}
380%files -n gda-freetds
381%{_libdir}/libgda-%{libver}/providers/libgda-freetds.so
382%endif
383
384%if %{IBMDB2}
385%files -n gda-ibmdb2
386%{_libdir}/libgda-%{libver}/providers/libgda-ibmdb2.so
387%endif
388
389%if %{MYSQL}
390%files -n gda-mysql
391%{_libdir}/libgda-%{libver}/providers/libgda-mysql.so
392%{_datadir}/libgda-%{libver}/mysql_*.xml
393%endif
394
395%if %{ODBC}
396%files -n gda-odbc
397%{_libdir}/libgda-%{libver}/providers/libgda-odbc.so
398%{_datadir}/libgda-%{libver}/odbc_*.xml
399%endif
400
401%if %{ORACLE}
402%files -n gda-oracle
403%{_libdir}/libgda-%{libver}/providers/libgda-oracle.so
404%endif
405
406%if %{POSTGRES}
407%files -n gda-postgres
408%{_libdir}/libgda-%{libver}/providers/libgda-postgres.so
409%{_datadir}/libgda-%{libver}/postgres_*.xml
410%endif
411
412%if %{SQLITE}
413%files -n gda-sqlite
414%{_libdir}/libgda-%{libver}/providers/libgda-sqlite.so
415%{_datadir}/libgda-%{libver}/sqlite_*.xml
416%endif
417
418%if %{SYBASE}
419%files -n gda-sybase
420%{_libdir}/libgda-%{libver}/providers/libgda-sybase.so
421%endif
422
423%if %{MDB}
424%files -n gda-mdb
425%{_libdir}/libgda-%{libver}/providers/libgda-mdb.so
426%endif
427
428%if %{LDAP}
429%files -n gda-ldap
430%{_libdir}/libgda-%{libver}/providers/libgda-ldap.so
431%{_datadir}/libgda-%{libver}/ldap_*.xml
432%endif
433
434
435%changelog
436* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.1.2-1
437- new upstream release
438
439* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.1.1-1
440- new upstream release
441- add BuildRequires: gtksourceview3-devel, libsoup-devel, libsecret-devel
442- remove BuildRequires: gcr-devel
443
444* Tue Apr 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0.3-1
445- new upstream release
446- add BuildRequires: gtk3-devel, gobject-introspection-devel, gcr-devel, iso-codes
447
448* Wed Dec 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.12-1
449- new upstream release
450
451* Mon Nov 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.11-1
452- new upstream release
453
454* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.9-1
455- new upstream release
456
457* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.8-1
458- new upstream release
459
460* Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.0-1
461- new upstream release
462- add Patch0 (libgda-4.2.0-disable-mdb.patch)
463- change %%{libver}
464
465* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.9-2
466- rebuild with rpm-4.8.1 for pkg-config file
467
468* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.9-1
469- new upstream release
470
471* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.8-1
472- new upstream release
473
474* Mon Nov 02 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 4.0.5-1
475- new upstream release
476- remove gnome-vfs2-devel from BR.(use gio-2.0)
477- add Vendor, Distribution and Packager.
478- update summary and description.
479
480* Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 4.0.2-3
481- rebuilt with postgresql-8.4.0
482
483* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.2-2
484- added intltool to BuildRequires.
485- rebuilt with MySQL-5.1.34.
486
487* Wed Apr 29 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 4.0.2-1
488- update from upstream.
489- update description and files.
490- ODBC,LDAP outdated
491
492* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 3.1.4-2
493- rebuilt with postgresql-8.3.3
494
495* Sun Jun 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.4-1
496- new upstream release
497- not build sharp subpackage
498- built with db4-4.6.21, MySQL-5.0.51a
499
500* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 1.9.100-0vl8
501- rebuilt with postgresql-8.2.6
502
503* Wed Sep 19 2007 Shu KONNO <owa@bg.wakwak.com> 1.9.100-0vl7
504- rebuilt with postgresql-8.2.5
505
506* Sun May 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl6
507- rebuilt with new toolchain
508
509* Wed Nov  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl5
510- rebuilt with openldap 2.3.27, MySQL 5.0.27
511- added Patch0 from Fedora
512
513* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl4
514- rebuilt with openldap-devel-2.3.24-0vl4
515
516* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.100-0vl3
517- rebuilt with gamin-devel in place of fam-devel
518
519* Sun Apr 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl2
520- rebuilt with readline 5.1
521- added subpackage for Mono binding
522
523* Mon Jan  9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl1
524- new upstream release
525
526* Tue May 31 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
527- new upstream release
528- rebuild with postgresql-devel-8.0.3-0vl2 and sqlite3-devel
529
530* Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
531- new upstream release
532- fixed %files on devel package
533
534* Sun Aug 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.6-0vl1
535- new upstream release
536- re-define __libtoolize to compile shared object
537- updated summary
538- make sqlite package by default
539
540* Sun Mar 28 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl1
541- new upstream release
542- build with new MySQL
543- make ldap package by default
544
545* Sat Dec  6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl1
546- new upstream release
547
548* Fri Oct 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.1-0vl1
549- new upstream release
550
551* Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.0-1vl1
552- updated to 1.0.0
553- based on original spec
554- disabled smp_flag at compile time
555
556* Sun Apr 20 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.2.96-0vl3
557- added BuildPreReq: bonobo >= 1.0.9
558  (0.2.96-0vl2 seems to be lost by accident, so putting again here)
559
560* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.2.96-0vl1
561- New upstream release.
562- use gcc-2.95.3 and g++-2.95.3
563
564* Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 0.2.94-0vl1
565- New upstream release.
566
567* Fri Jan  4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 0.2.93-0vl1
568- Rebuild for Vine.
569
570* Thu May 31 2001 Serge Pavlovsky <pal@re.com.ua>
571- Cleaned
572
573* Sat Sep 2 2000 Rodrigo Moya <rodrigo@linuxave.net>
574- Initial spec imported from old GNOME-DB spec
575
Note: See TracBrowser for help on using the repository browser.