source: projects/specs/trunk/lib/libg/libgda/libgda-vl.spec @ 4812

Revision 4812, 13.1 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.1.92

Line 
1%define major   4
2%define minor   2
3%define micro   9
4%define version %{major}.%{minor}.%{micro}
5
6%define __libtoolize :
7# Default provider build options (MySQL, Postgres & unixODBC)
8#
9# Package build options:
10# --with tds
11# --with db2
12# --with oracle
13# --without sqlite
14# --with sybase
15# --with mdb
16# --without ldap
17# --without mysql
18# --without odbc
19# --without postgres
20#
21
22%define           FREETDS  0
23%define           IBMDB2   0
24%define           MYSQL    1
25%define           ODBC     0
26%define           ORACLE   0
27%define           POSTGRES 1
28%define           SQLITE   1
29%define           SYBASE   0
30%define           MDB      0
31%define           LDAP     0
32
33%{?_with_tds:%define FREETDS    1}
34%{?_with_db2:%define IBMDB2     1}
35%{?_without_ldap:%define LDAP   0}
36%{?_with_mdb:%define MDB        1}
37%{?_with_oracle:%define ORACLE  1}
38%{?_without_sqlite:%define SQLITE 0}
39%{?_with_sybase:%define SYBASE  1}
40%{?_without_mysql:%define MYSQL 0}
41%{?_without_odbc:%define ODBC   0}
42%{?_without_postgres:%define POSTGRES   0}
43
44%define libver  4.0
45
46Summary:        A (relatively small) database access library
47Name:           libgda
48Version:        %{version}
49Release:        1%{?_dist_release}
50Source:         %{name}-%{version}.tar.xz
51URL:            http://www.gnome-db.org/
52Group:          System Environment/Libraries
53License:        LGPL
54BuildRoot:      %{_tmppath}/%{name}-%{version}-root
55Summary(ja):    比較的小規模なデータベース接続ライブラリ
56
57Patch0:         libgda-4.2.0-disable-mdb.patch
58
59Vendor: Project Vine
60Distribution: Vine Linux
61Packager: yasumichi
62
63BuildRequires:  pkgconfig       >= 0.8
64BuildRequires:  intltool        >= 0.35.5
65BuildRequires:  glib2-devel     >= 2.12.0
66BuildRequires:  libxml2-devel
67BuildRequires:  libxslt-devel >= 1.0.9
68BuildRequires:  db4-devel ncurses-devel
69BuildRequires:  gamin-devel >= 0.1.8
70BuildRequires:  libgcrypt-devel >= 1.1.42
71#BuildRequires: gnome-vfs2-devel >= 2.20        # use gio-2.0(in glib2)
72#BuildRequires: mono-devel gtk-sharp2 gtk-sharp2-gapi
73
74%if %{FREETDS}
75BuildRequires:    freetds-devel
76%endif
77
78%if %{MYSQL}
79BuildRequires:    MySQL-devel
80%endif
81
82%if %{POSTGRES}
83BuildRequires:    postgresql-devel
84%endif
85
86%if %{ODBC}
87BuildRequires:    unixODBC-devel
88%endif
89
90%if %{SQLITE}
91BuildRequires:    sqlite3-devel
92%endif
93
94%if %{MDB}
95BuildRequires:    mdbtools-devel
96%endif
97
98%if %{LDAP}
99BuildRequires:    openldap-devel
100%endif
101
102%description
103Libgda is a (relatively small) database access library:
104 - a wrapper like ODBC but with more features to access several database
105   engines
106 - a meta data extractor (to know all about database objects in a common
107   way)
108 - comes with an SQL console application (like mysql, psql or sqlite3
109   consoles)
110 - relies on GLib, coded in C, its API is easy to use
111 - at the moment supports SQLite, MySQL, PostgreSQL, MSAccess and Bdb, work
112   is in progress for other database types (such as Firebird and Oracle) and
113   to wrap JDBC for more wider usage.
114     
115Build option is:
116 --with mysql postgres sqlite
117 --without tds ibmdb2 ldap mdb odbc oracle sybase
118
119%package devel
120Summary:          Development libraries and header files for libgda.
121Group:            Development/Libraries
122Requires:         %{name} = %{version}
123Requires:         glib2-devel   >= 2.12.0
124Requires:         libxml2-devel
125Requires:         libxslt-devel >= 1.0.9
126
127%description devel
128This package contains the header files and libraries needed to write
129or compile programs that use libgda.
130
131
132#%package sharp
133#Summary:          Mono bindings for libgda
134#Group:            System Environment/Libraries
135#Requires:         %{name} = %{version}-%{release}
136#Requires:         mono-core
137#
138#%description sharp
139#This package contains the dll files needed to run (and compile) Mono
140#applications which use libgda.
141
142
143%if %{FREETDS}
144%package -n gda-freetds
145Summary:        GDA FreeTDS Provider
146Group:          System Environment/Libraries
147%description -n gda-freetds
148This package includes the GDA FreeTDS provider.
149%endif
150
151%if %{IBMDB2}
152%package -n gda-ibmdb2
153Summary:        GDA IBM DB2 Provider
154Group:          System Environment/Libraries
155%description -n gda-ibmdb2
156This package includes the GDA IBM DB2 provider.
157%endif
158
159%if %{MYSQL}
160%package -n gda-mysql
161Summary:        GDA MySQL Provider
162Group:          System Environment/Libraries
163%description -n gda-mysql
164This package includes the GDA MySQL provider.
165%endif
166
167%if %{ODBC}
168%package -n gda-odbc
169Summary:        GDA ODBC Provider
170Group:          System Environment/Libraries
171%description -n gda-odbc
172This package includes the GDA ODBC provider.
173%endif
174
175%if %{ORACLE}
176%package -n gda-oracle
177Summary:        GDA Oracle Provider
178Group:          System Environment/Libraries
179%description -n gda-oracle
180This package includes the GDA Oracle provider.
181%endif
182
183%if %{POSTGRES}
184%package -n gda-postgres
185Summary:        GDA PostgreSQL Provider
186Group:          System Environment/Libraries
187%description -n gda-postgres
188This package includes the GDA PostgreSQL provider.
189%endif
190
191%if %{SQLITE}
192%package -n gda-sqlite
193Summary:        GDA SQLite Provider
194Group:          System Environment/Libraries
195%description -n gda-sqlite
196This package includes the GDA SQLite provider.
197%endif
198
199%if %{SYBASE}
200%package -n gda-sybase
201Summary:        GDA Sybase Provider
202Group:          System Environment/Libraries
203%description -n gda-sybase
204This package includes the GDA Sybase provider.
205%endif
206
207%if %{MDB}
208%package -n gda-mdb
209Summary:        GDA MDB Provider
210Group:          System Environment/Libraries
211%description -n gda-mdb
212This package includes the GDA MDB provider.
213%endif
214
215%if %{LDAP}
216%package -n gda-ldap
217Summary:        GDA LDAP Provider
218Group:          System Environment/Libraries
219%description -n gda-ldap
220This package includes the GDA LDAP provider.
221%endif
222
223%prep
224%setup -q -n %{name}-%{version}
225%patch0 -p1 -b .mdb
226
227%build
228%if %{FREETDS}
229CONFIG="$CONFIG --with-tds"
230%else
231CONFIG="$CONFIG --without-tds"
232%endif
233
234%if %{IBMDB2}
235CONFIG="$CONFIG --with-ibmdb2"
236%else
237CONFIG="$CONFIG --without-ibmdb2"
238%endif
239
240%if %{MYSQL}
241CONFIG="$CONFIG --with-mysql"
242%else
243CONFIG="$CONFIG --without-mysql"
244%endif
245
246%if %{POSTGRES}
247CONFIG="$CONFIG --with-postgres"
248%else
249CONFIG="$CONFIG --without-postgres"
250%endif
251
252%if %{ODBC}
253CONFIG="$CONFIG --with-odbc"
254%else
255CONFIG="$CONFIG --without-odbc"
256%endif
257
258%if %{ORACLE}
259CONFIG="$CONFIG --with-oracle"
260%else
261CONFIG="$CONFIG --without-oracle"
262%endif
263
264%if %{SQLITE}
265CONFIG="$CONFIG --with-sqlite"
266%else
267CONFIG="$CONFIG --without-sqlite"
268%endif
269
270%if %{SYBASE}
271CONFIG="$CONFIG --with-sybase"
272%else
273CONFIG="$CONFIG --without-sybase"
274%endif
275
276%if %{MDB}
277CONFIG="$CONFIG --with-mdb"
278%else
279CONFIG="$CONFIG --without-mdb"
280%endif
281
282%if %{LDAP}
283CONFIG="$CONFIG --with-ldap"
284%else
285CONFIG="$CONFIG --without-ldap"
286%endif
287
288%configure $CONFIG --disable-gtk-doc --with-libdir-name=%{_lib}
289make
290
291%install
292rm -rf $RPM_BUILD_ROOT
293#makeinstall LIBGDA_DTDDIR=%{buildroot}%{_datadir}/libgda/dtd
294make install DESTDIR=$RPM_BUILD_ROOT
295
296#fixup mono / sharp related files install
297#mkdir -p %{buildroot}/%{_datadir}/gapi-2.0
298#mv %{buildroot}/%{_libdir}/libgda/gda-api.xml %{buildroot}/%{_datadir}/gapi-2.0
299#mkdir -p %{buildroot}/usr/lib/mono/gda-sharp-2.0
300#mv %{buildroot}/%{_libdir}/libgda/* %{buildroot}/usr/lib/mono/gda-sharp-2.0
301#rmdir %{buildroot}/%{_libdir}/libgda
302
303# Cleanup unnecessary, unpackaged files
304rm -f %{buildroot}/%{_libdir}/lib*.la
305rm -f %{buildroot}/%{_libdir}/libgda-%{libver}/providers/*.{a,la}
306rm -f %{buildroot}/%{_sysconfdir}/libgda-%{libver}/sales_test.db
307
308%find_lang libgda-%{libver}
309
310%post -p /sbin/ldconfig
311
312%postun -p /sbin/ldconfig
313
314%clean
315rm -rf $RPM_BUILD_ROOT
316
317
318%files
319%defattr(-,root,root)
320%doc AUTHORS COPYING COPYING.LIB ChangeLog README NEWS
321%dir %{_sysconfdir}/libgda-%{libver}
322%config(noreplace) %{_sysconfdir}/libgda-%{libver}/config
323%{_bindir}/*
324%{_libdir}/*.so.*
325
326%dir %{_libdir}/libgda-%{libver}
327%dir %{_libdir}/libgda-%{libver}/providers
328%{_libdir}/libgda-%{libver}/providers/libgda-bdb.so
329%{_libdir}/libgda-%{libver}/providers/libgda-sqlcipher.so
330
331%dir %{_datadir}/libgda-%{libver}
332%{_datadir}/libgda-%{libver}/dtd
333%{_datadir}/libgda-%{libver}/gda_trml2html
334%{_datadir}/libgda-%{libver}/gda_trml2pdf
335%{_datadir}/libgda-%{libver}/*.xml
336%{_datadir}/libgda-%{libver}/web
337
338%{_mandir}/man1/*
339%{_datadir}/locale/*/LC_MESSAGES/*
340
341%files devel
342%defattr(-,root,root)
343%{_includedir}/libgda-%{libver}
344%{_libdir}/*.a
345#{_libdir}/*.la
346%{_libdir}/*.so
347%{_libdir}/pkgconfig/*
348%{_datadir}/gtk-doc/html/*
349#%{_datadir}/omf/*
350#%{_mandir}/man5/*
351
352#files sharp
353#defattr(-,root,root)
354#{_datadir}/gapi-2.0
355#/usr/lib/mono/gda-sharp-2.0
356#{_libdir}/pkgconfig/gda-sharp-2.0.pc
357
358%if %{FREETDS}
359%files -n gda-freetds
360%{_libdir}/libgda-%{libver}/providers/libgda-freetds.so
361%endif
362
363%if %{IBMDB2}
364%files -n gda-ibmdb2
365%{_libdir}/libgda-%{libver}/providers/libgda-ibmdb2.so
366%endif
367
368%if %{MYSQL}
369%files -n gda-mysql
370%{_libdir}/libgda-%{libver}/providers/libgda-mysql.so
371%{_datadir}/libgda-%{libver}/mysql_*.xml
372%endif
373
374%if %{ODBC}
375%files -n gda-odbc
376%{_libdir}/libgda-%{libver}/providers/libgda-odbc.so
377%{_datadir}/libgda-%{libver}/odbc_*.xml
378%endif
379
380%if %{ORACLE}
381%files -n gda-oracle
382%{_libdir}/libgda-%{libver}/providers/libgda-oracle.so
383%endif
384
385%if %{POSTGRES}
386%files -n gda-postgres
387%{_libdir}/libgda-%{libver}/providers/libgda-postgres.so
388%{_datadir}/libgda-%{libver}/postgres_*.xml
389%endif
390
391%if %{SQLITE}
392%files -n gda-sqlite
393%{_libdir}/libgda-%{libver}/providers/libgda-sqlite.so
394%{_datadir}/libgda-%{libver}/sqlite_*.xml
395%endif
396
397%if %{SYBASE}
398%files -n gda-sybase
399%{_libdir}/libgda-%{libver}/providers/libgda-sybase.so
400%endif
401
402%if %{MDB}
403%files -n gda-mdb
404%{_libdir}/libgda-%{libver}/providers/libgda-mdb.so
405%endif
406
407%if %{LDAP}
408%files -n gda-ldap
409%{_libdir}/libgda-%{libver}/providers/libgda-ldap.so
410%{_datadir}/libgda-%{libver}/ldap_*.xml
411%endif
412
413
414%changelog
415* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.9-1
416- new upstream release
417
418* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.8-1
419- new upstream release
420
421* Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.0-1
422- new upstream release
423- add Patch0 (libgda-4.2.0-disable-mdb.patch)
424- change %%{libver}
425
426* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.9-2
427- rebuild with rpm-4.8.1 for pkg-config file
428
429* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.9-1
430- new upstream release
431
432* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.8-1
433- new upstream release
434
435* Mon Nov 02 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 4.0.5-1
436- new upstream release
437- remove gnome-vfs2-devel from BR.(use gio-2.0)
438- add Vendor, Distribution and Packager.
439- update summary and description.
440
441* Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 4.0.2-3
442- rebuilt with postgresql-8.4.0
443
444* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.2-2
445- added intltool to BuildRequires.
446- rebuilt with MySQL-5.1.34.
447
448* Wed Apr 29 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 4.0.2-1
449- update from upstream.
450- update description and files.
451- ODBC,LDAP outdated
452
453* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 3.1.4-2
454- rebuilt with postgresql-8.3.3
455
456* Sun Jun 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.4-1
457- new upstream release
458- not build sharp subpackage
459- built with db4-4.6.21, MySQL-5.0.51a
460
461* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 1.9.100-0vl8
462- rebuilt with postgresql-8.2.6
463
464* Wed Sep 19 2007 Shu KONNO <owa@bg.wakwak.com> 1.9.100-0vl7
465- rebuilt with postgresql-8.2.5
466
467* Sun May 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl6
468- rebuilt with new toolchain
469
470* Wed Nov  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl5
471- rebuilt with openldap 2.3.27, MySQL 5.0.27
472- added Patch0 from Fedora
473
474* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl4
475- rebuilt with openldap-devel-2.3.24-0vl4
476
477* Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.100-0vl3
478- rebuilt with gamin-devel in place of fam-devel
479
480* Sun Apr 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl2
481- rebuilt with readline 5.1
482- added subpackage for Mono binding
483
484* Mon Jan  9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl1
485- new upstream release
486
487* Tue May 31 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
488- new upstream release
489- rebuild with postgresql-devel-8.0.3-0vl2 and sqlite3-devel
490
491* Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
492- new upstream release
493- fixed %files on devel package
494
495* Sun Aug 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.6-0vl1
496- new upstream release
497- re-define __libtoolize to compile shared object
498- updated summary
499- make sqlite package by default
500
501* Sun Mar 28 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl1
502- new upstream release
503- build with new MySQL
504- make ldap package by default
505
506* Sat Dec  6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl1
507- new upstream release
508
509* Fri Oct 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.1-0vl1
510- new upstream release
511
512* Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.0-1vl1
513- updated to 1.0.0
514- based on original spec
515- disabled smp_flag at compile time
516
517* Sun Apr 20 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.2.96-0vl3
518- added BuildPreReq: bonobo >= 1.0.9
519  (0.2.96-0vl2 seems to be lost by accident, so putting again here)
520
521* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.2.96-0vl1
522- New upstream release.
523- use gcc-2.95.3 and g++-2.95.3
524
525* Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 0.2.94-0vl1
526- New upstream release.
527
528* Fri Jan  4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 0.2.93-0vl1
529- Rebuild for Vine.
530
531* Thu May 31 2001 Serge Pavlovsky <pal@re.com.ua>
532- Cleaned
533
534* Sat Sep 2 2000 Rodrigo Moya <rodrigo@linuxave.net>
535- Initial spec imported from old GNOME-DB spec
536
Note: See TracBrowser for help on using the repository browser.