source: projects/specs/trunk/lib/libf/libfm/libfm-vl.spec @ 7800

Revision 7800, 6.4 KB checked in by kudoh, 11 years ago (diff)

--force-log

Line 
1Name: libfm
2Summary: A glib/gio-based lib used to develop file managers
3Summary(ja): ファイルマネージャー開発に用いられる glib/gio ベースのライブラリー
4Version: 1.1.2.2
5Release: 1%{?_dist_release}
6License: GPLv2+
7Group: System Environment/Libraries
8URL: http://sourceforge.net/projects/pcmanfm/
9Source0: %{name}-%{version}.tar.gz
10Patch0: libfm_customize.patch
11
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildRequires: autoconf automake
14BuildRequires: dbus-glib-devel
15BuildRequires: desktop-file-utils
16BuildRequires: fdupes
17BuildRequires: gettext
18BuildRequires: gvfs-devel
19BuildRequires: gtk-doc
20BuildRequires: gtk2-devel >= 2.16.0
21BuildRequires: glib2-devel >= 2.26.0
22BuildRequires: intltool >= 0.40
23BuildRequires: menu-cache-devel >= 0.3.2
24BuildRequires: pango-devel
25BuildRequires: perl-XML-Parser
26BuildRequires: pkgconfig
27BuildRequires: udisks-devel
28BuildRequires: vala
29
30Requires(post): /sbin/ldconfig
31Requires(postun): /sbin/ldconfig
32
33Vendor: Project Vine
34Distribution: Vine Linux
35Packager: kudoh
36
37
38%description
39A glib/gio-based lib used to develop file managers providing some
40file management utilities and related-widgets missing in gtk+/glib.
41
42%package        gtk
43Summary:        File manager-related GTK+ widgets of %{name}
44Summary(ja):    ファイルマネージャーに関連する %{name} の GTK+ ウィジェット
45Group:          System Environment/Libraries
46Requires:       %{name} = %{version}-%{release}
47Requires:       gvfs
48
49%description    gtk
50libfm is a GIO-based library used to develop file manager-like programs. It is
51developed as the core of next generation PCManFM and takes care of all file-
52related operations such as copy & paste, drag & drop, file associations or
53thumbnail support. By utilizing glib/gio and gvfs, libfm can access remote
54file systems supported by gvfs.
55
56This package provides useful file manager-related GTK+ widgets.
57
58%package        devel
59Summary:        Development files for %{name}
60Summary(ja):    %{name} の開発ファイル
61Group:          Development/Libraries
62Requires:       %{name} = %{version}-%{release}
63
64%description    devel
65The %{name}-devel package contains libraries and header files for
66developing applications that use %{name}.
67
68
69%package        gtk-devel
70Summary:        Development files for %{name}-gtk
71Summary(ja):    %{name}-gtk の開発ファイル
72Group:          Development/Libraries
73Requires:       %{name}-gtk = %{version}-%{release}
74Requires:       %{name}-devel = %{version}-%{release}
75
76%description    gtk-devel
77The %{name}-devel package contains libraries and header files for
78developing applications that use %{name}-gtk.
79
80
81%package        devel-docs
82Summary:        Development documation for %{name}
83Summary(ja):    %{name} の開発ドキュメント
84Group:          Development/Libraries
85
86%description    devel-docs
87This package containg development documentation files for %{name}.
88
89%prep
90%setup -qn libfm-%{version}
91%patch0 -p1
92
93# treak rpath
94sed -i.libdir_syssearch -e \
95  '/sys_lib_dlsearch_path_spec/s|/usr/lib |/usr/lib /usr/lib64 /lib /lib64 |' \
96  configure
97
98%build
99%configure --enable-static=no --enable-udisks --enable-gtk-doc
100make -C po -j1 GMSGFMT="msgfmt --statistics"
101make %{?_smp_mflags}
102
103
104%install
105rm -rf $RPM_BUILD_ROOT
106make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
107
108find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
109rm -f $RPM_BUILD_ROOT%{_libdir}/pkgconfig/libfm-gtk3.pc
110
111%find_lang %{name}
112
113echo '%%defattr(-,root,root,-)' > base-header.files
114echo '%%defattr(-,root,root,-)' > gtk-header.files
115for f in $RPM_BUILD_ROOT%{_includedir}/%name/%name/*.h
116do
117  bf=$(basename $f)
118  for dir in base job
119  do
120    if [ -f src/$dir/$bf ]
121    then
122      echo %_includedir/%name/%name/$bf >> base-header.files
123    fi
124  done
125  for dir in gtk
126  do
127    if [ -f src/$dir/$bf ]
128    then
129      echo %_includedir/%name/%name/$bf >> gtk-header.files
130    fi
131  done
132done
133
134/usr/lib/rpm/check-rpaths
135
136%check
137desktop-file-validate %{buildroot}/%{_datadir}/applications/*.desktop
138
139%clean
140rm -fr %{buildroot}
141
142%pre devel
143# Directory -> symlink
144if [ -d %{_includedir}/libfm ] ; then
145  rm -rf %{_includedir}/libfm
146fi
147
148%post
149/sbin/ldconfig
150update-mime-database %{_datadir}/mime &> /dev/null || :
151
152
153%postun
154/sbin/ldconfig
155update-mime-database %{_datadir}/mime &> /dev/null || :
156
157
158%post gtk -p /sbin/ldconfig
159%postun gtk -p /sbin/ldconfig
160
161%files -f %{name}.lang
162%defattr(-,root,root,-)
163%doc AUTHORS ChangeLog COPYING NEWS README
164%dir %{_sysconfdir}/xdg/libfm/
165%config(noreplace) %{_sysconfdir}/xdg/libfm/pref-apps.conf
166%config(noreplace) %{_sysconfdir}/xdg/libfm/libfm.conf
167%{_libdir}/%{name}.so.*
168%{_datadir}/mime/packages/libfm.xml
169
170
171%files gtk
172%defattr(-,root,root,-)
173%{_bindir}/libfm-pref-apps
174%{_libdir}/%{name}-gtk.so.*
175%{_datadir}/libfm/
176%{_datadir}/applications/libfm-pref-apps.desktop
177%{_mandir}/man1/libfm-pref-apps.1.gz
178
179
180%files devel -f base-header.files
181%defattr(-,root,root,-)
182%doc TODO
183%dir %{_includedir}/libfm/
184#%dir %{_includedir}/libfm-1.0/
185%{_includedir}/libfm-1.0/
186%{_libdir}/%{name}.so
187%{_libdir}/pkgconfig/libfm.pc
188
189
190%files gtk-devel -f gtk-header.files
191%defattr(-,root,root,-)
192%{_libdir}/%{name}-gtk.so
193%{_libdir}/pkgconfig/libfm-gtk.pc
194#%{_libdir}/pkgconfig/libfm-gtk3.pc
195
196
197%files devel-docs
198%defattr(-,root,root,-)
199%dir %{_datadir}/gtk-doc
200%dir %{_datadir}/gtk-doc/html
201%{_datadir}/gtk-doc/html/%{name}
202
203%changelog
204* Sun Sep 15 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.2.2-1
205- new upstream release
206
207* Sat Nov 17 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.0-2
208- rebuilt with menu-cache-0.4.1
209
210* Sat Nov 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.0-1
211- new upstream release
212- recreated patch0
213- stopped autoreconf --force --install and intltoolize --force
214- added %%configure option --enable-gtk-doc
215- runnning desktop-file-validate in %%check
216
217* Sat Sep 22 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0.1-1
218- new upstream release
219- run autoreconf --force --install and intltoolize --force
220- aded BuildRequires: vala
221
222* Tue Aug 14 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0-2
223- new upstream release
224- added BuildRequires: dbus-glib-devel
225- changed BuildRequires: glib2-devel >= 2.24.0 to 2.26.0
226- fixed BuildRequires: udisks to udisks-devel
227- added %%configure option --enable-udisks (experimental)
228
229* Tue Jul 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0rc1-1
230- new upstream release
231
232* Sun Feb 05 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.17
233- initial build for VineSeed
234
235* Sat Jan 30 2010 Oliver Burger <rpm@mandrivauser.de> 1.2-0.1git20100129.1mud2010.0
236- initial package for Mandriva Linux
Note: See TracBrowser for help on using the repository browser.