source: projects/specs/trunk/lib/libf/libfli/libfli-vl.spec @ 521

Revision 521, 2.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define majorver 1
2
3Name: libfli
4Version: 1.7
5Release: 8%{?_dist_release}
6Summary: Library for FLI CCD Camera & Filter Wheels
7
8Group: System Environment/Libraries
9# Code and LICENSE.LIB have different versions of the BSD license
10# https://sourceforge.net/tracker2/?func=detail&aid=2568511&group_id=90275&atid=593019
11License: BSD
12URL: http://indi.sourceforge.net/index.php
13
14Source0: http://downloads.sourceforge.net/indi/%{name}%{majorver}_%{version}.tar.gz
15Patch0: libfli-suffix.patch
16
17Buildroot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: cmake
19
20%description
21Finger Lakes Instrument library is used by applications to control FLI
22line of CCDs and Filter wheels
23
24%package devel
25Summary: Libraries, includes, etc. used to develop an application with %{name}
26Group: Development/Libraries
27Requires: %{name} = %{version}-%{release}
28
29%description devel
30These are the header files needed to develop a %{name} application
31
32%prep
33%setup -q -n %{name}%{majorver}-%{version}
34%patch0 -p1
35
36%build
37mkdir -p %{_target_platform}
38pushd %{_target_platform}
39CFLAGS="${CFLAGS:-%optflags}" \
40CXXFLAGS="${CXXFLAGS:-%optflags}" \
41FFLAGS="${FFLAGS:-%optflags}" \
42%cmake \
43    -DCMAKE_BUILD_TYPE=release \
44    -DDATA_INSTALL_DIR:PATH=%{_datadir} \
45    ..
46popd
47
48make VERBOSE=1 %{?_smp_mflags} -C %{_target_platform}
49
50%install
51rm -fr %{buildroot}
52make install DESTDIR=%{buildroot} -C %{_target_platform}
53
54%clean
55rm -fr %{buildroot}
56
57%post -p /sbin/ldconfig
58
59%postun -p /sbin/ldconfig
60
61%files
62%defattr(-,root,root,-)
63%doc LICENSE.BSD
64%{_libdir}/*.so.*
65
66%files devel
67%defattr(-,root,root,-)
68%{_includedir}/*
69%{_libdir}/*.so
70
71%changelog
72* Sat Sep 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> - 1.7-8
73- use %%cmake macro
74
75* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.7-7
76- Initial build for Vine Linux
77
78* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7-6
79- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
80
81* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7-5
82- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
83
84* Fri Feb 06 2009 Sergio Pascual <sergiopr at fedoraproject.org> -  1.7-4
85- Adding disttag
86
87* Thu Feb 05 2009 Sergio Pascual <sergiopr at fedoraproject.org> -  1.7-3
88- Description lines wrapped around
89- Consistent macros
90- Redownloaded source from upstream
91
92* Mon Jan 28 2009 Sergio Pascual <sergiopr at fedoraproject.org> -  1.7-2
93- Added patch to use LIB_SUFFIX
94
95* Mon Jan 28 2009 Sergio Pascual <sergiopr at fedoraproject.org> -  1.7-1
96- First specfile version
97
Note: See TracBrowser for help on using the repository browser.