source: projects/specs/trunk/lib/libf/libffi/libffi-vl.spec @ 1856

Revision 1856, 3.1 KB checked in by iwaim, 14 years ago (diff)

build with rpm-4.8.1-1; see [VineSeed:21791]

Line 
1%define name    libffi
2%define version 3.0.9
3%define release 2%{?_dist_release}
4
5Summary:        Foreign function interface library
6Summary(ja):    Foreign function interface ライブラリ
7Name:           %{name}
8Version:        %{version}
9Release:        %{release}
10Source0:        %{name}-%{version}.tar.gz
11License:        Distributable
12Group:          System Environment/Libraries
13URL:            http://sourceware.org/libffi/
14
15BuildRequires:  gcc
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18
19%description
20A foreign function interface is the popular name for the interface
21that allows code written in one language to call code written in
22another language.
23
24%description -l ja
25Foreign function interface は一般に普及しているインターフェイスで、
26ある言語で書かれたコードから、他の言語で書かれたコードを呼び出すこ
27とを可能にします。
28
29#-----------------------------------------------------------------------------
30
31%package devel
32Summary:        Libraries and headers for %{name}
33Summary(ja):    %{name} 用の開発ライブラリおよびヘッダファイル
34Group:          Development/Libraries
35Requires:       %{name} = %{version}
36
37%description devel
38This package includes the files needed for developing and compiling
39applications which use the ffi library.
40
41You should install the libffi-devel package if you would like to
42develop applications using libffi.
43
44%description devel -l ja
45このパッケージは ffi ライブラリを使用するアプリケーションを開発
46するのに必要なライブラリやヘッダファイルを含んでいます。
47
48libffi を使用したアプリケーションを開発するなら、このパッケージ
49をインストールしてください。
50
51#-----------------------------------------------------------------------------
52
53
54%prep
55
56%setup -q
57
58
59%build
60%configure
61%{__make}
62
63
64%install
65%{__rm} -rf ${RPM_BUILD_ROOT}
66%{__make} install DESTDIR=${RPM_BUILD_ROOT}
67
68# move include files.
69%{__mv} ${RPM_BUILD_ROOT}/%{_libdir}/libffi-%{version}/include ${RPM_BUILD_ROOT}/%{_includedir}
70
71# remove unnecessary files.
72%{__rm} -rf ${RPM_BUILD_ROOT}/%{_libdir}/libffi.la
73%{__rm} -rf ${RPM_BUILD_ROOT}/%{_infodir}/dir
74
75%clean
76%{__rm} -rf ${RPM_BUILD_ROOT}
77
78%post -p /sbin/ldconfig
79
80%postun -p /sbin/ldconfig
81
82
83%files
84%defattr(-,root,root)
85%doc ChangeLog* LICENSE README 
86%{_libdir}/libffi.so.*
87%{_infodir}/libffi.info*
88%{_mandir}/man3/ffi.3*
89%{_mandir}/man3/ffi_call.3*
90%{_mandir}/man3/ffi_prep_cif.3*
91
92%files devel
93%defattr(-,root,root)
94%{_libdir}/pkgconfig/*
95%{_libdir}/libffi.a
96%{_libdir}/libffi.so
97%{_includedir}/*.h
98
99
100%changelog
101* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 3.0.9-2
102- build with rpm-4.8.1-1 for pkg-config file
103
104* Tue Feb 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.0.9-1
105- new upstream release
106- built with new toolchain
107
108* Wed Jan 21 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.0.8-1
109- new upstream release
110- spec in UTF-8
111
112* Thu Apr 17 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.0.5-1
113- updated to new upstream release
114
115* Wed Apr 02 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.0.4-1
116- apply new versioning policy
117
118* Sun Mar 02 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.0.4-0vl1
119- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.