source: projects/specs/trunk/lib/libf/libffi/libffi-vl.spec @ 11307

Revision 11307, 5.6 KB checked in by tomop, 6 years ago (diff)

libffi-3.2.1-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define name    libffi
4%define version 3.2.1
5%define release 1%{?_dist_release}
6
7Summary:        Foreign function interface library
8Summary(ja):    Foreign function interface ライブラリ
9Name:           %{name}
10Version:        %{version}
11Release:        %{release}
12Source0:        ftp://sourceware.org/pub/libffi/%{name}-%{version}.tar.gz
13Patch0:         libffi-3.1-fix-include-path.patch
14License:        Distributable
15Group:          System Environment/Libraries
16URL:            http://sourceware.org/libffi/
17
18BuildRequires:  gcc
19BuildRequires:  texinfo
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21
22Vendor: Project Vine
23Distribution: Vine Linux
24
25%description
26A foreign function interface is the popular name for the interface
27that allows code written in one language to call code written in
28another language.
29
30%description -l ja
31Foreign function interface は一般に普及しているインターフェイスで、
32ある言語で書かれたコードから、他の言語で書かれたコードを呼び出すこ
33とを可能にします。
34
35#-----------------------------------------------------------------------------
36
37%package devel
38Summary:        Libraries and headers for %{name}
39Summary(ja):    %{name} 用の開発ライブラリおよびヘッダファイル
40Group:          Development/Libraries
41Requires:       %{name} = %{version}
42Requires:       pkgconfig
43
44%description devel
45This package includes the files needed for developing and compiling
46applications which use the ffi library.
47
48You should install the libffi-devel package if you would like to
49develop applications using libffi.
50
51%description devel -l ja
52このパッケージは ffi ライブラリを使用するアプリケーションを開発
53するのに必要なライブラリやヘッダファイルを含んでいます。
54
55libffi を使用したアプリケーションを開発するなら、このパッケージ
56をインストールしてください。
57
58#compat32
59%package -n compat32-%{name}
60Summary:        Foreign function interface library
61Summary(ja):    Foreign function interface ライブラリ
62Group:          System Environment/Libraries
63Requires:       %{name} = %{version}
64
65%description -n compat32-%{name}
66A foreign function interface is the popular name for the interface
67that allows code written in one language to call code written in
68another language.
69
70%description -n compat32-%{name} -l ja
71Foreign function interface は一般に普及しているインターフェイスで、
72ある言語で書かれたコードから、他の言語で書かれたコードを呼び出すこ
73とを可能にします。
74
75%package -n compat32-%{name}-devel
76Summary:        Libraries and headers for %{name}
77Summary(ja):    %{name} 用の開発ライブラリおよびヘッダファイル
78Group:          Development/Libraries
79Requires:       compat32-%{name} = %{version}
80Requires:       %{name}-devel = %{version}
81
82%description -n compat32-%{name}-devel
83This package includes the files needed for developing and compiling
84applications which use the ffi library.
85
86You should install the libffi-devel package if you would like to
87develop applications using libffi.
88
89%description -n compat32-%{name}-devel -l ja
90このパッケージは ffi ライブラリを使用するアプリケーションを開発
91するのに必要なライブラリやヘッダファイルを含んでいます。
92
93libffi を使用したアプリケーションを開発するなら、このパッケージ
94をインストールしてください。
95
96#-----------------------------------------------------------------------------
97
98
99%prep
100
101%setup -q
102%patch0 -p1
103
104%build
105autoreconf -ifv
106%configure
107%{__make}
108
109
110%install
111%{__rm} -rf ${RPM_BUILD_ROOT}
112%{__make} install DESTDIR=${RPM_BUILD_ROOT}
113
114# move include files.
115%{__mv} ${RPM_BUILD_ROOT}/%{_libdir}/libffi-%{version}/include ${RPM_BUILD_ROOT}/%{_includedir}
116sed -i -e "s|^includedir=.*include$|includedir=%{_includedir}|" \
117        ${RPM_BUILD_ROOT}/%{_libdir}/pkgconfig/libffi.pc
118
119# remove unnecessary files.
120%{__rm} -rf ${RPM_BUILD_ROOT}/%{_libdir}/libffi.la
121%{__rm} -rf ${RPM_BUILD_ROOT}/%{_infodir}/dir
122
123%clean
124%{__rm} -rf ${RPM_BUILD_ROOT}
125
126%post -p /sbin/ldconfig
127
128%postun -p /sbin/ldconfig
129
130
131%files
132%defattr(-,root,root)
133%doc ChangeLog* LICENSE README 
134%{_libdir}/libffi.so.*
135%{_infodir}/libffi.info*
136%{_mandir}/man3/ffi.3*
137%{_mandir}/man3/ffi_call.3*
138%{_mandir}/man3/ffi_prep_cif.3*
139%{_mandir}/man3/ffi_prep_cif_var.3*
140
141%files devel
142%defattr(-,root,root)
143%{_libdir}/pkgconfig/*
144%{_libdir}/libffi.a
145%{_libdir}/libffi.so
146%{_includedir}/*.h
147
148# compat32
149%if %{build_compat32}
150%files -n compat32-%{name}
151%defattr(-,root,root)
152%{_libdir}/libffi.so.*
153
154%files -n compat32-%{name}-devel
155%defattr(-,root,root)
156%{_libdir}/libffi.so
157%endif
158
159%changelog
160* Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.1-1
161- updated to 3.2.1.
162- imported Patch0 from rawhide.
163
164* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.13-1
165- update to 3.0.13
166
167* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.9-4
168- create compat32 sub packages
169
170* Fri Nov 26 2010 Shu KONNO <owa@bg.wakwak.com> 3.0.9-3
171- fixed includedir in libffi.pc
172
173* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 3.0.9-2
174- build with rpm-4.8.1-1 for pkg-config file
175
176* Tue Feb 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.0.9-1
177- new upstream release
178- built with new toolchain
179
180* Wed Jan 21 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.0.8-1
181- new upstream release
182- spec in UTF-8
183
184* Thu Apr 17 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.0.5-1
185- updated to new upstream release
186
187* Wed Apr 02 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.0.4-1
188- apply new versioning policy
189
190* Sun Mar 02 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.0.4-0vl1
191- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.