source: projects/specs/trunk/lib/libf/libffi/libffi-vl.spec @ 8758

Revision 8758, 5.4 KB checked in by Takemikaduchi, 10 years ago (diff)

update or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define name    libffi
4%define version 3.0.13
5%define release 1%{?_dist_release}
6
7Summary:        Foreign function interface library
8Summary(ja):    Foreign function interface ライブラリ
9Name:           %{name}
10Version:        %{version}
11Release:        %{release}
12Source0:        ftp://sourceware.org/pub/libffi/%{name}-%{version}.tar.gz
13License:        Distributable
14Group:          System Environment/Libraries
15URL:            http://sourceware.org/libffi/
16
17BuildRequires:  gcc
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19
20Vendor: Project Vine
21Distribution: Vine Linux
22
23%description
24A foreign function interface is the popular name for the interface
25that allows code written in one language to call code written in
26another language.
27
28%description -l ja
29Foreign function interface は一般に普及しているインターフェイスで、
30ある言語で書かれたコードから、他の言語で書かれたコードを呼び出すこ
31とを可能にします。
32
33#-----------------------------------------------------------------------------
34
35%package devel
36Summary:        Libraries and headers for %{name}
37Summary(ja):    %{name} 用の開発ライブラリおよびヘッダファイル
38Group:          Development/Libraries
39Requires:       %{name} = %{version}
40Requires:       pkgconfig
41
42%description devel
43This package includes the files needed for developing and compiling
44applications which use the ffi library.
45
46You should install the libffi-devel package if you would like to
47develop applications using libffi.
48
49%description devel -l ja
50このパッケージは ffi ライブラリを使用するアプリケーションを開発
51するのに必要なライブラリやヘッダファイルを含んでいます。
52
53libffi を使用したアプリケーションを開発するなら、このパッケージ
54をインストールしてください。
55
56#compat32
57%package -n compat32-%{name}
58Summary:        Foreign function interface library
59Summary(ja):    Foreign function interface ライブラリ
60Group:          System Environment/Libraries
61Requires:       %{name} = %{version}
62
63%description -n compat32-%{name}
64A foreign function interface is the popular name for the interface
65that allows code written in one language to call code written in
66another language.
67
68%description -n compat32-%{name} -l ja
69Foreign function interface は一般に普及しているインターフェイスで、
70ある言語で書かれたコードから、他の言語で書かれたコードを呼び出すこ
71とを可能にします。
72
73%package -n compat32-%{name}-devel
74Summary:        Libraries and headers for %{name}
75Summary(ja):    %{name} 用の開発ライブラリおよびヘッダファイル
76Group:          Development/Libraries
77Requires:       compat32-%{name} = %{version}
78Requires:       %{name}-devel = %{version}
79
80%description -n compat32-%{name}-devel
81This package includes the files needed for developing and compiling
82applications which use the ffi library.
83
84You should install the libffi-devel package if you would like to
85develop applications using libffi.
86
87%description -n compat32-%{name}-devel -l ja
88このパッケージは ffi ライブラリを使用するアプリケーションを開発
89するのに必要なライブラリやヘッダファイルを含んでいます。
90
91libffi を使用したアプリケーションを開発するなら、このパッケージ
92をインストールしてください。
93
94#-----------------------------------------------------------------------------
95
96
97%prep
98
99%setup -q
100
101
102%build
103%configure
104%{__make}
105
106
107%install
108%{__rm} -rf ${RPM_BUILD_ROOT}
109%{__make} install DESTDIR=${RPM_BUILD_ROOT}
110
111# move include files.
112%{__mv} ${RPM_BUILD_ROOT}/%{_libdir}/libffi-%{version}/include ${RPM_BUILD_ROOT}/%{_includedir}
113sed -i -e "s|^includedir=.*include$|includedir=%{_includedir}|" \
114        ${RPM_BUILD_ROOT}/%{_libdir}/pkgconfig/libffi.pc
115
116# remove unnecessary files.
117%{__rm} -rf ${RPM_BUILD_ROOT}/%{_libdir}/libffi.la
118%{__rm} -rf ${RPM_BUILD_ROOT}/%{_infodir}/dir
119
120%clean
121%{__rm} -rf ${RPM_BUILD_ROOT}
122
123%post -p /sbin/ldconfig
124
125%postun -p /sbin/ldconfig
126
127
128%files
129%defattr(-,root,root)
130%doc ChangeLog* LICENSE README 
131%{_libdir}/libffi.so.*
132%{_infodir}/libffi.info*
133%{_mandir}/man3/ffi.3*
134%{_mandir}/man3/ffi_call.3*
135%{_mandir}/man3/ffi_prep_cif.3*
136%{_mandir}/man3/ffi_prep_cif_var.3*
137
138%files devel
139%defattr(-,root,root)
140%{_libdir}/pkgconfig/*
141%{_libdir}/libffi.a
142%{_libdir}/libffi.so
143%{_includedir}/*.h
144
145# compat32
146%if %{build_compat32}
147%files -n compat32-%{name}
148%defattr(-,root,root)
149%{_libdir}/libffi.so.*
150
151%files -n compat32-%{name}-devel
152%defattr(-,root,root)
153%{_libdir}/libffi.so
154%endif
155
156%changelog
157* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.13-1
158- update to 3.0.13
159
160* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.9-4
161- create compat32 sub packages
162
163* Fri Nov 26 2010 Shu KONNO <owa@bg.wakwak.com> 3.0.9-3
164- fixed includedir in libffi.pc
165
166* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 3.0.9-2
167- build with rpm-4.8.1-1 for pkg-config file
168
169* Tue Feb 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.0.9-1
170- new upstream release
171- built with new toolchain
172
173* Wed Jan 21 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.0.8-1
174- new upstream release
175- spec in UTF-8
176
177* Thu Apr 17 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.0.5-1
178- updated to new upstream release
179
180* Wed Apr 02 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.0.4-1
181- apply new versioning policy
182
183* Sun Mar 02 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.0.4-0vl1
184- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.