source: projects/specs/trunk/lib/libe/libexo/libexo-vl.spec @ 8068

Revision 8068, 6.1 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define srcname exo
2
3Summary: extension library to Xfce
4Summary(ja): Xfce の拡張ライブラリ
5Name: libexo
6Version: 0.8.0
7Release: 2%{?_dist_release}
8
9Group: System Environment/Libraries
10License: LGPLv2
11URL: http://www.xfce.org/
12
13Source0: http://archive.xfce.org/src/xfce/exo/0.8/%{srcname}-%{version}.tar.bz2
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: glib2-devel >= 2.27.0
17BuildRequires: gtk2-devel >= 2.14.0
18BuildRequires: libSM-devel
19BuildRequires: intltool >= 0.31
20BuildRequires: libxfce4util-devel >= 4.10.0
21BuildRequires: libxfce4ui-devel >= 4.10.0
22BuildRequires: libnotify-devel >= 0.4.0
23BuildRequires: python-devel
24BuildRequires: pygtk2-devel
25BuildRequires: perl-URI
26BuildRequires: chrpath
27Requires(post): gtk2
28Requires(postun): gtk2
29
30Provides: %{srcname} = %{version}-%{release}
31
32Vendor: Project Vine
33Distribution: Vine Linux
34
35%description
36libexo is the extension library to Xfce developed by os-cillation.
37While Xfce ships with quite a few libraries that are primarly targeted
38at desktop development, libexo is targeted at application development,
39with a focus on applications for Xfce.
40
41%description -l ja
42libexo は os-cillation により開発された Xfce の拡張ライブラリです.
43Xfce はデスクトップ環境の開発を第一の目的としたごくわずかのライブラリ
44と共に作成されていますが,libexo はアプリケーションの開発,それも
45Xfce 用のアプリケーション開発に焦点を定めています.
46
47%package -n %{name}-devel
48Summary: Header files and libraries for developing apps which will use %{name}
49Summary(ja): libexo の開発用ヘッダファイル及びライブラリ
50Group: Development/Libraries
51Requires: %{name} = %{version}-%{release}
52Requires: gtk2-devel >= 2.6.0
53Requires: libxfce4util-devel >= 4.10.0
54Requires: libxfce4ui-devel >= 4.10.0
55Provides: %{srcname}-devel = %{version}-%{release}
56
57%description -n %{name}-devel
58The libexo-devel package contains the header files and libraries needed
59to develop programs that use the libexo library.
60
61%description -n %{name}-devel -l ja
62libexo-develはlibexoライブラリを用いるプログラムの開発に
63必要なヘッダファイル及びライブラリを含むパッケージです。
64
65%prep
66%setup -q -n %{srcname}-%{version}
67
68%build
69%configure --disable-static
70%__make
71
72%install
73rm -rf $RPM_BUILD_ROOT
74make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
75
76rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
77rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
78
79chrpath --delete $RPM_BUILD_ROOT%{_bindir}/exo-desktop-item-edit
80chrpath --delete $RPM_BUILD_ROOT%{_bindir}/exo-open
81chrpath --delete $RPM_BUILD_ROOT%{_libdir}/xfce4/exo-*/exo-helper-*
82#chrpath --delete $RPM_BUILD_ROOT%{_libdir}/python*/site-packages/exo-*/_exo.so
83#chrpath --delete $RPM_BUILD_ROOT%{_libdir}/gio/modules/libexo-module-*.so
84
85%find_lang exo-1
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%post
91/sbin/ldconfig
92touch --no-create %{_datadir}/icons/hicolor
93
94%postun
95/sbin/ldconfig
96if [ $1 -eq 0 ]; then
97    touch --no-create %{_datadir}/icons/hicolor
98    /usr/bin/gtk-update-icon-cache -qf %{_datadir}/icons/hicolor;
99fi
100
101%posttrans
102gtk-update-icon-cache %{_iconsdir}/icons/hicolor &> /dev/null || :
103
104
105%files -f exo-1.lang
106%defattr(-,root,root)
107%doc AUTHORS COPYING ChangeLog README THANKS TODO
108%config(noreplace) %{_sysconfdir}/xdg/xfce4/helpers.rc
109%{_bindir}/*
110%{_libdir}/lib*.so.*
111%{_libdir}/xfce4/*
112%{_datadir}/applications/*.desktop
113%{_datadir}/icons/hicolor/*/apps/*.png
114%{_datadir}/pixmaps/exo-1
115%{_datadir}/xfce4/helpers
116%{_mandir}/man1/*
117
118%files -n %{name}-devel
119%defattr(-,root,root)
120%{_libdir}/lib*.so
121%{_libdir}/pkgconfig/*.pc
122%{_includedir}/exo-1
123%{_datadir}/gtk-doc/html/exo-1
124
125%changelog
126* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-2
127- rebuild with VineSeed environment
128
129* Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
130- new upstrem release
131- remove Patch0
132- add BuildRequires: libxfce4ui-devel
133
134* Mon May 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.1-1
135- new upstrem release
136
137* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.0-2
138- add BuildRequires: libSM-devel
139
140* Mon Mar 28 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.0-1
141- new upstrem release
142
143* Thu Sep 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.107-2
144- rebuilt with rpm-4.8.1 for pkg-config
145
146* Sun May 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.107-1
147- new upstrem release
148- built with new toolchain
149
150* Mon Feb  8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.106-1
151- new upstrem release
152- added BR: perl-URI
153
154* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.3.105-2
155- rebuilt with python-2.6.4
156
157* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.105-1
158- new upstrem release
159
160* Fri May 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.101-1
161- new upstrem release
162- removed lib*.a from devel package
163
164* Sun Aug 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.4-1
165- applied with new versioning policy
166- spec in UTF-8
167
168* Fri Jan 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.3.4-0vl3
169- add BuildRequires: libnotify >= 0.4.0, xfce-mcs-plugins >= 4.2.2
170
171* Sun Dec 23 2007 UECHI Yasumasa <uechi@potaway.net> 0.3.4-0vl2
172- new upstream release.
173
174* Sun Jul 29 2007 UECHI Yasumasa <uechi@potaway.net> 0.3.2-0vl2
175- build for VineSeed
176
177* Sat Jul 28 2007 UECHI Yasumasa <uechi@potaway.net> 0.3.2-0vl1
178- new upstream version
179- add %{_sysconfdir}/xdg/xfce4/helpers.rc in files section.
180- add %{_bindir}/* in files section.
181- add %{_libdir}/xfce4 in files section.
182- add %{_libexecdir}/* in files section.
183- add %{_datadir}/icons/hicolor/*/apps/*.png in files section.
184- add %{_mandir}/man1/* in files section.
185- add %{_datadir}/xfce4/doc/*/* in files section.
186- add %{_datadir}/xfce4/helpers in files section.
187- remove %{_datadir}/gtk-doc/html/exo in files section.
188- update icon-cache in %post and %postun.
189
190* Fri Aug 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl3
191- changed Group to System Environment/Libraires
192- changed devel Group to Development/Libraries
193- added %post and %postun section
194
195* Fri Apr 22 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.3.0-0vl2
196- rebuild for VineSeed
197
198* Sun Apr 17 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.3.0-0vl1
199- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.