source: projects/specs/trunk/lib/libe/libexo/libexo-vl.spec @ 9879

Revision 9879, 6.5 KB checked in by inagaki, 8 years ago (diff)

2015-12-20 Ryoichi INAGAKI <ryo1@…>

  • libexo, parole, xfce4-pulseaudio-plugin, xfce4-weather-plugin: updated


Line 
1%define srcname exo
2
3Summary: Extension library to Xfce
4Summary(ja): Xfce の拡張ライブラリ
5Name: libexo
6Version: 0.10.7
7Release: 1%{?_dist_release}
8
9Group: System Environment/Libraries
10License: LGPLv2+ and GPLv2+
11URL: http://www.xfce.org/
12
13Source0: http://archive.xfce.org/src/xfce/exo/0.10/%{srcname}-%{version}.tar.bz2
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: glib2-devel >= 2.30.0
17BuildRequires: gtk2-devel >= 2.24.0
18BuildRequires: libSM-devel
19BuildRequires: intltool
20BuildRequires: libxfce4util-devel >= 4.10.0
21BuildRequires: libxfce4ui-devel >= 4.10.0
22BuildRequires: perl-URI
23BuildRequires: chrpath
24Requires(post): gtk2
25Requires(postun): gtk2
26
27Provides: %{srcname} = %{version}-%{release}
28
29Vendor: Project Vine
30Distribution: Vine Linux
31
32%description
33libexo is the extension library to Xfce developed by os-cillation.
34While Xfce ships with quite a few libraries that are primarly targeted
35at desktop development, libexo is targeted at application development,
36with a focus on applications for Xfce.
37
38%description -l ja
39libexo は os-cillation により開発された Xfce の拡張ライブラリです.
40Xfce はデスクトップ環境の開発を第一の目的としたごくわずかのライブラリ
41と共に作成されていますが,libexo はアプリケーションの開発,それも
42Xfce 用のアプリケーション開発に焦点を定めています.
43
44%package -n %{name}-devel
45Summary: Header files and libraries for developing apps which will use %{name}
46Summary(ja): libexo の開発用ヘッダファイル及びライブラリ
47Group: Development/Libraries
48Requires: %{name} = %{version}-%{release}
49Requires: gtk2-devel >= 2.24.0
50Requires: libxfce4util-devel >= 4.10.0
51Requires: libxfce4ui-devel >= 4.10.0
52Provides: %{srcname}-devel = %{version}-%{release}
53
54%description -n %{name}-devel
55The libexo-devel package contains the header files and libraries needed
56to develop programs that use the libexo library.
57
58%description -n %{name}-devel -l ja
59libexo-devel は libexo ライブラリを用いるプログラムの開発に
60必要なヘッダファイル及びライブラリを含むパッケージです。
61
62%prep
63%setup -q -n %{srcname}-%{version}
64
65%build
66%configure --disable-static
67
68make %{?_smp_mflags}
69
70%install
71rm -rf $RPM_BUILD_ROOT
72make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
73
74rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
75rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
76
77chrpath --delete $RPM_BUILD_ROOT%{_bindir}/exo-desktop-item-edit
78chrpath --delete $RPM_BUILD_ROOT%{_bindir}/exo-open
79chrpath --delete $RPM_BUILD_ROOT%{_libdir}/xfce4/exo-*/exo-helper-*
80
81%find_lang exo-1
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%post
87/sbin/ldconfig
88touch --no-create %{_datadir}/icons/hicolor
89
90%postun
91/sbin/ldconfig
92if [ $1 -eq 0 ]; then
93    touch --no-create %{_datadir}/icons/hicolor
94    /usr/bin/gtk-update-icon-cache -qf %{_datadir}/icons/hicolor;
95fi
96
97%posttrans
98gtk-update-icon-cache %{_iconsdir}/icons/hicolor &> /dev/null || :
99
100
101%files -f exo-1.lang
102%defattr(-,root,root)
103%doc AUTHORS COPYING COPYING.LIB ChangeLog README THANKS TODO
104%config(noreplace) %{_sysconfdir}/xdg/xfce4/helpers.rc
105%{_bindir}/*
106%{_libdir}/lib*.so.*
107%{_libdir}/xfce4/*
108%{_datadir}/applications/*.desktop
109%{_datadir}/icons/hicolor/*/*/*.png
110%{_datadir}/pixmaps/exo-1
111%{_datadir}/xfce4/helpers
112%{_mandir}/man1/*
113
114%files -n %{name}-devel
115%defattr(-,root,root)
116%{_libdir}/lib*.so
117%{_libdir}/pkgconfig/*.pc
118%{_includedir}/exo-1
119%{_datadir}/gtk-doc/html/exo-1
120
121%changelog
122* Sat Nov 14 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.10.7-1
123- new upstream release
124
125* Thu Jun  4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.10.6-1
126- new upstream release
127- fixed License (some binaries are licensed under GPLv2+)
128
129* Thu Mar 19 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.10.4-1
130- new upstream release
131
132* Sat Feb 28 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.10.3-1
133- new upstrem release
134- removed BR: libnotify-devel, python-devel and pygtk2-devel
135
136* Thu Aug 28 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.10.2-1
137- new upstrem release
138
139* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-2
140- rebuild with VineSeed environment
141
142* Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
143- new upstrem release
144- remove Patch0
145- add BuildRequires: libxfce4ui-devel
146
147* Mon May 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.1-1
148- new upstrem release
149
150* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.0-2
151- add BuildRequires: libSM-devel
152
153* Mon Mar 28 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.0-1
154- new upstrem release
155
156* Thu Sep 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.107-2
157- rebuilt with rpm-4.8.1 for pkg-config
158
159* Sun May 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.107-1
160- new upstrem release
161- built with new toolchain
162
163* Mon Feb  8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.106-1
164- new upstrem release
165- added BR: perl-URI
166
167* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.3.105-2
168- rebuilt with python-2.6.4
169
170* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.105-1
171- new upstrem release
172
173* Fri May 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.101-1
174- new upstrem release
175- removed lib*.a from devel package
176
177* Sun Aug 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.4-1
178- applied with new versioning policy
179- spec in UTF-8
180
181* Fri Jan 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.3.4-0vl3
182- add BuildRequires: libnotify >= 0.4.0, xfce-mcs-plugins >= 4.2.2
183
184* Sun Dec 23 2007 UECHI Yasumasa <uechi@potaway.net> 0.3.4-0vl2
185- new upstream release.
186
187* Sun Jul 29 2007 UECHI Yasumasa <uechi@potaway.net> 0.3.2-0vl2
188- build for VineSeed
189
190* Sat Jul 28 2007 UECHI Yasumasa <uechi@potaway.net> 0.3.2-0vl1
191- new upstream version
192- add %{_sysconfdir}/xdg/xfce4/helpers.rc in files section.
193- add %{_bindir}/* in files section.
194- add %{_libdir}/xfce4 in files section.
195- add %{_libexecdir}/* in files section.
196- add %{_datadir}/icons/hicolor/*/apps/*.png in files section.
197- add %{_mandir}/man1/* in files section.
198- add %{_datadir}/xfce4/doc/*/* in files section.
199- add %{_datadir}/xfce4/helpers in files section.
200- remove %{_datadir}/gtk-doc/html/exo in files section.
201- update icon-cache in %post and %postun.
202
203* Fri Aug 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl3
204- changed Group to System Environment/Libraires
205- changed devel Group to Development/Libraries
206- added %post and %postun section
207
208* Fri Apr 22 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.3.0-0vl2
209- rebuild for VineSeed
210
211* Sun Apr 17 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.3.0-0vl1
212- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.